Subject: Re: [idn] Cherokee letters look like uppercase Latin letters

From: John C Klensin <[email-masked]>
Date: Thu, 26 Jul 2001 13:50:08 -0400

--On Thursday, 26 July, 2001 17:44 +0900 Soobok Lee
<[email-masked]> wrote:

> The initial ascii domain idea  was not a mistake, but a
> practical choice  in so early stage of the internet when  
> we had no standard for UNICODE-like universal character set .

Without getting involved in the other issues in this thread, the
above statement might be historically misleading although it is
correct.  

The original decisions came in  more than one stage, and predated
the Internet by some years.  In at least one of those cases,
internationalization issues were explicitly considered
--obviously in the context of things that evolved into ISO 646
national variants, rather than Unicode-- and the conclusion was
to focus the identifier character set on a set of characters that
was as common, broadly available, and usable at the time.  The
usability discussions considered issues very similar to those we
have discussed, including transcription from other media
(including hand-written text).  

The choice of that ASCII subset was reasonable --for identifier,
not language-- purposes at the time, but obviously is not
appropriate if one is dealing with people or devices that can't
render ASCII characters.

But at no time where non-"hostname" or non-ASCII characters
ignored in the process.  The decisions were made on the basis
that the names were identifiers, that they would rarely be seen
by ordinary users, that absolute precision of the identifiers was
a requirement, and that all users who did need to look at the
names would be able to create and render ASCII-subset characters.
We are having the discussions we are today because changes in
Internet protocols and usage patterns have called some of those
assumptions into question.

    john

---

From: "Soobok Lee" <[email-masked]>
Date: Thu, 26 Jul 2001 18:19:22 +0900

http://www.unicode.org/unicode/standard/unsupported.html will help us
to find that UNICODE 3.1 does not contain all the modern scripts that
may be added in near future.

Soobok Lee
-------------------------------------------------

Modern Scripts
The following scripts in current use in living communities are not yet
supported in Unicode. Extensions to Unicode (and ISO/IEC 10646) which
will address the needs of these scripts are being developed and
evaluated by both the Unicode Technical Committee and by ISO JTC1/SC2/WG2.
See Proposed New Scripts for details.

Kirat (Limbu)
Manipuri (Meithei, Kanglei)
Moso (Naxi)
Pahawh Hmong
Rong (Lepcha)
Tai Lu
Tai Mau
Tifinagh

Scripts awaiting approval or proposed

Philippine Scripts

Tagalog
Hanunoo
Buhid
Tagbanwa

Cham
Tai (Dai) scripts
Glagolitic
Coptic
Buginese
Old Hungarian
Phoenician
Avestan
Tifinagh (Berber)
Javanese
Lepcha (Rong)
For Plane 1 (surrogates)

Basic Egyptian Hieroglyphics
Meroitic
Old Persian Cuneiform
Ugaritic Cuneiform
Tengwar
Cirth
tlhIngan Hol
Brahmi
Old Permic
South Arabian
Pollard
Blissymbolics
Soyombo
Last updated 27-March-2001

----- Original Message -----
From: "Soobok Lee" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 26, 2001 5:44 PM
Subject: Re: [idn] Cherokee letters look like uppercase Latin letters

> Uppercase Latin 'A' is case-folded into latin 'a'.
> Cyrillic 'A' is also case-folded into cyrillic 'a'.
> (latin 'a' and cyrillic 'a' still look the same.)
>
> But Cherokee 'A' has no lowercase letter for it.
>
> Prefix-based Versioning on ACE may help to ease this situation around
> Cherokee and new scripts blocks to be added to UCS
> in the future.
>
> For future script additions to UCS ,we have no nameprep rules now.
> As long as we should enforce current NAMEPREP rules, we are also prohibiting
> future script additions from being used in IDN that will have to be
nameprepped
> by the future versions of ACE and NAMEPREP rules.
>
> http://www.unicode.org/unicode/alloc/Pipeline.html will help to guess
> the agenda for future ACE and NAMEPREP versioning.
>
> Regards, Soobok Lee
>
> ----- Original Message -----
> From: "Yves Arrouye" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, July 26, 2001 4:25 PM
> Subject: RE: [idn] Cherokee letters look like uppercase Latin letters
>
>
> >
> > > Do we need to allow Cherokee letters in IDN?
> >
> > It would be quite bad to deny access to IDN to one population, yes! After
> > all, we're internationalizing DNS because some populations have been left
> > over initially and we want to fix that.
> >
> > I find very interesting (and ironic) to see these suggestions about
> > removing characters whose glyphs may confuse some people. It is a similar
> > reasoning that led to the choice of the initial set of characters allowed
> > in DNS labels, and I am sure that in the world of then, complex scripts or
> > even exotic scripts would have been dismissed for fear of confusion for the
> > typical user. Are you really seriously suggesting to do the same mistake
> > again, but with different populations?!
> >
> > YA
> >
>
>

---

From: "Soobok Lee" <[email-masked]>
Date: Thu, 26 Jul 2001 17:44:02 +0900

For future script additions to UCS ,we have no nameprep rules now.
As long as we should enforce current NAMEPREP rules, we are also prohibiting
future script additions from being used in IDN that will have to be nameprepped
by the future versions of ACE and NAMEPREP rules.

Regards, Soobok Lee

---

From: Yves Arrouye <[email-masked]>
Date: Thu, 26 Jul 2001 00:25:55 -0700

YA

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 27 Jul 2001 00:04:40 +0200

--On 01-07-26 17.44 +0900 Soobok Lee <[email-masked]> wrote:

> As long as we should enforce current NAMEPREP rules, we are also
> prohibiting future script additions from being used in IDN that will have
> to be nameprepped by the future versions of ACE and NAMEPREP rules.

No, the versioning issues are explicitly described in the nameprep
document. See how to take care of versioning and unassigned codepoints.

It might be wrong, but we have some text talking about it.

  paf