Subject: [idn] Mail reliability

From: Martin Duerst <[email-masked]>
Date: Wed, 18 Jul 2001 00:17:10 +0900

<sneak>Just a side remark. Given things like below, which I see daily,
I don't think that using UTF-8 in mail headers will cause much more
problems.</sneak>

Regards,   Martin.

At 08:11 01/07/17 -0700, Mail Delivery Subsystem wrote:
>The original message was received at Tue, 17 Jul 2001 08:11:23 -0700 (PDT)
>from localhost [127.0.0.1]
>
>    ----- The following addresses had permanent fatal errors -----
><[email-masked]>
>     (reason: 550 5.1.1 <[email-masked]>... User unknown)
>
>    ----- Transcript of session follows -----
>... while talking to sj-msg-core-4.cisco.com.:
> >>> RCPT To:<[email-masked]>
><<< 550 5.1.1 <[email-masked]>... User unknown
>550 5.1.1 <[email-masked]>... User unknown
>Reporting-MTA: dns; sj-msg-av-1.cisco.com
>Received-From-MTA: DNS; localhost
>Arrival-Date: Tue, 17 Jul 2001 08:11:23 -0700 (PDT)
>
>Final-Recipient: RFC822; [email-masked]
>Action: failed
>Status: 5.1.1
>Remote-MTA: DNS; sj-msg-core-4.cisco.com
>Diagnostic-Code: SMTP; 550 5.1.1 <[email-masked]>... User unknown
>Last-Attempt-Date: Tue, 17 Jul 2001 08:11:27 -0700 (PDT)
>Return-Path: <[email-masked]>
>Received: from proxy3.cisco.com (localhost [127.0.0.1])
>         by sj-msg-av-1.cisco.com (8.10.1/8.10.1) with ESMTP id f6HFBNR28562
>         for <[email-masked]>; Tue, 17 Jul 2001 08:11:23 -0700 (PDT)
>Received: from sh.w3.mag.keio.ac.jp (sh.w3.mag.keio.ac.jp [133.27.194.41])
>         by proxy3.cisco.com (8.11.2/8.11.2) with ESMTP id f6HFBn402614
>         for <[email-masked]>; Tue, 17 Jul 2001 08:11:50 -0700 (PDT)
>Received: from enoshima (g055087.ppp.asahi-net.or.jp [211.132.55.87])
>         by sh.w3.mag.keio.ac.jp (8.9.3/3.7W) with ESMTP id AAA10384;
>         Wed, 18 Jul 2001 00:11:24 +0900 (JST)
>Message-Id: <[email-masked]>
>X-Sender: [email-masked]
>X-Mailer: QUALCOMM Windows Eudora Pro Version 4.2.0.58.J
>Date: Wed, 18 Jul 2001 00:10:52 +0900
>To: Patrik F$BgM(Btstr$B‹N(B <[email-masked]>,Russ Rolfe 
><[email-masked]>, [email-masked]
>From: Martin Duerst <[email-masked]>
>Subject: Re: Just send UTF-8 with nameprep (was: RE: [idn] RealityCheck)
>In-Reply-To: <152039.995367999@localhost>
>Mime-Version: 1.0
>Content-Type: text/plain; charset="ISO-2022-JP"; format=flowed
>Content-Transfer-Encoding: 7bit
>
>Hello Patrick
>
>At 11:06 01/07/17 +0200, Patrik F$BgM(Btstr$B‹N(B wrote:
>>--On 01-07-17 16.48 +0900 Martin Duerst <[email-masked]> wrote:
>>
>> > It is very important to understand that in most contexts, the chance
>> > that a label is changed (except for lowercasing, which was part of
>> > the UTF-8 proposal from the start) by nameprep when somebody takes a
>> > proper domain name from paper and inputs it, is *very* small.

---

From: Keith Moore <[email-masked]>
Date: Tue, 17 Jul 2001 12:09:37 -0400

> I don't think that using UTF-8 in mail headers will cause much more

but if you really thought about it you'd realize that the problems
with UTF-8 in mail headers would compound those that exist due to other
reasons.  for instance, instead of seeing an error message indicating
that paf's mail was broken, you wouldn't get the message at all because
your UTF-8 domain was munged in transit.