Subject: [idn] Re: language scripts classified

From: "Soobok Lee" <[email-masked]>
Date: Wed, 18 Jul 2001 11:17:53 +0900

Some corrections.
someone suggests that these two should be moved to #1.
These are modern scripts used by some minorities. sorry.

Syriac: only used for for liturgical purpose 
Unified Canadian ABoriginal Syllables:  

----- Original Message ----- 
From: Soobok Lee 
To: [email-masked] 
Sent: Wednesday, July 18, 2001 9:28 AM
Subject: language scripts classified

While gathering  usage frequency data for many language scripts,
I classified them into 6 categories (see enclosed ):

  Will all of these scripts  be frequently  used in IDN ?
  At least #3 archaic scripts and #4 won't and 
  for #1 and #2 , i am neutral yet.
  I am working on #5.

I can find many similarities and ambiguities across these language scripts.
Many Indian language scripts came from the same mother language 
'Brahmi' and have  similarly-looking scripts and numerals .

 see http://www.omniglot.com/writing/yi.htm

Soobok Lee 
------------------------------------------------------------------------

#0  already in ML.com testbed  (I got huge usage frequency samples for these)
Hebrew:
Arabic:
Thai:
Hindi(Devanagari):
Cyrillic:
Greek:
Hiragana:
Katakana:
Hangul:
Han Ideograph:

#1 few native speakers

Georgian: < 3.5 millions
Cherokee:  100,000 (North America)
Thaana  :  100,000 (Maldives)
Armenian:   2 millions

#2 two languages in one country:

bengali: Indian language ( > 180 millions )
gujarati: Indian language  
gurmukhi: Indian language
kannada: Indian language
malayalam: Indian language
oriya: Indian language
telugu: Indian language

tibetan : chinese (mainland china)   , < 5 milliions
yi syllables: chinese (mainland china), < 5 millions

#3 Archaic
Ogham: 
Runic:
Gothic:
Syriac: only used for for liturgical purpose 
Unified Canadian ABoriginal Syllables:

#4 Written only vertically
mongolian:  (once had been abolished and restored)

#5  others

sinhala : Sri lanka
tamil : Sri lanka
khmer : Camobodian
lao  : Laos, Thai
ethiopic : Ethiopia
myanmar : Burmese

---

From: John C Klensin <[email-masked]>
Date: Wed, 18 Jul 2001 12:11:59 -0400

I suggest that most of your category #5 should also be moved to
#1.  Regardless of the population, these are contemporary,
spoken, languages.  Also, separating #2 from other categories
is, while factual, not useful.  Most or all of these are the
_primary_ languages of some groups: the fact that members of
those populations also speak "something else" is no more
relevant  than the fact that you speak English is to the
legitimacy of Korean.  

In addition, linguistic boundaries are, for better or worse,
different from political ones.  Both tend to shift.  If we make
decisions based on a mapping between political and linguistic
boundaries (which is what #2 implies), we will certainly find
ourselves, over time, getting it wrong.

Finally, if we really want to internationalize the system, we
had best not try to do so on the basis of population counts.
Doing so leads to forms of discrimination that are
uncomfortable, at best.  And it is not clear that the small
number of people who might want to do so is a good argument
against prohibiting naming hosts in, e.g., Runic.

    john

--On Wednesday, 18 July, 2001 11:17 +0900 Soobok Lee
<[email-masked]> wrote:

> While gathering  usage frequency data for many language
> scripts, I classified them into 6 categories (see enclosed ):
> 
> I can find many similarities and ambiguities across these
> language scripts. Many Indian language scripts came from the
> same mother language  'Brahmi' and have  similarly-looking
> scripts and numerals .
> 
># 0  already in ML.com testbed  (I got huge usage frequency
># samples for these)
> Hebrew:
> Arabic:
> Thai:
> Hindi(Devanagari):
> Cyrillic:
> Greek:
> Hiragana:
> Katakana:
> Hangul:
> Han Ideograph:
> 
> 
># 1 few native speakers
> 
> Georgian: < 3.5 millions
># 2 two languages in one country:
> 
># 3 Archaic
># 4 Written only vertically
># 5  others

---

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Thu, 19 Jul 2001 00:37:23 -0400

Soobok,

I still haven't any idea as to the utility or purpose of your scheme, but
I don't have to understand your purpose to attempt an answer to your set
of questions.

UCAS (Unified Canadian Aboriginal Syllabics) entered ISO10646 via the work
of the Canadian Aboriginal Syllabics Encoding Committee, chaired by Dirk
Vermeulen.

It incorporates the syllabic characters of Eastern, Western and Bible Cree,
Naskapi, Siksika (Algonquin), Athabascan, Carrier, Sayisi, Slavey (Dene),
and Inuktitut and Nunavut (Inuit), three language families, so character
frequency data "for UCAS" would be an average, comperable to one for Finnish
and Turkish, Icelandic, English and French, and Romaji-form Japanesse.

As with some other scripts now in ISO10646 via the Unicode Technical Committee,
UCAS was "unified" by people who's primary interest was glyph collection and
who view language, collation, distribution, etc., as properties of glyphs, who
managed to fail to impress upon the beneficiaries of their technical largess
that perhaps not all the world is a printer.

The current ISO10646 ordering approximates row-centric (E, I, O, A) vowel
ordering, marred by "Han (like) Unification", which manages to compress a
set of under 1K possible code-points into 600 or so (range U+1400 to U+1676),
a rather modest win. Here are the first "row", keep in mind that Y-CREE is as
like CARRIER as Japanese is like English.

		U+1401 E
		U+1401 AAI
		U+1402 I
		U+1404 II
		U+1405 O
		U+1406 OO
		U+1407 Y-CREE OO
		U+1408 CARRIER EE
		U+1409 CARRIER I
		U+1410 A

All the Algonquin languages I'm familiar with (W-Cree, Y-Cree, Siksika) teach
column ordering in schools ("Wa Pa Ta Ka ...") columnar consonant-ordering,
though both ordering exist in Nunavut (Inuktitut) usages. I can't shed any
light on Dene use though I suppose I'll have to ask around eventually.

That should motivate why writing collation for languages using UCAS for
code-points is difficult, even a barrier to the expansion of text-based
computer mediated language applications for about half of the Indians in
Canada.

The population question is hard to answer, as lots of people, Canadian and
Indian, arrive at different answers, for policy reasons. Canadians want to
diminsh the number of "Indians", Treaty Indians want to control the number
of C-31 "Indians", and Constitutional "Indians" may differ from everyone.
The "counting" situation is no better in the US, where differing "blood
quanta" and lineal descent rules exist, in a hodgepodge of Federal, State,
and formerly Terminated Tribes rules. It isn't a useful question to attempt
either, utilitarianism in this area is not polite, neh?

I hope this has been helpful, there are several dozen characters in the
1400 - 1676 range that are nameprep suspects for the usual reasons e.g.,
U+1429 FINAL PLUS looks like "+" U+002b, etc.

Do you really need character frequency data for UCAS for reordering? Just
how much of a win would halving the effective repetoire present to an ACE
designer? I'm pretty ignorant about ACE design issues. I'm afraid that my
text archives are a) in print, and b) W-Cree and Siksika centric, and not
representative of all the syllabics language communities.

I hope you don't mind my responding via the IDN list, and cc'ing Dr. Nii
Quaynor, who is working on a syllabary for several Central African languages,
and may appreciate some exposure to non-glyph issues he may not already be
aware of.

Eric