Subject: Re: [idn] ACE37,AMCW and LDUDE

From: "Soobok Lee" <[email-masked]>
Date: Sat, 7 Jul 2001 09:28:26 +0900

Moreover,

codeblock shifting produces longer XOR diff in some cases:

0x5000 and 0x5f00: xor diff value = 0xf00

after codeblock shifting applied ( 0x4e00 -> 0x0000 ),

They are reduced to

0x0200 and 0x1100: xor diff value = 0x1300

diff value 0x1300 is longer than 0xf00.

codeblock shifting withOUT frequecy reordering
does not  help.

It  merely SHIFT xor diff distribution and
does NOT REDUCE the xor diff values.

I had tried it before and gave up.

Soobok Lee

----- Original Message -----
From: "Soobok Lee" <[email-masked]>
To: "Edmon" <[email-masked]>; "Keith Moore" <[email-masked]>
 > > > I would *really* like to avoid complex reordering of codepoints,
because
> > > it would require fairly large tables (that would have to be
implemented
> > > on some machines of modest capability) and would be error-prone.
> > >
> > I agree.  The code block shifting mechanism in ACE37 however is very
> simple
> > and yeilds great benefit for CJK ideographs.
> >
>
> Code block shiffting  (  0x4E00:8FFFF ----> 0x0000: 0x52FF)
> does reduce XOR diff value  for small subset of the code points
> from   first 0x4E00 ~ 0x5E00 block.
>
> For example, 0x4e00 and 0x5000 (xor diff is 0x1e00)
> is mapped to 0x0000, 0x0200 (xir diff value 0x200 ).
>
>
> But, For 0x4e00 and 0x6e00, xor diff values are  0x2000  for either
> cases !

---

From: "Soobok Lee" <[email-masked]>
Date: Sat, 7 Jul 2001 11:23:34 +0900

codeblock shifting does good for ACE37, but not for DUDE.

The previous argument does not hurt ACE37's usefulness.
It cleverly uses
"base37" to utilize  shifted xor diff distrubutions. Good idea.

But the shifting will not benefit other "base16" ACEs (DUDE?).
That's the point.

----- Original Message -----
From: "Soobok Lee" <[email-masked]>
To: "Soobok Lee" <[email-masked]>; "Edmon" <[email-masked]>; "Keith
Moore" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, July 07, 2001 9:28 AM
Subject: Re: [idn] ACE37,AMCW and LDUDE

---

From: "Edmon" <[email-masked]>
Date: Mon, 9 Jul 2001 10:58:04 -0400

Hi Soobok,

> after codeblock shifting applied (
0x4e00 -> 0x0000 ),

This is incorrect. With codeblock
shifting in ACE37 0x4e00 becomes 0x1e00
(0x4e00 - 0x3000 = 0x1e00)
0x2000 and 0x2f00: diff = 0xf00
The diff is the same in this case.

> does NOT REDUCE the xor diff values.

ACE37 does not intend to reduce xor
diff values but to optimize it (or
shift it as the name suggests, so that
within the CJK ideograph library, diff
will not exceed 15bit or 3 <b32>
characters) to improve the han
ideographs capacity and keep the
algorithm as simple as DUDE.

Edmon