Subject: Re: [idn] WG Update

From: [email-masked]
Date: Tue, 9 Oct 2001 01:21:39 -0700

Case preserving has been there, and it is nice 
for people who wants to support it.  To make it 
a requirement will ensure a uniform support, 
and ensure a clear path for mixed use of 
scripts and CJK character recovery cross all 
types of devices, which adds more software work 
but benefit a general public on a long run.  Given 
this does not effect DNS structurally,  I don't see 
why we can not make it a requirement. 

If you only think in terms of all Latin upper case, it 
may not make that much a difference.  If you think 
SomethingLikeThis.com it does make a lot of 
difference, since we don't have that white space 
already.  When we speak about CJK characters,
people can tell some Kanji from Han in an 
equivalent CJK set. 

Liana

On Tue, 09 Oct 2001 06:30:18 +0100 David Hopwood
<[email-masked]> writes:
> -----BEGIN PGP SIGNED MESSAGE-----
> 
> [email-masked] wrote:
> > If IDN is going to be universal to all devices, then a
> > handheld device may have uppercase support for
> > a sick user to have a familar reading quickly.  So
> > I think your case preserving arguement should be
> > considered.
> 
> That doesn't sound like a very strong argument for case preservation
> to me. Suppose for the sake of argument that a user does find
> uppercase characters easier to read [*]. In that case, all names 
> should
> be displayed as uppercase to that user, not just names that were
> originally entered as uppercase. That could be done regardless of
> whether the IDN proposal supports case preservation.
> 
> 
> [*] Personally I find them less readable. Font size and style is 
> much
>     more important than case.
> 
> - -- 
> David Hopwood <[email-masked]>
>

---

From: David Hopwood <[email-masked]>
Date: Tue, 09 Oct 2001 20:00:47 +0100

-----BEGIN PGP SIGNED MESSAGE-----

> why we can not make it a requirement.

Case preservation does affect DNS structurally. In particular,
there have been IDN proposals discussed in this WG that do
not support case preservation; Just-send-UTF-8 is one example.

(That Just-send-UTF-8 has other problems is completely
beside the point; the example is sufficient to demonstrate
that requiring case preservation would eliminate some parts
of the design space, IMHO without justification.)

- -- 

Home page & PGP public key: http://www.users.zetnet.co.uk/hopwood/
RSA 2048-bit; fingerprint 71 8E A6 23 0E D3 4C E5  0F 69 8C D4 FA 66 15 01
Nothing in this message is intended to be legally binding. If I revoke a
public key but refuse to specify why, it is because the private key has been
seized under the Regulation of Investigatory Powers Act; see www.fipr.org/rip

---

From: "Adam M. Costello" <[email-masked]>
Date: Tue, 9 Oct 2001 22:14:44 +0000

David Hopwood <[email-masked]> wrote:

> In particular, there have been IDN proposals discussed in this WG that
> do not support case preservation; Just-send-UTF-8 is one example.

Actually, just-send-UTF-8 supports case preservation just fine; it's
send-nameprepped-UTF-8 that doesn't.  If the sender already requires the
receiver to support UTF-8, it might be reasonable to further require the
receiver to do normalization and case-folding when comparing strings.
The one exception is DNS queries, where for performance reasons you
would want to do it at the requestor, but who cares if DNS queries don't
preserve case (DNS responses still could).

AMC

---

From: David Hopwood <[email-masked]>
Date: Wed, 10 Oct 2001 03:24:06 +0100

-----BEGIN PGP SIGNED MESSAGE-----

"Adam M. Costello" wrote:
> send-nameprepped-UTF-8 that doesn't.

Just-send-UTF-8 requires users to type lowercase names, and does not allow
storing or registering names with uppercase (if I understand the intention
correctly; there was never an I-D). Send-nameprepped-UTF-8, OTOH, does
support case preservation, since names can be stored with uppercase and
then mapped to lowercase-NFKC by the resolver (or application).

- --

---

From: "tsenglm@????.??.tw" <[email-masked]>
Date: Wed, 10 Oct 2001 10:52:29 +0800

> preserve case (DNS responses still could).
       The reason is not for performance of DNS. We use ACE only for
backward compatability of  existed LDH-DNS server. All LDH-server do
comarison case-insenstively and keep case preserving in response.
       Nameprep will map all Full-Width-english-character in unicode
directly to lower-case ASCII  is considered the confusing of  TLD and  ASCII
name. To force all case to lower case is over-specifications in
requirements. UTF-8 can keep the case of ASCII
but can not preserve the case of non-ASCII . But now AMC-ACE-Z can preserve
one case of non-ASCII , it is an excellent improvements over UTF-8 . We
should consider the specification based on new technology ---AMC-ACE-Z.
      Mapping all Full-Width-english-characters to ASCII is necessary , but
mapping all case of  ASCII to lower case in Nameprep is not necessary .
That will be more compatible with historical  DNS and let all non-ASCII has
the chance to view the name in their like form.
      Only in  case-insensive comparison and case preserving of non-ASCII ,
ACE is more suitable for next step in DNS developing.

L.M.Tseng

---

From: Martin Duerst <[email-masked]>
Date: Wed, 10 Oct 2001 13:55:00 +0900

At 03:24 01/10/10 +0100, David Hopwood wrote:
>correctly; there was never an I-D).

There was an I-D with UTF-8 in the old days (1997? 1998?) at least,
which proposed that the client map to lower case (according to the
user preferences/locale settings at the client).

Regards,   Martin.