Subject: RE: [idn] Re: stringprep and unassigned code points

From: Yves Arrouye <[email-masked]>
Date: Wed, 24 Oct 2001 15:47:43 -0700

> I finished careful reading your clear answers titled with
>  "Re: [idn] questions: unassigned code points in nameprep".
> 
> What I understand is:
> 
>   "saved string" :  generated ACE labels by applications
>                       with known version of nameprep
> 
>   "query"        :  received ACE label from other applications
>                       the ACE label may have been generated by
>                          unknown version of nameprep
> 
>  from this understanding,
> 
>  1) I will prefer to use "generated ACE label" and "received ACE label".
>  They seem to be  more intuitive.

I don't think they really are more intuitive; the names still do not convey
the main point you wanted to show, which that the Nameprep version info is
known somehow. I understood the previous names better (at least query, in
the spirit of programming defensively and being prepared for the unassigned
code points).

Anybody cares to find good names conveying this (versioned/dated ACE label
and unversioned/undated ACE label do not sound that much better, form what I
could come up with)?

YA

---

From: "Soobok Lee" <[email-masked]>
Date: Thu, 25 Oct 2001 13:01:32 +0900

----- Original Message ----- 
From: "Yves Arrouye" <[email-masked]>
To: "'Soobok Lee'" <[email-masked]>; "Patrik Fältström" <[email-masked]>; <[email-masked]>
Sent: Thursday, October 25, 2001 7:47 AM
Subject: RE: [idn] Re: stringprep and unassigned code points

> the spirit of programming defensively and being prepared for the unassigned

A generated ACE label become a received ACE label  once it leaves its mother
application and arrive at other applications/dns servers in the outer world.
Therefore,the two distinctions merely express two aspects of one ACE label in its trip from application to applications.

If you received unknown-nameprep-made ACE email addresses from others,
they are "saved" in your addressbook/mailbox. Should we call any received
IDN email address as  "query" (???, why?)  which may have no lookup sematics within email clients?   

If you type new native web address into your browser, they are ACEed and
sent to the dns and webservers. the ACE label is "saved string"(???, why?) 
for for browser, but "query" (right!) for dns and webservers.
 
Soobok Lee