Subject: Re: [idn] (bias) summary of reordering discussion

From: liana Ye <[email-masked]>
Date: Thu, 25 Oct 2001 02:57:03 -0700

On Thu, 25 Oct 2001 10:08:48 +0200 =?ISO-8859-1?Q?Patrik_F=E4ltstr=F6m?=
<[email-masked]> writes:
> --On 01-10-25 12.54 +0900 Martin Duerst <[email-masked]> wrote:
> 
> > At 19:41 01/10/23 +0200, Patrik F舁tstr仁 wrote:
> > 
> >> o Nameprep mappings is defined by UTC, not IETF.
> >>   -> I am nervous when we in IETF talk about these things
> > 
> > The main mappings used by nameprep (casemapping and normalization)
> > are defined by the UTC. But it is IETF that chooses which mappings
> > to select (e.g. NFC vs. NFKC), it is IETF that may request other
> > mappings to be created (NFC was created based on a request by W3C,
> > an additional file was added to help IETF with case mapping,
> > a (tentative, implicit) request for TC/SC mappings was turned 
> down).
> > 
> > Also, nameprep contains a few additional mappings and prohibitions
> > that are motivated by the specific situation of domain names,
> > without taking these from anywhere.
> 
> You are correct, but I am still nervous.
> 
>    paf
> 
> 

What if we define a frame and  make it possible to let any 
script to be mapped by their own user group, as long as 
the user group can come up with their agreement on how
to do the mapping. The [nameprep] is severing as example
of such mapping. BTW, is "PROFILE" have such meaning? 

Liana

---

From: Martin Duerst <[email-masked]>
Date: Fri, 26 Oct 2001 16:08:28 +0900

>of such mapping. BTW, is "PROFILE" have such meaning?

Well, there is only one DNS for the whole world. That's
why profiles or frames (or whatever you call it) are not
a good idea.

Also, DNS server have heavy loads. That's why some kinds
of solutions designed by user groups may not be workable,
and why we have DNS experts in this group.

Regards,    Martin.