Subject: Re: [idn] case preservation

From: [email-masked]
Date: Tue, 9 Oct 2001 14:46:52 -0700

I have offered a solution to the old problem in 
  draft-liana-idn-map-00. 
Have you read it?  

If you have read it, then I would ask your support 
for the WG's consideration.  May I?  And please DO
tell me why you are NOT support it for your 
consideration? 

If I have enough support for the submission, I will
address the following in an updated draft:
 Limits of IDN-map (This section is for you)
 Limits of language tags(mostly mixed use of scripts)
 Mix Scripts and Multiple Languages of a Script 
 Multiple Standards vs. DNS Format 
 and some implementation of language specific procedures.

Liana

On Tue, 09 Oct 2001 08:00:47 -0700 Dave Crocker <[email-masked]>
writes:
> At 11:51 PM 10/8/2001, D. J. Bernstein wrote:
> >A properly typeset uppercase Alpha is IDENTICAL to a properly 
> typeset
> >uppercase A, just as a properly typeset tab is IDENTICAL to a 
> properly
> >typeset sequence of spaces. It is simply NOT POSSIBLE to tell the
> >difference between AOL.com and AOL.com.
> 
> Thank you for providing an example that very nicely shows this to be 
> an old 
> problem  for which there is no known solution.
> 
> Feel free to offer text to add to the specification, if you feel it 
> will 
> solve the problem.
> 
> d/
> 
> 
> ----------
> Dave Crocker  <mailto:[email-masked]>
> Brandenburg InternetWorking  <http://www.brandenburg.com>
> tel +1.408.246.8253;  fax +1.408.273.6464
> 
>

---

From: [email-masked]
Date: Tue, 9 Oct 2001 15:08:57 -0700

You are right, that many people do not have experiences
with 4000+ symbols to use on a daily bases, and they 
think an international standard to cover alphabet languages 
of three: Latin, Greek and may be Cyrillic is good enough
to call it an IDN.  Chinese can offer a Five Stroke analogy 
to the 26 letter case, at least it is a 5:26 problem:-)

Liana

On Tue, 9 Oct 2001 12:08:32 -0400 "ben" <[email-masked]> writes:
> >
> > Already today, people can register domainnames with characters 
> which
> look
> > "similar" like 'o' and 0, or '1' and 'l'. I.e. this is not a new
> >problem.
> 
> I have been discussing my Supreme CDN system offline and have come 
> to
> the conclusion that it will *never* become a standard because it is
> simply not interoperable with existing systems.  But as I have said,
> that is okay as I believe all along that all the other CDN systems
> (although not as perfect as mine) are absolutely 100% fine exactly 
> the
> way they are.
> 
> Offline, I have gotten less then pleasant remarks about why "some
> people are trying to cause trouble/delay the progress/make things 
> more
> difficult then they really are/etc, etc."  Those remarks are made
> *not* because of a lack of respect for people's contribution to this
> WG but simply because of a lack of understanding of the Chinese
> culture and why TC<->SC is so important- which can lead to 
> fustrations
> that are fully understandable.  Although we may never come up with a
> solution that will be agreed upon by the majority of this WG, the 
> fact
> remains that TC<->SC is of paramount importance to the users of
> CDNs... and the above 'O', '0','1','l' issue just gave me a good 
> idea
> on how to explain why it is so (not sure if this analogy had ever 
> been
> made before, but it shouldn't hurt to repeat it.)
> 
> At first, the '1','l' may not seem like a good analogy for TC<->SC
> conversion because we definitely do *not* want to map 'l' with '1'.
> However, the confusion of '1' and 'l' does illustrate why TC<->SC is
> so important.  For example, when a person is given 'l.TLD', he can
> easy type in '1.TLD' instead and have absolutely no idea why he 
> cannot
> reach the intended website.  In English the chance of such a 
> confusion
> is only limited to a few cases (such as '0' and '1') where as for
> Chinese, *every single* Chinese character poises the opportunity for
> such confusion.  Remember, Simplified Chinese and Traditional 
> Chinese
> are indistinguishable to many users of CDNs of certain
> backgroud/education/location/culture.  (Given certain Chinese
> characters, even someone as educated in Chinese as I, cannot tell 
> you
> whether it is traditional Chinese or simplified Chinese.)
> 
> Thanks
> Ben Chan
> 
> 
> 
> 
> 
> 
> 
>