Subject: Re: [idn] (bias) summary of reordering discussion

From: [email-masked]
Date: Wed, 24 Oct 2001 01:37:19 EDT

In a message dated 2001-10-23 22:16:54 Pacific Daylight Time, 
[email-masked] writes yet again:

> let's assume new nameprep with new added script  which contains mapping 
X-->Y.

No, let's not assume this, because UTC/WG2 have said repeatedly that this 
will not happen.  I keep saying this, and Soobok keeps ignoring it.

-Doug Ewell
 Fullerton, California

---

From: "Soobok Lee" <[email-masked]>
Date: Wed, 24 Oct 2001 14:40:01 +0900

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, October 24, 2001 2:37 PM
Subject: Re: [idn] (bias) summary of reordering discussion

> will not happen.  I keep saying this, and Soobok keeps ignoring it.

What if X->Y is a Case mapping ?
You said case folding would happend in the future added script ? Didn't you?

Soobok Lee

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 24 Oct 2001 07:59:59 +0200

--On 2001-10-24 14.40 +0900 Soobok Lee <[email-masked]> wrote:

>> No, let's not assume this, because UTC/WG2 have said repeatedly that
>> this  will not happen.  I keep saying this, and Soobok keeps ignoring it.
> 

Mappings X-->Y will happen, but, _never_ where X is a codepoint which is
assigned in an earlier version of the Unicode Spec. X has to be an earlier
not assigned codepoint.

   paf

---

From: Martin Duerst <[email-masked]>
Date: Wed, 24 Oct 2001 17:27:39 +0900

>--On 2001-10-24 14.40 +0900 Soobok Lee <[email-masked]> wrote:
[Doug Ewell wrote:]

> > You said case folding would happend in the future added script ? Didn't

I think he did. But I don't know about any script in the pipeline
that is bicameral (has two cases). (If I'm wrong, please tell me.)
So the chance we get any more bicameral script in Unicode are pretty
low.

>assigned in an earlier version of the Unicode Spec. X has to be an earlier

Yes, that's by design of NFC (and by extension, of NFKC).

Regards,   Martin.