Subject: Re: [idn] WG Update

From: [email-masked]
Date: Mon, 8 Oct 2001 11:27:05 -0700

If IDN is going to be universal to all devices, then a 
handheld device may have uppercase support for 
a sick user to have a familar reading quickly.  So 
I think your case preserving arguement should be
considered. 

Liana

On Mon, 8 Oct 2001 08:33:56 +0200 (MEST) Dan Oscarsson
<[email-masked]> writes:
> 
> >> I recommend modify the last line "MUST be discussed" to be
> >> "MUST be provided", as to be " Case-insensitivity for non 
> US-ASCII MUST be
> >> provided in the protocol proposal"
> >
> >I disagree. As it happens, all of the proposals provide 
> case-insensitivity
> >for non-US-ASCII, but it is *not* a requirement. The protocol would 
> work
> >fine and would be perfectly acceptable to users without it. We 
> should be
> >clear about the difference between features that are *desirable* 
> (in this
> >case for consistency), and *required* features.
> 
> Well, I disagree to that.
> 
> It *is* a requirement that case-insensitivity shall work for all 
> letters.
> That has been the DNS standard so far. That is what people expect.
> To have case-sensitive matching is not fine for everybody.
> 
> If we are not going to support case-insensivity and case preserving 
> in
> responses, then we should turn it of for ASCII too.
> Either we support full backward compatibility (that includes having
> case-insensitivity and case preserving in protocol for all letters),
> or we kill it off for ASCII letters too.
> Just because non-ASCII has not been used, does not mean that people
> expect the same rules that exist for ASCII to exist for non-ASCII.
> The current DNS standard has defined that case-insensitivity shall 
> be
> used and that case should be preserved in responses. We break that
> if it is not done for non-ASCII letters too.
> 
>    Dan
> 
>

---

From: "Tim Langdell" <[email-masked]>
Date: Mon, 8 Oct 2001 11:33:56 -0700

Does anyone please have a link to a good conversion routine for NN% to and
from UTF8 for URI transport? Perl script would be good ...

---

From: David Hopwood <[email-masked]>
Date: Tue, 09 Oct 2001 06:30:18 +0100

-----BEGIN PGP SIGNED MESSAGE-----

> I think your case preserving arguement should be

That doesn't sound like a very strong argument for case preservation
to me. Suppose for the sake of argument that a user does find
uppercase characters easier to read [*]. In that case, all names should
be displayed as uppercase to that user, not just names that were
originally entered as uppercase. That could be done regardless of
whether the IDN proposal supports case preservation.

[*] Personally I find them less readable. Font size and style is much
    more important than case.

- -- 
David Hopwood <[email-masked]>

Home page & PGP public key: http://www.users.zetnet.co.uk/hopwood/
RSA 2048-bit; fingerprint 71 8E A6 23 0E D3 4C E5  0F 69 8C D4 FA 66 15 01
Nothing in this message is intended to be legally binding. If I revoke a
public key but refuse to specify why, it is because the private key has been
seized under the Regulation of Investigatory Powers Act; see www.fipr.org/rip

---

From: Martin Duerst <[email-masked]>
Date: Tue, 09 Oct 2001 17:55:33 +0900

Hello Tim,

>from UTF8 for URI transport? Perl script would be good ...

You probably mean the %HH convention used in URIs?
Converting from UTF-8 to %HH is rather easy; I can write
that code in Perl if you can use it (I should write it
anyway as an example).
Converting from %HH to UTF-8 is not as easy, unless you
know that the %HHs you are dealing with indeed came from
a decent string (e.g. no controls,...) decently encoded
in UTF-8.

Regards,   Martin.