Subject: Re: [idn] Problems in normalisation and matching

From: "Soobok Lee" <[email-masked]>
Date: Mon, 1 Jul 2002 14:01:28 +0900

Copy-and-paste *operation*   is not only a user interface but also a trigger to
a critical system service  for interprocess communications between independant applications  
like unix & NT-pipe or socket ,and it transfers some data from one application to the other 
with  conversions or transcodings. 

Some IETF protocols (TCP/IP) are often very strict at forcing on-the-wire communication octets streams to be 
little-endian and big-endian. Cut-and-paste is a popular communication tool and have much more
stricter rules and conventions for various data formats (images, sounds , URLs and texts ). 
IDN specifications can recommends special treatements of IDN or IDN-like strings in text copy&paste operation.

Identifier security and integrity issue around copy-and-paste operation still 
is of the concern of this WG.
  
Soobok Lee

----- Original Message ----- 
From: "Dave Crocker" <[email-masked]>
 > 
> The concern for cut-and-paste is obviously valid, but it is not the job of 
> the IETF protocol standards to operate well within a user cut-and-paste 
> environment.

---

From: "James Seng" <[email-masked]>
Date: Mon, 1 Jul 2002 23:06:37 +0800

Right. But IETF deals mostly with wire-protocols. UI issues such as
cut-and-paste should be done more at a more appropriate forum e.g. POSIX.

-James Seng

---

From: "Soobok Lee" <[email-masked]>
Date: Tue, 2 Jul 2002 00:59:09 +0900

To be more specific, 
double-click&drag&drop mouse operation is an UI for cut&paste data transfer *system* service.
This will clarify my point. It's clear that only "IDN-compliant OS" can support "IDN-aware" applictions
faithfully.

Soobok Lee