Subject: Re: [idn] IDN WG Last Call on two major changes to Stringprep

From: James Seng <[email-masked]>
Date: Sun, 7 Jul 2002 22:37:24 +0800 (SGT)

Please take note that this is _not_ a working group last call for Stringprep.

It is a last call for the two major changes in Stringprep, namely, Unicode 3.2 
and bidi. Please review these two major changes carefully. It is likely that 
this will be published as RFC after this last call.

Thank you.
 
-James Seng

[email-masked] wrote:
> A minor change:
> 
> > Other examples are
> > simplified Chinese spellings of names (for example,
> > "<U+7EDF><U+4E00><U+7801>") vs. the equivalent traditional Chinese
> > spelling (for example, "<U+7D71><U+4E00><U+78BC>").
> 
> I dont think Chinese phrases should be called "spelling".
> I would suggest using the word "representation" instead of "spelling" so
> that it makes more sense.
> 
> -----Update to-----
> Other examples are simplified Chinese representation of names (for example,
> "<U+7EDF><U+4E00><U+7801>") vs. the equivalent traditional Chinese
> representation (for example, "<U+7D71><U+4E00><U+78BC>").
> -----
> 
> Edmon
> 
> 
> 
> ----- Original Message -----
> From: "James Seng" <[email-masked]>
> To: "IETF/IDN WG" <[email-masked]>
> Sent: Sunday, July 07, 2002 4:06 AM
> Subject: [idn] IDN WG Last Call on two major changes to Stringprep
> 
> 
> > The IETF last call have been concluded and the latest version of
> > Stringprep is in the I-D directory:
> >
> > http://www.ietf.org/internet-drafts/draft-hoffman-stringprep-04.txt
> >
> > Other then editorial changes, there are two significant changes*:
> > - Reference Unicode 3.2, updating all the tables from 3.1 to 3.2.
> > - Additional Bidirection characters handling, Section 6 and Appendix D.
> >
> > The co-chairs is conducting a working group last call on these two
> > significant changes. Please send any proposed modification of text to the
> > wg mailing list as well as the wg co-chairs, stating clearly the text to
> > be modified and the new text.
> >
> > This three weeks WG last call will end on 28th July 2002, 23h59 GMT-5.
> > (We have a three weeks last call instead of the usual two weeks for those
> > who is busy preparing for IETF Yokohama)
> >
> > Marc & James
> > co-chairs
> >
> > * The previous of Stringprep can be found at
> > http://www.potaroo.net/ietf/old-ids/draft-hoffman-stringprep-03.txt
> >
> >
> >
> 
>

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 24 Jul 2002 10:38:29 -0400

> I'd like to make sure that these changes to stringprep have 
> been well-reviewed.
> There hasn't been much discussion on the list which could be 
> due to at least
> two different reasons:
>  - the changes are good, well understood, etc. thus there is nothing
>    to comment on
>  - not many people have read and understood the changes
> 
> In order to be able to tell the difference I'd appreciate a 
> note (to the
> list or directly to me) saying you've reviewed and understood the
> changes.

I've reviewed and am comfortable with the changes.

-Scott-

---

From: "Michel Suignard" <[email-masked]>
Date: Fri, 26 Jul 2002 17:20:17 -0700

I have reviewed and understood the changes and really appreciate that
bidi is now part of Stringprep. My only concern is that the restrictions
put on bidi labels (indirectly by usage of Stringprep in IDNA) are not
felt as being excessive by the Bidi user community.
Furthermore, Strinprep is likely to be used in other contexts, so it is
important that Bidi users realize what they are getting.

Michel