Subject: Re: [idn] Re: proposed charter items for possible URI working group

From: liana Ye <[email-masked]>
Date: Mon, 22 Jul 2002 09:49:23 -0700

> I propose to add one additional item:
> 
> Update the syntax of host names: Currently, this is one of the
> only places where %hh-escaping isn't allowed. Implementations
> are mixed, some browsers e.g. accept http://www.w%33.org while
> others don't. So this may go under "(b) document variations in
> current practice, as warnings to implementors." below.
> With Internationalized Domain Names, allowing %hh in host names
> is necessary for consistency.

Allow this in IDN label makes the string compare more complex
at this time.

Liana

________________________________________________________________
GET INTERNET ACCESS FROM JUNO!
Juno offers FREE or PREMIUM Internet access for less!
Join Juno today!  For your FREE software, visit:
http://dl.www.juno.com/get/web/.

---

From: Martin Duerst <[email-masked]>
Date: Tue, 23 Jul 2002 02:39:47 +0900

>Allow this in IDN label makes the string compare more complex

- It doesn't really add that much complexity given that the
   upper case/lower case comparison is already complex enough.

- Comparing URIs is a different thing from comparing IDNs.
   Nobody is proposing adding %hh to the IDN labels; it's
   just for URIs.

Regards,    Martin.

---

From: "Adam M. Costello" <[email-masked]>
Date: Mon, 22 Jul 2002 21:02:05 +0000

Martin Duerst <[email-masked]> wrote:

>   Nobody is proposing adding %hh to the IDN labels; it's just for
>   URIs.

I was not aware of that.  I was under the impression that IRIs were
supposed to be a superset of URIs, that is, every valid URI is also a
valid IRI, for backward compatibility.  Are you sure you don't want that
model?

AMC