Subject: Re: [idn] Re: idn-uri document

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Wed, 06 Nov 2002 03:30:26 +0100

Hoops sorry: please read at the first one below :
---
I came in here just to say two things as a "user"
- the punycode thing seems OK but the DNS aspects are
   inadequate
- the text you produced is not easily understandable.
I was said to be a troll for the second point. May be
could we also look at the (second) first one?

At 19:23 05/11/02, John C Klensin wrote:
>--On Thursday, 31 October, 2002 23:40 +0100 Erik Nordmark

>But, even in that case, we haven't permitted profile variations _within_ 
>IDNA: a user, site, or registry cannot select a different stringprep 
>profile, and that is a Good, probably necessary, thing.

"probably" necessary ???
At this date, this rises a lot of question.
All I found was a very early commitment to that in the process.
I did not read everythng yet.
Any reason why it is "certainly" necessary?
(a part from obvious non technical reasons)

  But much the same argument applies to the type of use Martin
>contemplates.   IDNA, as written, is _one_ protocol.  It is not
>a toolkit for building other protocols, nor is it a a set of
>profiles that other protocols can adopt.  Those two may be much
>the same thing in practice.  As soon as we say "you should use
>that operation from IDNA, but without some particular step" we
>head down a slippery slope.  That is especially true because
>IDNA contains (or appears to contain) a good deal of normative
>text outside the particular of, e.g., ToASCII.  It is not clear
>whether "...explicitly state that one should apply ToASCII
>without the punycode step (and other steps..." includes some,
>all, or none of those textual specifications.  And, whatever
>choice is made, "do just what is done over there, except..." is
>a poor way to do protocol specification and introduces some of
>the worst properties of profiling without any of the benefits of
>being explicit about what can, and cannot, be profiled.

You point is accepted. But to say that applying ToASCII to
a valid ASCII name is equivalent to do nothing does not
removes the need to use ToASCII, but helps understanding
that this is what actually happens. The way it is written leaves
many questions open.
jfc

---

From: "James Seng" <[email-masked]>
Date: Wed, 6 Nov 2002 10:56:36 +0800

> could we also look at the (second) first one?

The document is written for an engineer, not an "user". End-user without
appropriate technical background will not likely to be able to understand
this (or any other Standard RFC for that matter).

I have asked you to read the books from Unicode Consortium and other
documents. You have replied that you are not interested to do so.

So let me repeat my request again. Please read up those books to get a basic
understand of the discussion going on here. Thanks.

> At this date, this rises a lot of question.
[snip]
> The way it is written leaves many questions open.

What is "lot of question" and what are the "questions open"? Your mail did
not ask anything except some handwaving about "obvious" and 'certainly".

Sorry, but this is not GA. We dont weasel here so please be more specific.

-James Seng