Subject: [idn] Fw: Results of BALLOT on Five Canonical Mapping Errors

From: "James Seng" <[email-masked]>
Date: Sat, 7 Dec 2002 16:54:17 +0800

fyi

----- Original Message -----
From: "Lisa Moore" <[email-masked]>
To: "unicore" <[email-masked]>
Sent: Saturday, December 07, 2002 6:09 AM
Subject: Results of BALLOT on Five Canonical Mapping Errors

> Folks,
>
> We are closing the ballot - 14 out of 18 members have voted, a majority of
> full members voted for Option A:
>
> A) Fix the canonical mappings and issue another normalization corrigendum
> with corrected mappings in the Unicode 4.0 time frame, as follows:
>
>    Make the following corrections in UnicodeData.txt for 4.0:
>    Correct canonical mapping for 2F868 from 2136A to 36FC.
>    Correct canonical mapping for 2F874 from 5F33 to 5F53.
>    Correct canonical mapping for 2F91F from 43AB to 243AB.
>    Correct canonical mapping for 2F95F from 7AAE to 7AEE.
>    Correct canonical mapping for 2F9BF from 4D57 to 45D7.
>    Add the following entries to NormalizationCorrections.txt:
>    2F868;2136A;36FC;4.0.0 # Corrigendum 4
>    2F874;5F33;5F53;4.0.0 # Corrigendum 4
>    2F91F;43AB;243AB;4.0.0 # Corrigendum 4
>    2F95F;7AAE;7AEE;4.0.0 # Corrigendum 4
>    2F9BF;4D57;45D7;4.0.0 # Corrigendum 4
>
> The vote was:
>
>       13 for A (Adobe, Apple, Basis, HP, Justsystem, Microsoft, Oracle,
> Peoplesoft, RLG, SAP, Sun, Sybase, Unisys)
>       1 for B (IBM)
>
> Thank you to all for voting so promptly.  The UTC will now support
> correcting the five above mappings at next week's WG2 meeting.
>
> Lisa
>
>
>
>

---

From: Soobok Lee <[email-masked]>
Date: Sat, 7 Dec 2002 22:17:17 +0900

Thanks. I welcome Option A. This is the right decision!

I hope to see Unicode 4.0 NFC also has
 corrected version of hangul jamo processing. My concern was
 that such false mappings become too heavily deployed and established
 to be corrected sometime later, due to critical use in IDN identifiers. 
 But, Today, UTC decision opened the  right way for correction.
 I fullheartedly appreciate for their honest efforts around this.

Then, what would be done on Stringprep ? Will it follow
future Unicode 4.0 ? Of course, it will take some time for authors 
to give the answer. So, I won't prompt them today... :-)

Soobok Lee

---

From: "Kent Karlsson" <[email-masked]>
Date: Sat, 7 Dec 2002 15:31:59 +0100

> to give the answer. So, I won't prompt them today... :-)

Since IDNs have not yet been deployed, there is still a VERY SMALL
window of opportunity to fix this for IDNs.  Once deployed, it will
be much harder to fix this for IDNs, if at all possible.

	/Kent Karlsson

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 9 Dec 2002 16:47:31 -0800

One should not read too much into this decision. The Unicode stability
policies only permit extremely constrained changes; see:

http://www.unicode.org/standard/stability_policy.html#Normalization

Jamo mappings would not fall under those criteria.

However, Kent Karlsson has been working on additional mappings and
information for aiding in the processing of Hangul/Jamo characters. Such
mappings the UTC is open to considering, and you might contact him to find
out the status of that effort.

Mark
__________________________________
http://www.macchiato.com
►  “Eppur si muove” ◄