Subject: [idn] Punycode conversion tool

From: "John Wall" <[email-masked]>
Date: Thu, 13 Feb 2003 11:03:18 -0500

I am looking for an IDNA conversion tool using 
the ACE prefix available since yesterday.

Can anybody help me?

Thank you

J.W.

Sent by Go2net Mail!

---

From: Yoshiro YONEYA <[email-masked]>
Date: Fri, 14 Feb 2003 01:39:55 +0900 (JST)

> the ACE prefix available since yesterday.

Sure :-)

Try idnkit which is available from following URL:

    http://www.nic.ad.jp/ja/idn/mdnkit/download/#sources
    ==> idnkit-1.0pr2

By default, the idnkit-1.0pr2 uses 'zq--' as ACE prefix.
But it can be changed to 'xn--' by using '--with-punycode-prefix=xn--'
configure option.  Please read 'INSTALL' for more detail.

-- 
Yoshiro YONEYA <[email-masked]>
           aka <[email-masked]>

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 13 Feb 2003 18:59:48 +0100

> the ACE prefix available since yesterday.

<http://www.gnu.org/software/libidn/>

---

From: Roozbeh Pournader <[email-masked]>
Date: Fri, 14 Feb 2003 18:25:36 +0330 (IRT)

> <http://www.gnu.org/software/libidn/>

Wow! Do you know if this will be integrated into glibc?

roozbeh

---

From: Simon Josefsson <[email-masked]>
Date: Fri, 14 Feb 2003 17:05:00 +0100

> Wow! Do you know if this will be integrated into glibc?

No, I don't.  The integration work has been done, so anyone that like
to run with an IDN enabled glibc can do so easily.  Perhaps interested
distributions will pick it up, a'la initial IPv6 deployment, or the
glibc maintainers will.