Subject: Re: [idn] IDNs in IE and Google

From: Martin Duerst <[email-masked]>
Date: Fri, 13 Feb 2004 12:10:56 -0500

At 00:12 04/01/28 +0900, Soobok Lee wrote:

>Moreover, Most asian HTML homepages are published in local charset encoding
>like euc-kr, big5 and gb2312 etc. UTF-8-encoded HTML pages are extremely 
>*RARE*
>in ASIA.

There is no need to switch to UTF-8 encoded pages to use IRIs.

>Need for backward compatibility to already deployed IRI-concept and
>Unicode<->Local charset conversion layer may lay another  complexity to 
>IRI effort.

Yes. That's why I have developed the fileiri module for Apache.
See http://dev.w3.org/cvsweb/apache-modules/mod_fileiri/,
http://www.w3.org/2003/06/mod_fileiri/Overview.html
(the examples don't work if the test server isn't up),
and http://www.w3.org/2003/Talks/0904-IUC-IRI/.

The idea of this module is easy: You tell it in what encoding
the file names on your server are, per directory if you want
(probably even finer, although I haven't tested that), and
the server makes sure that the files can be retrieved both
from older browsers (which just use the encoding in the page)
as well as from newer browsers (which convert to UTF-8 before
sending out the URI).

Any comments, beta-testers, and porters are welcome!

Regards,   Martin.

---

From: Martin Duerst <[email-masked]>
Date: Fri, 13 Feb 2004 11:58:07 -0500

At 17:20 04/01/27 +0900, Soobok Lee wrote:

>Thinking that Content/Javascript/Java/Cookie security models heavily 
>depends on text
>represenatations of hostname and file path parts of URL(then IRI), MS's 
>current conservative
>postitions may be justified for security reasons.

If you have any security issues related to IRIs that are not currently
at http://www.w3.org/International/iri-edit/draft-duerst-iri.html#anchor21,
please tell me.

Regards,   Martin.