Subject: RE: using default route to reach peer

From: "Natale, Jonathan" <[email-masked]>
Date: Thu, 24 Oct 2002 11:38:12 -0400

Also, are there other implementations that have this restriction?

-----Original Message-----
From: Natale, Jonathan 
Sent: Thursday, October 24, 2002 11:37 AM
To: [email-masked]
Subject: using default route to reach peer

Folks,

IOS does not allow a BGP peer to be reached via the default route.  This
seems like a good rule to me.  Is this specified in the/a RFC/Draft
somewhere?  Should it be added as a "MAY"?

Thank You,
-Jonathan

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 24 Oct 2002 17:17:44 -0400

Pedro,

	I believe if you think about the implications
of peering with a device for which you do not have a
route learned from some routing protocol, you will
see that doing so by default is not a good idea.  If
the administrator wants to force this behavior, they
could simply add a static route for the peer.

	That said, however, I see no reason to get too
acrimonious about this issue.  It is not possible to
engineer common sense into a specification, so it is
probably fine to leave this issue alone.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> From: Pedro Roque Marques [mailto:[email-masked]]
> Sent: Thursday, October 24, 2002 5:08 PM
> To: Natale, Jonathan
> Cc: [email-masked]
> Subject: RE: using default route to reach peer
> 
> Natale, Jonathan writes:
> 
> > key word is "MAY" key concept is documenting existing behavior: "one
> > goal of the update is document existing practice"
> > --http://www.ietf.org/html.charters/idr-charter.html
> 
> Can i add to the spec 'an implementation MAY choose to calculate the
> first 100 prime numbers between generating 2 sets of update
> messages'... ?
> 
> > "The point specifically here is that an implementation must be able
> > to deal w/ potentially looping routes. i.e. a route which by being
> > installed in a routing table causes itself to be looping..."
> > ...WRONG, that is not the point.
> 
> Are you going to put forward any argument other than the capital
> letters ?
> 
> If that is not the point, do you mind giving us a rational for not
> peering over the default route. Why is it such a good idea ?
> 
> The fact of the matter is that it works just fine when the apropriate
> safe gurards against looping routes are in place, usually for
> applications other than strictly internet routing.
> 
>   Pedro.

---

From: "Natale, Jonathan" <[email-masked]>
Date: Tue, 29 Oct 2002 11:51:50 -0500

"The multihop session is not established if the only route to the multi-hop
peer's address is the default route (0.0.0.0)."
--http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/np1
_c/1cprt1/1cbgp.htm

-----Original Message-----
From: Alexei Roudnev [mailto:[email-masked]] 
Sent: Tuesday, October 29, 2002 11:32 AM
To: [email-masked]; Natale, Jonathan
Cc: [email-masked]
Subject: Re: using default route to reach peer 

> 
> In message 
> <[email-masked]
> ks.com>, "Natale, Jonathan" writes:
> > Folks,
> > 
?? Where did you found it? There is not such limuitation in IOS.

---

From: "Natale, Jonathan" <[email-masked]>
Date: Tue, 29 Oct 2002 12:20:27 -0500

Also applies to IBGP:

Cisco-2500-RtrA#bs
BGP router identifier 192.1.1.1, local AS number 4
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down
State/PfxRcd
11.10.2.12      4     4       4       3        0    0    0 00:04:56 Active
Cisco-2500-RtrA#ping 11.10.2.12

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.10.2.12, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
Cisco-2500-RtrA#sho ip route 11.10.2.12
% Network not in table
Cisco-2500-RtrA#

> Sent: Tuesday, October 29, 2002 11:52 AM
> To: 'Alexei Roudnev'; [email-masked]; Natale, Jonathan
> Cc: [email-masked]
> "The multihop session is not established if the only route to 
> the multi-hop peer's address is the default route (0.0.0.0)." 
> --http://www.cisco.com/univercd/cc/td/doc/product/software/ios
120/12cgcr/np1_c/1cprt1/1cbgp.htm

---

From: "Natale, Jonathan" <[email-masked]>
Date: Wed, 30 Oct 2002 08:47:04 -0500

Alexei,

So are you saying it does work on pre-12, or are you just assuming it does
because the docs don't say it doesn't?

This is getting old, can we drop it or are we going to check all versions of
code?   The consensus seems to already be that it will not get added to the
draft.  I am OK with this, although I stand by my original assertion that it
should be added as a "MAY" since it represents working code and could affect
interoperability; we should at least wait to see if other
(non-Juniper/non-IOS) implementations have this limitation as I tried to do
initially (before I got stomped by Pedro).

:-)

> Sent: Wednesday, October 30, 2002 2:04 AM
> To: Natale, Jonathan; [email-masked]
> Cc: [email-masked]
> I found this limitation in IOS 12.x only; and I am not sure 
> if it have any meaning
> except protection from dummy admins. Before, they had such notice:
> 
> ===
> Usage Guidelines
> This feature should only be used under the guidance of 
> technical support staff.
> ===
> 
> 
> So, it's not in the CISCO IOS, it's in very last version of 
> Cisco IOS only. And I
> do not think it's a good idea - I can image a situation when 
> I NEED to use default
> routing for ebgp link.
> 
> Alex Roudnev
> 
> ----- Original Message -----
> From: "Natale, Jonathan" <[email-masked]>
> To: "'Alexei Roudnev'" <[email-masked]>; 
> <[email-masked]>; "Natale,
> Jonathan" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, October 29, 2002 8:51 AM
120/12cgcr/np1