Subject: RE: New Issue AS path

From: "Natale, Jonathan" <[email-masked]>
Date: Fri, 4 Oct 2002 09:43:40 -0400

I hate to drag "specific vendors" in, but does Juniper also count
AS_CONFED_SET as 1?
If they do, then the section below should be changed (it now says to count
it as 0), right?

Also, what to do with AS_CONFED_SET should be spec'd.

-----Original Message-----
From: Curtis Villamizar [mailto:[email-masked]] 
Sent: Thursday, October 03, 2002 6:35 PM
To: Natale, Jonathan
Cc: 'Jeffrey Haas'; [email-masked]; [email-masked]
Subject: Re: New Issue AS path 

In message
<[email-masked]
ks.com>, "Natale, Jonathan" writes:
> What about the fact that an AS_SET counts as 1 (in IOS)???  Is that 
> already in the spec?

That's in 9.1.2.2:

      a) Remove from consideration all routes which are not tied for
      having the smallest number of AS numbers present in their AS_PATH
      attributes. Note, that when counting this number, an AS_SET counts
      as 1, no matter how many ASs are in the set, and that, if the
      implementation supports [13], then AS numbers present in segments
      of type AS_CONFED_SEQUENCE or AS_CONFED_SET are not included in
      the count of AS numbers present in the AS_PATH.

> Does juniper set AS_CONFED_SEQUENCE to 0 too?

I'd say yes but don't know for sure.

> What about AS_CONFED_SETs?  Does anybody use these?

Don't think that's every used, but if so if AS_CONFED_SEQUENCE is not
counted, it would apply to AS_CONFED_SET.

> I don't think we want to put stuff in [to the draft] just because IOS 
> does it; it might be nice to put stuff in that covers Juniper and IOS, 
> if and only if it affect interoperability.

It looks like it is already covered in draft-17.  See above.

Curtis

> -----Original Message-----
> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: Thursday, October 03, 2002 3:28 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: issue 11
> 
> 
> On Thu, Oct 03, 2002 at 03:22:02PM -0400, Curtis Villamizar wrote:
> > It would be useful to add this to the RR RFC.
> 
> That would be my preferred action.
> 
> However, I would also prefer that the AS_PATH length calculation for 
> confederation segments (i.e. they have zero value) also be moved into 
> the confed update.
> 
> > Curtis
> 
> --
> Jeff Haas 
> NextHop Technologies
>

---

From: "Natale, Jonathan" <[email-masked]>
Date: Fri, 4 Oct 2002 10:05:58 -0400

The other option here is to remover references to CONFEDs as "out of scope"
and/or "refer to RFC3065" (although I am not sure if it is/will be
sufficiently covered there).

-----Original Message-----
From: Srikanth Rao [mailto:[email-masked]] 
Sent: Thursday, October 03, 2002 6:50 PM
To: [email-masked]; Natale, Jonathan
Cc: Jeffrey Haas; [email-masked]
Subject: RE: New Issue AS path 

>>counted, it would apply to AS_CONFED_SET.

Juniper counts AS_CONFED_SET towards path length of one.

-sr-

-----Original Message-----
From: Curtis Villamizar [mailto:[email-masked]]
Sent: Thursday, October 03, 2002 3:35 PM
To: Natale, Jonathan
Cc: 'Jeffrey Haas'; [email-masked]; [email-masked]
Subject: Re: New Issue AS path 

In message

That's in 9.1.2.2:

Curtis