Subject: RE: New Issue AS path

From: "Natale, Jonathan" <[email-masked]>
Date: Thu, 3 Oct 2002 17:31:59 -0400

So what about AS_CONFED_SETs?  Are they 1 or 0?

-----Original Message-----
From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Thursday, October 03, 2002 5:21 PM
To: Natale, Jonathan
Cc: [email-masked]
Subject: Re: New Issue AS path

On Thu, Oct 03, 2002 at 05:06:59PM -0400, Natale, Jonathan wrote:
> What about the fact that an AS_SET counts as 1 (in IOS)???  Is that 
> already in the spec?

That got moved into the spec.  It even makes sense, even it means aggregates
that aggregate as_paths may have shorter paths than their contributing
routes.

> What about AS_CONFED_SETs?  Does anybody use these?

GateD supports these.

> I don't think we want to put stuff in [to the draft] just because IOS 
> does it; it might be nice to put stuff in that covers Juniper and IOS, 
> if and only if it affect interoperability.

Things that affect route selection affect everyone.  Its best to be
consistant.

-- 
Jeff Haas 
NextHop Technologies

---

From: Mathew Richardson <[email-masked]>
Date: Thu, 3 Oct 2002 17:59:32 -0400

> Natale, Jonathan <[email-masked]> [Thu, Oct 03, 2002 at 05:31:59PM -0400]:

<since>

No confederation segments count towards the path length.

mrr