Subject: RE: MED for Originated Routes

From: "Natale, Jonathan" <[email-masked]>
Date: Thu, 3 Oct 2002 16:55:19 -0400

I checked this.

Juniper sends no MED for originated routes to IBGP, Cisco sends MED = 0 for
originated routes to IBGP.  So maybe this needs to be clarified in the Base
spec.

-----Original Message-----
From: Curtis Villamizar [mailto:[email-masked]] 
Sent: Wednesday, October 02, 2002 11:46 PM
To: Natale, Jonathan
Cc: [email-masked]
Subject: Re: MED for Originated Routes 

In message
<[email-masked]
ks.com>, "Natale, Jonathan" writes:
> 
> What should the MED be for originated routes to IBGP?  No Med?  All 
> 1's? Configurable?  Is it in the draft?  Is this a new issue?  Do you 
> want more questions?

I didn't look this up in the draft yet, but the answer is:

  for IBGP:

   The MED you got from EBGP (if any)

   or configurable:

     strip off MED (if any)
     or configure a MED

  originating to IBGP, use no MED or configure one.

  for EBGP (IBGP learned or originating):

    default to no MED

    or configurable:

     put IGP cost into MED
     or configure a MED

That in a nutshell is what implementations do (AFAIK).

I don't think this level of detail needs to go into the protocol spec. But
I've been on the minority end of the consensus before so...  first lets ask
if we need this level of detail.  I think no.  Others?

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 03 Oct 2002 17:02:17 -0400

In message <[email-masked]
> originated routes to IBGP.  So maybe this needs to be clarified in the Base

I don't see an interoperability problem with that.

The question still stands - do we need to put anything about this in
the base spec?  Alex - your opinion?

Curtis