Subject: RE: inclusion of AS no in AS path

From: "Natale, Jonathan" <[email-masked]>
Date: Tue, 29 Oct 2002 12:26:40 -0500

I agree with curtis, a peer must put its AS in

maybe referring to outbound pruning that a major vendor does that is not
required and that we have reached a consensus on not adding to the draft as
a MAY even though the paper the Jeff sent indicates it is good and nobody
could answer me why it is bad. ugh

pruning is done inbound, always.

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]] 
> Sent: Tuesday, October 29, 2002 12:13 PM
> To: naresh paliwal
> Cc: [email-masked]
> Subject: Re: inclusion of AS no in AS path 
> 
> 
> 
> In message 
> <[email-masked]>, "naresh paliwa
> l" writes:
> > 
> > Is not it useful to check whether an update contains external 
> > peer's AS number in AS path attribute, avoiding this may introduce 
> > routing loop.
> > 
> > In other words, Are there situations/policies which could restrict 
> > a BGP speaker from including his AS number in the route advertised 
> > to an external peer ?
> > If yes how will routing loop be pruned?
> > 
> > regards
> > -naresh
> 
> 
> When advertising to an EBGP peer, a router MUST include its own AS in
> the path.  I can't think of any exceptions.
> 
> Curtis
>

---

From: "naresh paliwal" <[email-masked]>
Date: 30 Oct 2002 11:10:16 -0000

Curtis,

agree!

Even rfc 2858 (MPE for BGP4) tells the following:
"If such a message is received from an external peer, the local 
system shall check whether the leftmost AS in the AS_PATH 
attribute is equal to the autonomous system number of the peer 
than sent the message. If that is not the case, the local system 
shall send the NOTIFICATION message with Error Code UPDATE Message 
Error, and the Error Subcode set to Malformed AS_PATH."

This is not specific to MPE feature, then should be included in 
basic BGP4.

-naresh

On Tue, 29 Oct 2002 Curtis Villamizar wrote :
>"naresh paliwal" writes: