Subject: RE: Complex AS Path Aggregating

From: "Natale, Jonathan" <[email-masked]>
Date: Wed, 2 Oct 2002 11:40:30 -0400

The fact is that nobody does it (if anyone does do this,
please speak up), so I think is should be removed to reflect
current working code.

The test tested that the complex aggregation was done, it did not test
that complex aggregation could received gracefully; this
would be a useless test anyway, since no real world implementations do
complex aggregation.

-----Original Message-----
From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Wednesday, October 02, 2002 11:10 AM
To: Natale, Jonathan
Cc: [email-masked]
Subject: Re: Complex AS Path Aggregating

On Wed, Oct 02, 2002 at 11:06:25AM -0400, Natale, Jonathan wrote:
> AFAIK, all implementations aggregate by either: (2nd)putting ONLY the
local
> AS in the path (and setting the atomic) OR (3rd)by creating 1 giant set
and
> adding the local AS as a seq.

If vendors choose to implement the complex as path aggregation, thats
fine.  If they do simple, thats fine.

Vendors should be able to receive and use either without problem.  *That*
is what the conformance tests should test.

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 2 Oct 2002 12:02:54 -0400

> please speak up), so I think is should be removed to reflect

This is one of those things that it doesn't hurt to leave it as is,
even if no one currently does it.  Someone *could* do it, and
it should still be legal to do.

> would be a useless test anyway, since no real world implementations do

But if they did (and you could synthesize the packets easily enough),
it should be able to be received gracefully.

-- 
Jeff Haas 
NextHop Technologies