Subject: RE: draft-ietf-idr-bgp4-mibv2-03.txt

From: "Natale, Jonathan" <[email-masked]>
Date: Tue, 19 Nov 2002 10:19:24 -0500

Jeff,

I think you had suggested an object to indicate which step/attribute was
used to select/not select the route as best.  I think this is a good idea.
Has this been formally drafted anywhere?  I did not see it in
draft-ietf-idr-bgp4-mibv2-03.txt, but I may have missed it.

Thanks,
Jonathan

> -----Original Message-----
> From: Jeffrey Haas [mailto:[email-masked]] 
> Sent: Thursday, November 07, 2002 10:21 AM
> To: Gray, Eric
> Cc: [email-masked]
> Subject: Re: draft-ietf-idr-bgp4-mibv2-03.txt
> 
> 
> Eric,
> 
> On Thu, Nov 07, 2002 at 09:58:56AM -0500, Gray, Eric wrote:
> >   
> http://www.ietf.org/internet-drafts/draft-ietf-idr-bgp4-mibv2-03.txt
> > 
> > Apparently, about 3/4 of page 98 was vaporized in production,
> 
> Weird.  Looks like my "roff fixup" script has an error.  My apologies.
> 
> The missing two sections are "intellectual property" which is generic
> IETF boilerplate and the acknowledgements section.
> 
> > including all of sections 3 and 4.  Also, I think it would be
> > helpful to move the table of contents to the beginning of the
> > draft... 
> 
> Will do this for the next rev of the MIB.  This is largely 
> the raw output
> of the roff.
> 
> > Eric W. Gray
> 
> -- 
> Jeff Haas 
> NextHop Technologies
>

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 19 Nov 2002 12:09:28 -0500

Jonathon,

> used to select/not select the route as best.  I think this is a good idea.

I think operators would find this particularly useful. :-)

> Has this been formally drafted anywhere?

Not at the moment.  However, the recent draft:
    BGP Custom Decision Process (draft-retana-bgp-custom-decision-00.txt)o

gives a start to this by enumerating route selection steps.

The biggest obstacle to doing this is formally enumerating the
route selection steps and permitting them to vary from vendor to
vendor since no one seems to be interested in getting things to the
level of 100% consistancy.

Then again, something kinky (at least in the MIB) could be done
such that the object contains an index into a table that contains
the vendor's implementation of route selection.  A dump of that
table would show what all the steps are.

Given that vendors allow tweaking of the process via knob in many
cases, even that is probably not 100% feasible. 

The best we could probably hope for is a text description of where
we stopped.

> I did not see it in

At this point, I'm not arbitrarily putting stuff in the v2MIB without
group consensus.  However, given some of the recommendations made at
the IDR session (e.g. injecting multiple route instances), the
MIB may require serious tweaking.

-- 
Jeff Haas 
NextHop Technologies