Subject: aggregation in AS confed

From: "naresh paliwal" <[email-masked]>
Date: 14 Nov 2002 09:50:08 -0000

How is route aggregation performed within the AS confederation, 
especially when aggregated route is be advertised to a 
Confederation peer(Peer, belongs to the same confed).

Regards
-naresh paliwal

---

From: Danny McPherson <[email-masked]>
Date: Thu, 14 Nov 2002 17:00:02 -0700

What specifically are you referring to?  It should be performed 
no differently than it is without confederations.

-danny

---

From: "Venu Kumar G - CTD, Chennai." <[email-masked]>
Date: Fri, 15 Nov 2002 15:16:48 +0530

Hi danny,

-----Original Message-----
From: Danny McPherson [mailto:[email-masked]]
Sent: Friday, November 15, 2002 5:30 AM
To: idr
Subject: Re: aggregation in AS confed 

Danny >> What specifically are you referring to?  It should be performed 
Danny >> no differently than it is without confederations.

       Yes I too aggree, But the only missing point in the current spec,
When you do the aggregation on "confederation" feature enabled router, and
if they are intrested to add the "AGGREGATOR" attribute, In that case
AGGREGATOR attribute AS number SHOULD be the "Confederation Identifier"
instead of local "AS Number".

      Can we  document this point in the next version, and if possible can
we mention the same, what you mention above by using words
"AS_CONFED_SEQUENCE " /"AS_CONFED_SET" and comparing this with "AS_SEQUENCE"
/"AS_SET" segment types. 

Regards
Venu G.

-danny

---

From: "naresh paliwal" <[email-masked]>
Date: 15 Nov 2002 10:27:00 -0000

Should the aggregator attr contains Confed-Id in case of 
advertisement to internal or confed-peer also.

If "yes", Its not as per the rfc 3065, which quotes in section 
6:
" A member of a BGP confederation will use its Member-AS Number in 
all the transactions with peers that are memebers of the same 
confederation as the given router."

-naresh

---

From: "Venu Kumar G - CTD, Chennai." <[email-masked]>
Date: Fri, 15 Nov 2002 18:07:51 +0530

-----Original Message-----
From: naresh paliwal [mailto:[email-masked]]
Sent: Friday, November 15, 2002 3:57 PM
To: Venu Kumar G - CTD,Chennai.
Cc: Sivananda Ramnath - CTD,Chennai.; [email-masked]; idr
Subject: Re: RE: aggregation in AS confed

naresh>>Should the aggregator attr contains Confed-Id in case of 
naresh>>advertisement to internal or confed-peer also.
   
  I guess the idea of having AS no in AGGREGATOR attribute  could be
          1.  Network operators to track last aggregation (debugging
purpose)
          2.  To take some policy decisions.
       So while sending/receiving routes to/from other  BGP speakers,  In
general we take policy decisions only at AS level, not with-in AS.  So I
think Sending "Confed-ID" is the only correct option in the AGGREGATOR. All
internal BGP routers can ignore this AS no, if it contains it's own
"Confederation ID".

naresh>>If "yes", Its not as per the rfc 3065, which quotes in section 
naresh>>
6:
" A member of a BGP confederation will use its Member-AS Number in 
all the transactions with peers that are memebers of the same 
confederation as the given router."

       We can  add an exceptional case for this.

naresh>>

Regards
Venu G.

-naresh

---

From: Danny McPherson <[email-masked]>
Date: Fri, 15 Nov 2002 09:58:11 -0700

OK, I'll address this in the next rev of 3065, which should 
be within a few months as draft-mcpherson-rfc3065bis-00.txt
is already published and in the "awaiting WG acceptance" 
queue.

-danny