Subject: revised Security Consideration section

From: Yakov Rekhter <[email-masked]>
Date: Thu, 21 Nov 2002 08:14:09 -0800

Folks,

Here is a proposed revision for the Security Consideration section.
This revision reflects the discussion on making TCP MD5 a "MUST", and 
also on including by reference the BGP vulnerabilities analysis in the
base spec.

   The authentication mechanism that an implementation of BGP MUST
   support is specified in [RFC2385]. The authentication provided by
   this mechanism could be done on a per peer basis.

   Security issues with BGP routing information dissemination are 
   discussed in [XXX].

   [RFC2385] Heffernan, A., "Protection of BGP Sessions via the TCP MD5 
   Signature Option", RFC2385, August 1998.

   [XXX] Murphy, S., "BGP Security Vulnerabilities Analysis",
   draft-ietf-idr-bgp-vuln-00.txt, work in progress

Yakov.

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 21 Nov 2002 12:36:04 -0500

Yakov,

	This is exactly what I am concerned about.  Given
the delta in processing state between the current BGP
draft and Sandy's draft, this means potentially sitting
on the BGP draft for some time to come.

	As I understand it, Sandy's draft is intended to
be informational.  Therefore, it is not clear to me that
the reference needs to be normative.  As a non normative
reference, it could be referred to as a work in progress
(as it is in your proposal).

	If the reference must be normative for some reason,
it should be sufficient to include a snap-shot of Sandy's 
draft as an additional appendix and refer to that appendix 
in the security considerations section.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Thursday, November 21, 2002 11:47 AM
> To: Gray, Eric
> Cc: [email-masked]
> Subject: Re: revised Security Consideration section
> 
> Eric,
> 
> >
> > 	This change is okay with me only if the reference to
> > XXX is non normative.  Otherwise, I would suggest literally
> > including those aspects of Sandy's draft that you think
> > apply to BGP as part of the BGP RFC-to-be.  Otherwise, we
> > are back into the mode where advancing the BGP effort is an
> > open-ended proposition.
> 
> Sandy's draft (with appropriate revisions, if necessary) will be
> advanced together with the base BGP spec.
> 
> Yakov.

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 21 Nov 2002 13:08:46 -0500

Eric,

At 11:42 AM -0500 11/21/02, Gray, Eric wrote:
>apply to BGP as part of the BGP RFC-to-be.

The title of Sandy's draft is "BGP Security Vulnerabilities 
Analysis", and the Security Considerations sections says in part:

   This entire memo is about security, describing an analysis of the
   vulnerabilities that exist in the BGP protocol.

Clearly the entire thing applies to BGP.  Are you suggesting a 
complete cut-n-paste of the draft into the main spec?  If not, what 
are you suggesting?

FWIW, the proposal as written is OK by me.

Regards,

--John

---

From: "Gray, Eric" <[email-masked]>
Date: Thu, 21 Nov 2002 14:37:33 -0500

Okay.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

> From: Alex Zinin [mailto:[email-masked]]
> Sent: Thursday, November 21, 2002 2:32 PM
> To: Gray, Eric
> Cc: 'John G. Scudder'; [email-masked]
>   Some thoughts on this:
>   1. The BGP spec will need a security analysis as well
>      as the authentication mechanism in order to go through
>      the IESG.
> 
>   2. Security analysis needs to be specified either in
>      the spec itself or in a separate document. If in a
>      separate document, both docs will need to go to
>      the IESG at the same time (otherwise there is no
>      way to ensure that the requirement for a useful
>      Security Considerations section is ever satisfied).
> 
>   3. Sandy's doc seems to have a quite thorough BGP security
>      analysis. If the WG believes that more work needs
>      to be done on it, then it does not matter whether
>      the text is cut-n-pasted or stays in a separate doc.
>      If the WG believes that the security text is good
>      enough, then again it doesn't matter and we go back
>      to point 2 above.
> 
>   Thanks.
> 
> --
> Alex
> 
> Thursday, November 21, 2002, 2:16:41 PM, Gray, Eric wrote:
> > Yeah, John, as indicated in crossed-mail, I am suggesting
> > either a complete cut-and-paste or a non-normative reference.
> > Sandy's draft seems only just now to have become a WG draft
> > (the reference given by Yakov does not yet exist).  I see
> > no reason why the BGP draft needs to be held up pending
> > WG, IESG and IETF processing of Sandy's informational WIP,
> > however valuable this WIP is.
> 
> > Obviously, it would be easier to make it a non-normative
> > reference.
> 
> > An analysis of protocol vulnerability is inherently an
> > open-ended task.  I believe the key reason for rev'ing
> > the BGP specification was to update it according to what
> > implementations really do and to push it forward to
> > Draft Standard status - not solve the world's problems.  :-)
> 
> > BGP exists and is massively deployed. Clearly understanding
> > BGP security risks is important, and this information is
> > increasingly useful as it is made available.  But let's not
> > block other important work in the process...
> 
> > Eric W. Gray
> > Systems Architect
> > Celox Networks, Inc.
> > [email-masked]
> > 508 305 7214
> 
> 
> >> From: John G. Scudder [mailto:[email-masked]]
> >> Sent: Thursday, November 21, 2002 1:09 PM
> >> To: Gray, Eric
> >> Cc: 'Yakov Rekhter'; [email-masked]
> >> Subject: RE: revised Security Consideration section
> >>
> >> Eric,
> >>

---

From: [email-masked]
Date: Thu, 21 Nov 2002 14:47:24 -0500 (EST)

>however valuable this WIP is.

valuable, schmaluable.  It's required.  

How would a complete cut-and-paste help?  We'd have to re-last-call the
bgp spec.  (!)

--Sandy