Subject: bgp18 WG Last Call fsm MIB objects

From: "Tom Petch" <[email-masked]>
Date: Thu, 28 Nov 2002 17:43:35 -0000

The FSM makes several references to putting values into MIB objects
variously identified as

       Connect state

          MIB FSM error information

      Active State:

          MIB reason code
          the MIB information

      Open Sent:

           MIB state information
           MIB reason
           MIB Error reason code,

      Open Confirm State:

           the appropriate MIB information
           MIB Reason code
           the MIB entry for this peer
           the MIB reason
           the MIB reason code
           the MIB FSM variable

      Established State:

            MIB reason code,
            MIB reason code
            MIB Reason code

I can find no objects with names resembling these in either of the two
draft MIBs.  My guess would be that in most cases it is either
- bgpM2PeerLastErrorReceived/bgpM2PeerLastErrorSent from
draft-ietf-idr-bgp4-mibv2-03.txt
or
- bgpPeerLastError from draft-ietf-idr-bgp4-mib-10.txt

I believe this needs defining more clearly, probably with a reference
to the relevant MIB document.  (Currently I see no MIB document in the
list of references).

Tom Petch
[email-masked]

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 29 Nov 2002 20:36:24 -0500

> The FSM makes several references to putting values into MIB objects

To make everyone's life easier, the MIB references will be removed from
the FSM and the MIB will incorporate the "do this here" references.

This way we don't have to worry about MIB object taxonomy getting out
of sync with the base specification.

> to the relevant MIB document.  (Currently I see no MIB document in the

I'm taking this as a work item for the MIBv2.  The MIBv1 is basically
going up for informational/historical status. (i.e. this is what *is*
implemented, but not what we are going to use for standards purposes).

-- 
Jeff Haas 
NextHop Technologies