Subject: Why MinRouteAdverInterval is recommended 30

From: "Qiu Jian" <[email-masked]>
Date: Fri, 1 Nov 2002 15:37:42 +0800

Hello, idr

    I am a graduate student and hope you kindly give
me some help.
	I have a question on MinRouteAdverInterval:
    Why MinRouteAdverInterval is recommended to
 be 30 seconds? 
    Is it right to say that the Maximal Propagation 
Delay in Internet is almost less than 30 seconds, 
so MinRouteAdverInterval is set to 30 seconds to 
guarantte the furthest route change can be caught 
before sending the relevant update?
    Thank you very much!
Have a nice day!

　　　　　　　　Qiu Jian
　　　　　　　　[email-masked]
　　　　　　　　　　2002-11-01

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 1 Nov 2002 10:29:30 -0500

> Delay in Internet is almost less than 30 seconds, 

This is a matter of some debate.

> before sending the relevant update?

Theoretically, this means that if a route is still reachable (feasible),
then you will delay sending changes to the route.  This will
cause the entire routing system (in this case, possibly the Internet)
to have potential for blackholes and forwarding loops due to these
timers for some period of time.  The following paper goes into 
some details on this:

http://www.acm.org/sigcomm/sigcomm2000/conf/paper/sigcomm2000-5-2.pdf

-- 
Jeff Haas 
NextHop Technologies