Subject: Re: bgp18 WG Last Call fsm delete action

From: "Tom Petch" <[email-masked]>
Date: Thu, 28 Nov 2002 14:52:15 -0000

I do not know either why the action is present in OpenSent and
OpenConfirm states but that is a separate (and valid) issue.  My
concern is that where we have one and the same action, we use the same
description (which may then make other issues more clear).

My guess is that it stems from the OpenDelay mechanism so that while
in OpenSent or OpenConfirm states, the exchange of Open messages
completes successfully, KeepAlive can arrive hotly followed by Update
messages.  Note that at least in some cases in OpenSent and
OpenConfirm states, the KeepAlive is sent as part of the action list
so that Updates could start arriving before the action list is
complete and so, depending on the FSM implementation view of single
threading, Updates can arrive too.  Just a guess.

Tom Petch
[email-masked]

-----Original Message-----
From: Venu Kumar G - CTD, Chennai. <[email-masked]>
To: Tom Petch <[email-masked]>; idr <[email-masked]>
Date: 28 November 2002 05:46
Subject: RE: bgp18 WG Last Call fsm delete action

>HI,
>
>         I could not understand the idea behind addding   "deleting
route
>associated with BGP sessioon...x" text in OpenSent  and  OpenConfirm
state.
>We can only receive  routes  when we in "Established" state,  and
their is
>no action or event in FSM, with that we can move to "OpenConfirm" or
"Open
>Sent " State, when we are in "Established" state.
>
>
>Venu G.
>
>
>-----Original Message-----
>From: Tom Petch [mailto:[email-masked]]
>Sent: Wednesday, November 27, 2002 11:11 PM
>To: idr
>Subject: bgp18 WG Last Call fsm delete action
>
>
>In several places in the FSM, under Open Sent, Open Confirm,
>Established states, there is an action relating to delete routes
which
>is variously described as
>
>      Open Sent:
>
>        - if there are any routes associated with the BGP session,
>         delete these routes
>
>        - if any routes are associated with te BGP session,
>          delete the routes,
>
>      Open Confirm State:
>
>        - if any BGP routes, dete the routes
>
>        - If any BGP routes exist, delete the routes,
>
>        - deletes all routes associated with connection,
>
>      Established State:
>
>        - if any BGP routes exist, delete all BGP routes,
>
>        - deletes all routes associated with bgp connection,
>
>        - deletes all routes associated with connection,
>
>        - deletes all routes associated with BGP connection,
>
>If, as I believe, this is always the same action, then I would like
>the same description in every case.  I suggest
>
>        - deletes all routes associated with this connection,
>
>Tom Petch
>[email-masked]
>
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 29 Nov 2002 20:23:26 -0500

Tom,

> description (which may then make other issues more clear).

In the OpenSent and OpenConfirm states, there should be no routes to
be deleted.  This is an error in the document.

-- 
Jeff Haas 
NextHop Technologies