Subject: RE: draft-ietf-idr-bgp-identifier-02.txt

From: "Krishnan, Vijay G." <[email-masked]>
Date: Tue, 8 Apr 2003 11:37:32 -0400

Hi Enke,

>Please see the following text in the Remarks Section of the draft:
>
>   A BGP speaker that supports the AS-wide Unique BGP Identifier can not
>   share a BGP Identifier with its external neighbor until the remote
>   BGP speaker is upgraded with software that supports the proposed
>   revisions.

Is there be a way of knowing whether the peer supports AS-wide unique ID? I
didn't see any new capability in the draft. 

regards
Vijay

---

From: Enke Chen <[email-masked]>
Date: Tue, 08 Apr 2003 11:16:13 -0700

Hi, Vijay:

> Message-ID: <[email-masked]>
> From: "Krishnan, Vijay G." <[email-masked]>
> To: "'Enke Chen'" <[email-masked]>
> Cc: [email-masked]
> Subject: RE: draft-ietf-idr-bgp-identifier-02.txt 
> Date: Tue, 8 Apr 2003 11:37:32 -0400 
> 
> Hi Enke,
> 

BGP capability is good at dealing with optinal features. However, it does not
seem to help in this case as the BGP identifier is mandatory:

     - For an existing BGP speaker that has a globally unique identifier,
       there is no issue.

     - For an ipv6-only speaker, if the identifier is the same as that
       of the remote speaker, the session will not be up until the software
       is upgraded (regarless of whether a new capability is introduced).

Regards,

-- Enke