Subject: [Idr] Re: WG Last Call on BGP MIB - normalised names

From: "Tom Petch" <[email-masked]>
Date: Wed, 20 Aug 2003 19:48:52 +0100

Agreed, we must not change the names of the enumerations or objects;
what I was suggesting was that in the description, where it refers to
stop and start, that is now ambiguous as we have multiple stops and
starts and so the description should include Manual.... as per the
normalised event names in the base spec for events 1 and 2.

The base has normalised names for the timers and here is where there
might be confusion since the names are or may be different and so I
think the MIB needs a cross reference. I have pushed for the terms
KeepaliveTime, HoldTime, IdleHoldTime, DelayOpenTime ;-) etc to be
explicitly the initial value to which the corresponding Timer is set.
The MIB refers to some of these but uses a different name - hence the
need for a mapping for those present in the current MIB. eg

'bgpPeerKeepAlive corresponds to the KeepaliveTime session attribute
as defined in [BGP4]'

The mapping of OpenSent to opensent I think obvious enough not to need
explanation.

Tom Petch

----Original Message-----
From: Jeffrey Haas <[email-masked]>
To: Tom Petch <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: 20 August 2003 17:42
Subject: Re: WG Last Call on BGP MIB - normalised names

>On Wed, Aug 20, 2003 at 04:39:34PM +0100, Tom Petch wrote:
>> Normalised names - um.  Now we have normalised names in the base
bgp
>> spec - good, great, why didn't I think of that? - they are ideal
for
>> SNMP ( adding a 'bgp' prefix).
>>
>> Except we already have some names in the MIB and they are
different;
>> for me this means we should not be last calling the MIB until we
are
>> last calling the base spec.
>>
>> A simple change to the MIB is to specify ManualStart and ManualStop
in
>> bgpPeerAdminStatus.
>
>I don't believe we're allowed to change the names of enumerated
values.
>I will check on this.
>
>> A change we should not make is to bring the states in line (eg
>> opensent as opposed to OpenSent).
>
>Ditto.
>
>> But it is the timers that make me think we must wait.  We will need
a
>> reference from MIB to optional attribute names as defined in the
FSM
>> and I don't think we are yet agreed enough on the latter to make
those
>> references.
>
>The v2MIB is intended to reflect all of the details of the updated
>BGP specification.  This draft is largely intended to fix up the
>previously published MIB, note some obvious changes and to fix
>a problem with the traps.  So, don't expect to see any sweeping
changes
>reflected here.
>
>Generally, the idea is to not disrupt operator's lives any more than
>is necessary.  Unfortunately, the "fix" to the traps/notifications
>will do that.
>
>(More on that in a later email.)
>
>> Tom Petch,
>
>--
>Jeff Haas
>NextHop Technologies

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Tom Petch" <[email-masked]>
Date: Wed, 20 Aug 2003 19:48:52 +0100

Tom Petch

----Original Message-----
From: Jeffrey Haas <[email-masked]>
To: Tom Petch <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: 20 August 2003 17:42
Subject: Re: WG Last Call on BGP MIB - normalised names

bgp
for
different;
are
in
values.
a
FSM
those
changes