Subject: Re: [Idr] comments on idr-bgp4-20

From: Yakov Rekhter <[email-masked]>
Date: Tue, 07 Oct 2003 13:21:25 -0700

Pekka,

> substantial
> -----------
> 
> 1) Section 3 on Summary of the Operations, states:
> 
>    In the context of this document we assume that a BGP speaker adver-
>    tises to its peers only those routes that it itself uses (in this
>    context a BGP speaker is said to "use" a BGP route if it is the most
>    preferred BGP route and is used in forwarding). All other cases are
>    outside the scope of this document.
> 
> this "usability" requirement is in conflict with section 4.3 on UPDATE
> message format:
> 
>    An UPDATE message is used to advertise feasible routes sharing common
>    path attributes to a peer, [...]
> 
> ==> in particular note that "feasible" is a superset of "only those routes
> the router itself uses" (compare to "those routes the router itself _could_
> use if they were the most preferred ones"), right?

Keep in mind that the term "feasible" applies to routes *being* advertised 
by a BGP speaker (in BGP UPDATE messages). Such routes are available for use 
*by the recipients* (by the BGP speakers that receive these UPDATE messages).
And according to Section 3, to be feasible, a route has to be used by the 
router that advertises such a route as feasible.

To clarify I'll fix the definition of Feasible route as follows:

  Feasible route

     An advertised route that is available for use by the recipient.

Yakov.

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 07 Oct 2003 13:21:25 -0700

Pekka,

  Feasible route

Yakov.

---

From: Pekka Savola <[email-masked]>
Date: Wed, 8 Oct 2003 09:02:10 +0300 (EEST)

>      An advertised route that is available for use by the recipient.

This addresses my concern about ambiguity.  Thanks.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Pekka Savola <[email-masked]>
Date: Wed, 8 Oct 2003 09:02:10 +0300 (EEST)