Subject: [Idr] Question about RFC 3107 Carrying label in bgp-4

From: [email-masked]
Date: Thu, 3 Jun 2004 11:21:03 -0500

Hi,

I will use 
  192.168.0.0/16   as an ip prefix, and
  0x102031         as an mpls label
in the following questions.

RFC 3107 (Carrying Label Information in BGP-4) 
Section 3 states 
0x102031:192.168.0.0/16 can be advertised in a
MP_REACH_NLRI. 
It can be withdrawn by either 
 a) a new route with a new label:
    0xB1B2B3:192.168.0.0/16 in MP_REACG_NLRI
or
 b) 0x800000:192.168.0.0/16 in a MP_UNREACH_NLRI.

In Section 4, it states that multiple routes to the
same destination, but different labels can be
maintained and advertised. 

This seams to contradict to Section 3 a).
If Section 3 a) is used, both routes would have
been kept by peer, instead of deleting
  0x102031:192.168.0.0/16 and keeping
  0xB1B2B3:192.168.0.0/16.

Section 4 also states that
  a peer would keep both
  192.168.0.0/16 and 0x102031:192.168.0.0/16 
  if 192.168.0.0/16 is advertised with 
   (AFI=1, SAFI=1) and
  0x102031:192.168.0.0/16 is advertised with
   (AFI=1, SAFI=4).

Does this contradicts to BGP's general principle that
only one route from a peer is kept?

Does this also implicitly mean that
0x102031:192.168.0.0/16 cannot be used for regular
ipv4 unicast routing?

It looks to me that the entire Section 4 is
contradictory.

--
Qi Ning

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Pedro Roque Marques <[email-masked]>
Date: Fri, 4 Jun 2004 15:33:48 -0700

qning  writes:

> Hi, I will use 192.168.0.0/16 as an ip prefix, and 0x102031 as an
> mpls label in the following questions.

> RFC 3107 (Carrying Label Information in BGP-4) Section 3 states
> 0x102031:192.168.0.0/16 can be advertised in a MP_REACH_NLRI.  It
> can be withdrawn by either a) a new route with a new label:
> 0xB1B2B3:192.168.0.0/16 in MP_REACG_NLRI or b)
> 0x800000:192.168.0.0/16 in a MP_UNREACH_NLRI.

Not commenting on the spec...

The implementations i'm aware of treat the IP prefix as the NLRI key
for safi-4 and the label as a per nlri attribute.

As such an update for a given IP prefix implicitly withdrawn the
previously advertised label.

Another area to be concerned in terms of interoperability is the fact
that some implementations seem to consider a SAFI=1 update/withdrawl
for the same prefix to update the safi=4 information...
Not JunOS implementation, however...

JunOS considers a safi=4 update and a safi=1 update to refer to
different routing databases...

You may want to verify some of these details if you are concerned w/
interoperability...

  Pedro.