Subject: [Idr] Next Hop changes

From: "ephim era" <[email-masked]>
Date: 7 Jul 2004 07:41:50 -0000

Hi All,

Is there a scenario (protocol, deployment, configuration) wherein a change in BGP nexthop could lead to sea of changes in IGP routes (or vice-versa) ?

Thanks in advance,
Ephim

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "ephim era" <[email-masked]>
Date: 10 Jul 2004 09:54:20 -0000

>Is there a scenario (protocol, deployment, configuration) wherein a change in BGP nexthop could lead to sea of changes in IGP routes (or vice-versa) ?

 case excluding redistribution of routes... ?

---

From: "Naidu, Venkata" <[email-masked]>
Date: Sun, 11 Jul 2004 11:35:36 -0400

John,

-> > I also feel that the concept of things like HOT Potato 
-> come into play only 
-> > in the case when 1 protocol has to depend on the other. 
-> Though, if I look up 
-> > the defination of Hot Potato in some classic books like 
-> Data Networks by 
-> > Robert Gallager and Dimitri Bertsekas , it does not seem 
-> to be what is 
-> > referred to as "Hot Paotato" in some other papers and 
-> discussions that I 
-> > see. The case and examples in the books never talk about 
-> multiple protocols 
-> > to put forth the point of Hot Potato routing.
-> >  
-> > Perhaps someone could help clarify the definations in the 
-> 1st place,

  Yes. 'Hot-Potato routing' is an over-used term in routing and
  leads to confusion.
  
  I think, you are referring to book's classical defination:
http://www.amazon.com/exec/obidos/tg/detail/-/0132009161/103-4767008-2544628
?v=glance

  In data networks, hot-potato routing is nothing to do with
  BGP or IGPs. Rather more to do with queuing and buffer length
  estimations. Where packets are never buffered in routers 
  queues and never dropped(unlike today's store and forward 
  technique). Packets are always bounced back till reaches the 
  destination.

  And this defination of 'get rid of packet from router's 
  buffer as soon as possible' has changed to 'get rid of packet
  from the domain as soon as possible'. This has been
  transformed to 'nearest exit' - which is not the original
  intended definition.

Venkata.

---

From: "ephim era" <[email-masked]>
Date: 31 Jul 2004 09:27:55 -0000

Folks,

Sorry, I wasn't in town. I was working on some routing table implementation and redistribution of routes .... (RFC 1745 BGP -- OSPF interactions) it's been made historical... but do vendors provide that feature ? it's available on cisco tho' say when I redist static into BGP(AS A) redist BGP to IGP ( in transit AS B) and back from IGP to BGP in at border of transit --> BGP(AS C) I saw the origin being lost from incomplete to IGP!!! (safely assume IGP as OSPFv2)

How valid is this RFC 1745... I understand that BGP route reflectors are designed to avoid BGP-IGP redistibution in transit AS. But RR mechanism is pretty new. Should any new implementatino of BGP & OSPF support (least partally) RFC 1745 ?

Thanks in advance,
-Ephim

 Sun, 11 Jul 2004 Tony Li wrote :
>I'll try to answer both:
>
>1) A change in BGP next hops should never lead to a change in IGP routes unless someone is doing redistribution.  It _can_ of course,
>change how traffic flows internal to the domain.
>
>2) Hot potato routing is also known as "nearest exit".  The basic philosophy is that a transit provider wants to hand off the traffic
>with the fewest number of fiber miles/router hops/overall expense.  Multiple protocols are not required.
>
>Tony
>
>
>On Jul 10, 2004, at 3:23 AM, john smith wrote:
>
>>
>>I am amazed no one has answered to this post.
>>
>>I have never seen the changes in BGP causing changes in IGP, as we rarely ever have cases where people do BGP-->IGP. It would bring down your network though :)
>>
>>I also feel that the concept of things like HOT Potato come into play only in the case when 1 protocol has to depend on the other. Though, if I look up the defination of Hot Potato in some classic books like Data Networks by Robert Gallager and Dimitri Bertsekas , it does not seem to be what is referred to as "Hot Paotato" in some other papers and discussions that I see. The case and examples in the books never talk about multiple protocols to put forth the point of Hot Potato routing.
>>
>>Perhaps someone could help clarify the definations in the 1st place,
>>
>>-brgds
>>JS
>>
>>
>>> From: "ephim  era" <[email-masked]>
>>>Reply-To: ephim  era <[email-masked]>
>>>To: [email-masked]
>>>Subject: Re: [Idr] Next Hop changes
>>>Date: 10 Jul 2004 09:54:20 -0000
>>>
>>>
>>>
>>>
>>_________________________________________________________________
>>MSN 8 with e-mail virus protection service: 2 months FREE* http://join.msn.com/?page=features/virus
>>
>>