Subject: RE: [Idr] draft-ck-bgp-atm-nlri-01.txt to become a working group document?

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Tue, 14 Dec 2004 12:10:51 -0500

Curtis Villamizar wrote:
[snipped]

> Yes, in principal PNNI is like an IP IGP and BGP could be its exterior
> routing protocol.  ATM itself is end-to-end connection oriented and
> ATM SVC service has never been offerred by any major provider so
> arguments of scaling due to not having an exterior routing protocol
> completely fall apart.

This has nothing to do with SVCs. The draft proposes to solve routing issues that might arise when an MPLS network is used to interconnect previously independent ATM islands. Signaling (whether it is to set up SVCs or, as is much more common, SPVCs) has its own issues, but is not necessarily impacted by the use of an MPLS core network and is completely independent of the routing protocols used.

> 
> It is not unreasonable for an IETF WG to demand strong indication that
> there is a clear requirement for anything that the WG is asked to
> consider as a WG work item.  We've asked and there has been no
> indication from any provider of any need for this.

I too am anxiously waiting for Service Providers who might benefit from the solution to speak up. It should be noted, though, that the people who run ATM networks usually don't subscribe to the IDR mailing list and therefore might not as readily respond as one would hope.

> Curtis

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Curtis Villamizar <[email-masked]>
Date: Tue, 14 Dec 2004 13:11:23 -0500

In message <[email-masked]>
"Busschbach, Peter B (Peter)" writes:
> This has nothing to do with SVCs. The draft proposes to solve routing
> issues that might arise when an MPLS network is used to interconnect
> previously independent ATM islands. Signaling (whether it is to set up
> SVCs or, as is much more common, SPVCs) has its own issues, but is not
> necessarily impacted by the use of an MPLS core network and is
> completely independent of the routing protocols used.

My point was that scaling is terrible if you need PVCs because you
must either settle for partial connectivity or an unscalable full
mesh.  If partial connectivity is the goal, then ATM becomes just a
VPN technology.

> I too am anxiously waiting for Service Providers who might benefit
> from the solution to speak up. It should be noted, though, that the
> people who run ATM networks usually don't subscribe to the IDR mailing
> list and therefore might not as readily respond as one would hope.

And they are all too clueless to figure out how to subscribe?  If a
provider intending to use this does exist, you might want to mention
that this probably won't happen in the IETF if they remain silent.

The argument that demand exists but the providers are too shy doesn't
count for anything.  Nor does the argument that they really need this
but they don't yet really know that they really need this.

Curtis