Subject: [Idr] ORGIN priority & and Routing Protocol priority..

From: "P, Sridhar (Sridhar)" <[email-masked]>
Date: Fri, 17 Dec 2004 12:22:50 +0530

orgin :
the priority in assinging the orgin of the route entry is 
IGP
EGP 
and INCOMPLETE.
 
the preference among the routing protocols are 
EGP 
IGP ..

it is contridicting...like 

(AS-X)------(AS-1)------(AS-2)

Net A is adv from AS-X to AS-1 as a ebgp route.
i have Net A learned as igp in AS-1 (via IGP) so  while updating into bgp it
updates as IGP orgin because of orgin priority....
and if packet comes to AS-1 to reach AS-X it prefers AS-x path because of
route protocol priority...
so both are contridicting...can someone explain this....
 
Sridhar P 
* Lucent Technologies MultiService Switching
* 91-80-51191190
* [email-masked] 
 
_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 17 Dec 2004 16:01:18 -0500

In message <[email-masked]>
> * Lucent Technologies MultiService Switching

Your routing policy should be set so that you should never repair an
IGP fault with routes learned by BGP.

The typical use of the above is if you advertise a single homed
customer's route which is a static in your IGP you also announce the
same static with BGP communities into IBGP.  The border routers should
prefer the IBGP route in order to be able to use the BGP communities
to make use of BGP export policy based on BGP communities.

Announcing an IGP route into IBGP was initially considered an abuse of
BGP but it had the practical application of being able to carry BGP
communities so the practice stuck.

Curtis