Subject: Re: [Idr] BGP nexthop calculation question

From: Jeffrey Haas <[email-masked]>
Date: Mon, 4 Apr 2005 13:03:28 -0400

Acharya,

On Mon, Feb 28, 2005 at 02:48:20AM +0000, Acharya wrote:
> Infact, since the latest versions of BSD, and Linux
> since the start, allow IF-address configuration as in:
> eth1 = 10.10.10.1/24 and eth2 = 10.10.10.2/24, its
> next to imppossible to actually detect, on the RUT,
> whether two Nbrs have direct connectivity or not.

In ipv4, in the above configuration, you are declaring that both
of the above interfaces are on the same logical subnet.  If they
don't share a common physical subnet, this is a configuration 
error.

In ipv6, for ipv6 link-local addresses, this would be different.
However, RFC 2545 mandates that a global address be sent with
the nexthop.  As such, it is possible for two global addresses
be configured on the subnet as above.  For purposes of first
vs. third party nexthop behavior, the check is against the
global address since it is a nonsensical check against the
link-local address.

[elided]
> The above statement makes the provision of a command
> akin to "nexthop-self" mandatory.
> 
> This would become a requirement if both TR2 and TR1,
> in Cleary's example, are IPv6-Link-local neighbors
> which donot have direct reachability to each other.
> Then its impossible for the RUT to check whether "the
> router" is reachable for the neighbor!

There was a proposal a while back for utilizing link-local peering
sessions.  In this proposal, only a link-local address was exchanged
in the MP-BGP nexthop field.  I don't believe this proposal ever
gained traction in the IDR WG.

> Acharya.

-- 
Jeff Haas 
NextHop Technologies

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Acharya <[email-masked]>
Date: Sat, 23 Apr 2005 04:19:46 +0100 (BST)

Jeff,

> don't share a common physical subnet, this is a

They need not share a common physical subnet and it
actually makes no difference whether they do share a
common physical subnet or not. One may say certain
aspects of the network may be undefined but as its
today with linux/netbsd, it is configurable and valid
since both interfaces come up fine and one can ping
and do the "regular stuff".

> In ipv6, for ipv6 link-local addresses, this would

Configuring overlapping addresses on different
physical I/Fs was allowed in dual-stack Linux/Netbsd
basically because of the L-Local IPv6 addresses all
having the same subnet mask by default. So v6 LLocal
is no strange scenario or in any way different. So in
the dual-stack kernels, other a-families (non-LLocal)
have just been made to fall inline with the same
checks in code.

> global address since it is a nonsensical check

If one configures LLocal neighbors, there is no way
the NHop can be Global. (Also see the following
comment)

> gained traction in the IDR WG.

Well, if NextHop.com does not support configuring BGP
peers with LLocal Addresses just because your belief
against it, doesnt mean the world will follow. Infact
the world  (Cisco & Junos) does allow configuring BGP
peers with LLocal addresses. So NextHop.com better
follow suite! Nothing personal here.

Infact, 2545 does not explicitly preclude the use of
LLocal NHop addresses with "MUST NOT"/"SHALL NOT"
(uppercase). Its terminology is more suggestive than
preclusive.

Acharya.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com