Subject: [Idr] I-D Action:draft-ietf-idr-rfc4760bis-00.txt

From: [email-masked]
Date: Mon, 10 Jan 2011 09:45:06 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

	Title           : Multiprotocol Extensions for BGP-4
	Author(s)       : R. Chandra, et al.
	Filename        : draft-ietf-idr-rfc4760bis-00.txt
	Pages           : 12
	Date            : 2011-01-10

This document defines extensions to BGP-4 to enable it to carry
routing information for multiple Network Layer protocols (e.g., IPv6,
IPX, L3VPN, etc...). The extensions are backward compatible - a
router that supports the extensions can interoperate with a router
that doesn't support the extensions.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-idr-rfc4760bis-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Ilya Varlashkin <[email-masked]>
Date: Mon, 10 Jan 2011 21:09:26 +0100

As I've previously mentioned in private conversation, this draft seem like a perfect place to address an issue of intermixing various SAFI of the same AFI. The problem has been discussed here at IDR ("interoperability of 6PE and native-IPv6 within same network" - http://www.ietf.org/mail-archive/web/idr/current/msg04364.html). What's group view on adding something along following line to the draft: if a route has been learned from AFI=x SAFI=y1, then BGP speaker MAY NOT advertise it over a SAFI=y2 session unless speaker sets itself as NEXT_HOP?

Kind regards,
iLya

On Jan 10, 2011, at 18:45 , [email-masked] wrote:

> <Mail Attachment>_______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

/iLya

---

From: zengqing <[email-masked]>
Date: Thu, 13 Jan 2011 10:03:19 +0800

Hi Tony & Ravi & Dave & Yakov,

I have one question about section 10, 
	10. Comparison with RFC4760					
			This document explicitly spells out that receiving an UPDATE message	
			that carried MP_REACH_NLRI or MP_UNREACH_NLRI attribute, with the	
			attribute carrying no NLRI, must not be treated as an error.
NLRI is equal to the index of Update information. 
If no NLRI, should the info be global or network wide? 
Would you like to tell us what is possible scenarios?

Thanks and Regards
Qing

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, January 11, 2011 1:45 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Idr] I-D Action:draft-ietf-idr-rfc4760bis-00.txt
> 
> This document defines extensions to BGP-4 to enable it to carry routing
> information for multiple Network Layer protocols (e.g., IPv6, IPX, L3VPN, etc...).
> The extensions are backward compatible - a router that supports the
> extensions can interoperate with a router that doesn't support the extensions.
>

---

From: Enke Chen <[email-masked]>
Date: Wed, 12 Jan 2011 18:30:38 -0800

Hi, Qing:

Here is an application described in RFC 4724 (Graceful Restart for BGP):

-------------------------

2.  Marker for End-of-RIB

    An UPDATE message with no reachable Network Layer Reachability
    Information (NLRI) and empty withdrawn NLRI is specified as the End-
    of-RIB marker that can be used by a BGP speaker to indicate to its
    peer the completion of the initial routing update after the session
    is established.  For the IPv4 unicast address family, the End-of-RIB
    marker is an UPDATE message with the minimum length [BGP-4].  For any
    other address family, it is an UPDATE message that contains only the
    MP_UNREACH_NLRI attribute [BGP-MP] with no withdrawn routes for that
    <AFI, SAFI>.
--------------------------

-- Enke

On 1/12/11 6:03 PM, zengqing wrote:
> Hi Tony&  Ravi&  Dave&  Yakov,
>
> _______________________________________________
> Idr mailing list
> [email-masked]

---

From: zengqing <[email-masked]>
Date: Thu, 13 Jan 2011 11:03:45 +0800

Hi, Enke:

Thanks for your reply, I had known the case of End-of-RIB, and is it the only one possible scenarios?

Regards
Qing

> From: Enke Chen [mailto:[email-masked]]
> Sent: Thursday, January 13, 2011 10:31 AM
> To: zengqing
> Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Idr] A question about no NLRI. RE: I-D
> Action:draft-ietf-idr-rfc4760bis-00.txt
> 
> Hi, Qing:
>