Subject: Re: [Idr] draft-ymbk-bgp-extended-messages-01

From: Jakob Heitz <[email-masked]>
Date: Wed, 13 Apr 2011 13:29:22 -0400

I think you're the one throwing numbers, because you
have no clue how much you need.

Show me the 65535 long BGP message.

--
Jakob Heitz.

> -----Original Message-----
> From: Randy Bush [mailto:[email-masked]] 
> Sent: Tuesday, March 22, 2011 9:03 PM
> To: Jakob Heitz
> Subject: Re: [Idr] draft-ymbk-bgp-extended-messages-01
> 
> > Sorry Randy, I didn't get your point.
> 
> well, a typo probably did not help
> 
> >>> How about some numbers:
> >>> maximm message size = 65000
> >>> maximum update message size = 64000
> >>> 
> >>> It won't hurt anyone to have it a little short of 65535 
> and it gives
> >>> us a little playroom for the "what if" cases.
> >> 
> >> throwing kitty litter over your off by onw errors is a giggle.
> >> trying to cover up an off by 1000 error had me laughing for five
> >> minutes.
> 
> s/onw/one/
> 
> you're just throwing numbers because you do not really know what you
> need.  you are reversing the solution.  there should be no what if
> cases.
> 
> randy
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 14 Apr 2011 03:26:02 +0900

> Show me the 65535 long BGP message.

check out the bgpsec work in sidr wg.

randy
---
Q: Because it reverses the logical flow of conversation.
A: Why is top posting frowned upon?

---

From: Jakob Heitz <[email-masked]>
Date: Wed, 13 Apr 2011 14:45:58 -0400

I see a 256 byte signature added at each AS
and a single NLRI in each update.

How many AS's do you want to pass through?

--
Jakob Heitz.

> Sent: Wednesday, April 13, 2011 11:26 AM
> To: Jakob Heitz
> Cc: [email-masked]

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 13 Apr 2011 15:36:15 -0400

> Show me the 65535 long BGP message.

Ignoring SIDR for the moment.

If I remember this right, a 4K BGP update holds over 500 prefixes.  I
can remember way back in the early BGP4 days when there were plenty of
times where the 4K BGP update filled and a new update had to be
created.  That code was well exercises 15 years ago.

I seriously doubt we are doing a great job aggregating and there are
no more AS announcing more than 500 prefixes with the same AS_PATH and
other attributes.

Add to that the many uses of MP-BGP and SIDR and packets can get quite
big.  Certainly larger than 4K.

Curtis