Subject: Re: [Idr] WG adoption of "IPv6 AF Extensions for Route Target Distribution"

From: Keyur Patel <[email-masked]>
Date: Thu, 14 Apr 2011 09:14:26 -0700

Support.

Keyur

On 3/31/11 8:54 AM, "Jie Dong" <[email-masked]> wrote:

> Dear all, 
> 
> Authors of "IPv6 AF Extensions for Route Target Distribution" would like to
> propose to adopt this draft as IDR WG document.
> 
> The draft could be found at:
> http://tools.ietf.org/html/draft-keyur-bgp-af-specific-rt-constrain-01
> 
> 
> Best regards,
> Keyur Patel
> Robert Raszuk
> Martine Djernaes
> Jie Dong
> Mach Chen
> 
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "Balaji Pitta Venkatachalapathy (bvenkata)" <[email-masked]>
Date: Thu, 14 Apr 2011 21:55:52 +0530

support

Balaji
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jie Dong
Sent: Thursday, March 31, 2011 8:54 AM
To: [email-masked]
Subject: [Idr] WG adoption of "IPv6 AF Extensions for Route
TargetDistribution"

Dear all, 

Authors of "IPv6 AF Extensions for Route Target Distribution" would like
to propose to adopt this draft as IDR WG document.

Best regards,
Keyur Patel
Robert Raszuk
Martine Djernaes
Jie Dong
Mach Chen

---

From: "Selma Yilmaz (seyilmaz)" <[email-masked]>
Date: Thu, 14 Apr 2011 11:34:21 -0700

Support

Selma Yilmaz

---

From: Xu Xiaohu <[email-masked]>
Date: Fri, 15 Apr 2011 09:50:21 +0800

Support.

Xiaohu

> > Authors of "IPv6 AF Extensions for Route Target Distribution" would like
to

---

From: Mach Chen <[email-masked]>
Date: Fri, 15 Apr 2011 03:02:59 +0000

Support!

Best regards,
Mach

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Jie
> Dong
> Sent: Thursday, March 31, 2011 11:54 PM
> To: [email-masked]
> Subject: [Idr] WG adoption of "IPv6 AF Extensions for Route Target Distribution"
> 
> Dear all,
>

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 14 Apr 2011 23:42:53 -0400

support

--
Jakob Heitz.

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jie Dong
> Target Distribution"
> Authors of "IPv6 AF Extensions for Route Target Distribution" 
> would like to propose to adopt this draft as IDR WG document.
>

---

From: <[email-masked]>
Date: Fri, 15 Apr 2011 11:06:36 +0200

Support

On 3/31/11 8:54 AM, "Jie Dong" <[email-masked]> wrote:

> Dear all,
> 
> Authors of "IPv6 AF Extensions for Route Target Distribution" would 
> like to propose to adopt this draft as IDR WG document.
> 

********************************************************************************
IMPORTANT.Les informations contenues dans ce message electronique y compris les fichiers attaches sont strictement confidentielles
et peuvent etre protegees par la loi.
Ce message electronique est destine exclusivement au(x) destinataire(s) mentionne(s) ci-dessus.
Si vous avez recu ce message par erreur ou s il ne vous est pas destine, veuillez immediatement le signaler  a l expediteur et effacer ce message 
et tous les fichiers eventuellement attaches.
Toute lecture, exploitation ou transmission des informations contenues dans ce message est interdite.
Tout message electronique est susceptible d alteration.
A ce titre, le Groupe France Telecom decline toute responsabilite notamment s il a ete altere, deforme ou falsifie.
De meme, il appartient au destinataire de s assurer de l absence de tout virus.

IMPORTANT.This e-mail message and any attachments are strictly confidential and may be protected by law. This message is
intended only for the named recipient(s) above.
If you have received this message in error, or are not the named recipient(s), please immediately notify the sender and delete this e-mail message.
Any unauthorized view, usage or disclosure ofthis message is prohibited.
Since e-mail messages may not be reliable, France Telecom Group shall not be liable for any message if modified, changed or falsified.
Additionally the recipient should ensure they are actually virus free.
********************************************************************************

---

From: <[email-masked]>
Date: Fri, 15 Apr 2011 11:09:38 +0200

Dear all,

I also support the adoption of this draft as an idr WG document.

Cheers,

Christian. 

********************************************************************************
IMPORTANT.Les informations contenues dans ce message electronique y compris les fichiers attaches sont strictement confidentielles et peuvent etre protegees par la loi.
Ce message electronique est destine exclusivement au(x) destinataire(s) mentionne(s) ci-dessus.
Si vous avez recu ce message par erreur ou s il ne vous est pas destine, veuillez immediatement le signaler  a l expediteur et effacer ce message et tous les fichiers eventuellement attaches.
Toute lecture, exploitation ou transmission des informations contenues dans ce message est interdite.
Tout message electronique est susceptible d alteration.
A ce titre, le Groupe France Telecom decline toute responsabilite notamment s il a ete altere, deforme ou falsifie.
De meme, il appartient au destinataire de s assurer de l absence de tout virus.

IMPORTANT.This e-mail message and any attachments are strictly confidential and may be protected by law. This message is intended only for the named recipient(s) above.

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 15 Apr 2011 15:16:21 -0400

Yes/support

Regards,
Jeff  

-----Original Message-----

Dear all, 

Best regards,
Keyur Patel
Robert Raszuk
Martine Djernaes
Jie Dong
Mach Chen

---

From: Jeffrey Haas <[email-masked]>
Date: Sun, 17 Apr 2011 16:22:07 +0000

Apologies if this is a duplicate.  I had thought I had responded to this but
I don't see it either in my inbox or the IDR archives.

On Thu, Mar 31, 2011 at 03:54:07PM +0000, Jie Dong wrote:
> Authors of "IPv6 AF Extensions for Route Target Distribution" would like to propose to adopt this draft as IDR WG document.
> 

I support adoption of this draft as a working group item.

However, I also strongly request that the IPv6 RTC be moved to a
different code point, whether AFI or SAFI.  This would avoid muddying the
semantics of an 12 byte RTC vs. the 20 byte RTC. 

As an example, the type and subtype fields of both regular AS-based route
targets are identical with the IPv6 route target.  It's unclear if the RTC
prefix is /64 if the two octets not including the type/subtype are intended
to be IP address or AS.

-- Jeff

---

From: Jie Dong <[email-masked]>
Date: Mon, 18 Apr 2011 07:49:37 +0000

Hi Jeff,

> I support adoption of this draft as a working group item.

Thanks for your support.

> semantics of an 12 byte RTC vs. the 20 byte RTC.

This could be one solution to achieve support of IPv6 RT, though IMO IPv6 RT may also be used for address families other than IPv6. We'd like to hear opinions on defining new code point for IPv6 RTC. 

FYI, the other part of the previous version (-00) includes specification of per AF RTC. This may be needed with the emergence of new VPN services, e.g. e-vpn etc. AFI/SAFI specific RT-constrain would be described later in a separate draft. We'd also like to hear feedbacks on defining AFI or AFI/SAFI specific RT-constrain.

> prefix is /64 if the two octets not including the type/subtype are intended

Yes this is an issue the authors had discussed. In current draft it defines aggregation rules of RTC prefix in section 3:
"only the Local Administrator field of the Route Target can be aggregated. Route Target Type and the Global Administrator Route Target fields MUST not be aggregated."
This way the length range of this two types of RTC prefix will not be overlapped, then length field could be used to distinguish the two RT types. 

Further comments would be appreciated.

Many thanks,
Jie

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 18 Apr 2011 13:54:57 +0000

> This way the length range of this two types of RTC prefix will not be overlapped, then length field could be used to distinguish the two RT types. 

As long as the l3vpn wg is willing to constrain future formats for route
targets in a way that accommodates this, it might work.  Have you asked them
if they're willing to commit to such a restriction?

As a more general statement, since formats may pop up faster than the
matching RTC restriction on that type(/subtype), doesn't it make sense to
simply make sure the spec be able to handle arbitrary lengths?  The base RTC
spec effectively does this already with the restriction on the prefix length
being 0,32<=n<=96.  While a number of such lengths are nonsensical from a
global/local perspective, the protocol still deals with them.  

E.g. anything that matches on "all 2-byte AS RT" can be encoded, but it's
silly.  But it's certainly simpler than saying "if the first two octets of
the RT portion of the RTC contain the following values, the prefix length is
restricted to being between...."

-- Jeff

---

From: Jie Dong <[email-masked]>
Date: Tue, 19 Apr 2011 02:20:30 +0000

Hi Jeff, 

Thanks for sharing your opinions on this. 

> if they're willing to commit to such a restriction?

We will ask L3VPN on this after the adoption. AFAIK, currently the use of RTC prefix aggregation is only mentioned in MVPN, in which only the local administrator field is aggregated.

> global/local perspective, the protocol still deals with them.

If there is consensus, aggregation rule in the base RTC may also be updated to represent only reasonable prefix lengths. 

> restricted to being between...."

This may be true in specifying the rules. OTOH, more specific aggregation rule may make the matching process of RTC prefixes simpler.

Regards,
Jie