Subject: [Idr] Question about draft-scudder-idr-ebgp-rr

From: Danny McPherson <[email-masked]>
Date: Wed, 24 Oct 2012 11:54:10 -0400

John, 
The two specific updates in this I-D seem reasonable to me.   It's interesting that 4456 never stated behavior for an RR for EBGP-learned routes, (it seems intuitive), I suspect you need to be explicit for a reason. 

I do have one question with the current version of the draft, regarding this text in S.4:

   A RR that serves as an EBGP speaker SHOULD have an IBGP peering with
   any redundant RR.  It SHOULD advertise the same EBGP-learned routes
   over this peering that it advertises to any other IBGP peer.  It MAY
   suppress reflection of any IBGP-learned routes to the redundant RR.

As you might suspect, I like this recommendation a lot [1].  That said, I'm wondering how would you expect the local RR to know that the peer is a "redundant RR" and that reflected routes could be suppressed?  Through static configuration?  Dynamic analysis of CLUSTER_LIST CLUSTER_IDs in received updates?  Or..?

Thanks, 

-danny

[1] Slides 30-32 here: <https://www.nanog.org/meetings/nanog46/abstracts.php?pt=MTM3NSZuYW5vZzQ2&nm=nanog46>

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 24 Oct 2012 13:05:18 -0400

> The two specific updates in this I-D seem reasonable to me.   It's interesting that 4456 never stated behavior for an RR for EBGP-learned routes, (it seems intuitive), I suspect you need to be expl…

Yes -- apparently what is intuitive to you, is not to everyone. Such is the way of standards...

> As you might suspect, I like this recommendation a lot [1].  That said, I'm wondering how would you expect the local RR to know that the peer is a "redundant RR" and that reflected routes could be…

Static configuration, although as you point out it's possible in principle to work it out from analyzing received CLUSTER_LISTs. 

--John

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Wed, 24 Oct 2012 17:51:34 +0000

John,

	Draft looks good...

Thanks,
	Jim Uttaro

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John G. Scudder
Sent: Wednesday, October 24, 2012 1:05 PM
To: Danny McPherson
Cc: idr@ietf. org
Subject: Re: [Idr] Question about draft-scudder-idr-ebgp-rr

--John
_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr