Subject: [Idr] Concerns with draft-vandevelde-idr-remote-next-hop

From: Xuxiaohu <[email-masked]>
Date: Tue, 6 Nov 2012 16:44:26 +0000

Hi co-authors of this draft,

As I mentioned during the WG session,  I have the following concerns with this draft:

1) This draft proposes to use other address (i.e., remote next-hop address) than the next-hop address as the tunnel endpoint address. In fact, the "BGP Tunnel Address Prefix Attribute and Tunnel Address Prefix Extended Community" defined in http://tools.ietf.org/html/draft-xu-idr-tunnel-address-prefix-00 have already allow us to achieve such goal.

2) This draft proposes to optionally use multiple tunnel endpoints for a given NRLI. In fact,  the "BGP Tunnel Address Prefix Attribute and Tunnel Address Prefix Extended Community" defined in http://tools.ietf.org/html/draft-xu-idr-tunnel-address-prefix-00 have already allowed us to achieve such goal as well.

3) This draft proposes to associate the tunnel encapsulation advertisement with the NRLI advertisement. In fact, RFC5512 has already provided such flexibility by using the BGP Tunnel Encapsulation Attribute, insteads of the BGP Encapsulation SAFI. In addition, http://tools.ietf.org/html/draft-xu-idr-tunnel-address-prefix-00 provides such flexibility as well.

Best regards,
Xiaohu

---

From: Randy Bush <[email-masked]>
Date: Wed, 07 Nov 2012 09:48:11 +0900

nexthop is rewritten at provider borders, if not more often (some
rewrite at RR).  you are not going to change that.

randy