Subject: [Idr] Requesting WG adoption and WGLC of draft-scudder-deprecate-dpa-etal-00.txt

From: "John G. Scudder" <[email-masked]>
Date: Wed, 14 Nov 2012 13:16:55 -0500

Hi,

Nobody responded to my note of November 8 ("Deprecating path attributes DPA, ADVERTISER and RCID_PATH / CLUSTER_ID"). Accordingly, I've submitted the below tiny Internet Draft. The substantive text of the draft is:

1.  Introduction

   As of this writing the BGP Path Attributes registry maintained by
   IANA contains entries for DPA, ADVERTISER, and RCID_PATH /
   CLUSTER_ID.  The first of these is associated with
   [draft-ietf-idr-bgp-dpa-05], an Internet Draft that was abandoned in
   1996.  The latter are associated with [RFC1863], an RFC that was
   reclassified as Historic in 2005.  Neither of these specifications is
   in use now, nor ever was.

2.  IANA Considerations

   This document requests IANA to mark the BGP Path Attributes registry
   entries for DPA, ADVERTISER, and RCID_PATH / CLUSTER_ID as
   "Deprecated".

The rest is boilerplate, references, etc. 

I would like to ask the WG to adopt the draft. Since the draft is so trivial, I would like to also request a WGLC, to run in parallel. 

Since many WG members will be on holiday for part of next week, let's have the call for adoption + WGLC end on December 3. Please send any comments before December 3.

Also, regarding the out-of-the-ordinary expedited WGLC: If there's any disagreement whatsoever (with the content or wording of the draft, its adoption, or indeed the expedited procedure itself), let's have only the call for adoption end on December 3, and then we can do a normal WGLC when appropriate.

Thanks,

--John (wearing two hats)

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-scudder-deprecate-dpa-etal-00.txt
> Date: November 14, 2012 1:06:11 PM EST
> To: [email-masked]
> Cc: [email-masked]
> 
> 
> A new version of I-D, draft-scudder-deprecate-dpa-etal-00.txt
> has been successfully submitted by John Scudder and posted to the
> IETF repository.
> 
> Filename:	 draft-scudder-deprecate-dpa-etal
> Revision:	 00
> Title:		 Deprecation of BGP Path Attributes DPA, ADVERTISER and RCID_PATH / CLUSTER_ID
> Creation date:	 2012-11-14
> WG ID:		 Individual Submission
> Number of pages: 2
> URL:             http://www.ietf.org/internet-drafts/draft-scudder-deprecate-dpa-etal-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-scudder-deprecate-dpa-etal
> Htmlized:        http://tools.ietf.org/html/draft-scudder-deprecate-dpa-etal-00
> 
> 
> Abstract:
>   This document requests IANA to deprecate several BGP path attributes,
>   associated with an abandoned Internet Draft and a Historic RFC,
>   respectively.
> 
> 
> 
> 
> The IETF Secretariat

---

From: "Keyur Patel (keyupate)" <[email-masked]>
Date: Wed, 14 Nov 2012 18:34:34 +0000

Support for both.

Regards,
Keyur

On 11/14/12 10:16 AM, "John G. Scudder" <[email-masked]> wrote:

>Hi,
>
>Nobody responded to my note of November 8 ("Deprecating path attributes
>DPA, ADVERTISER and RCID_PATH / CLUSTER_ID"). Accordingly, I've submitted
>the below tiny Internet Draft. The substantive text of the draft is:
>
>1.  Introduction
>
>I would like to ask the WG to adopt the draft. Since the draft is so
>trivial, I would like to also request a WGLC, to run in parallel.
>
>Since many WG members will be on holiday for part of next week, let's
>have the call for adoption + WGLC end on December 3. Please send any
>comments before December 3.
>
>Also, regarding the out-of-the-ordinary expedited WGLC: If there's any
>disagreement whatsoever (with the content or wording of the draft, its
>adoption, or indeed the expedited procedure itself), let's have only the
>call for adoption end on December 3, and then we can do a normal WGLC
>when appropriate.
>
>Thanks,
>
>> URL:            
>>http://www.ietf.org/internet-drafts/draft-scudder-deprecate-dpa-etal-00.t
>>xt
>> Status:         
>>http://datatracker.ietf.org/doc/draft-scudder-deprecate-dpa-etal
>> Htmlized:       
>>http://tools.ietf.org/html/draft-scudder-deprecate-dpa-etal-00
>> 
>> 
>> Abstract:
>_______________________________________________
>Idr mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/idr

---

From: Brian Dickson <[email-masked]>
Date: Wed, 14 Nov 2012 15:19:14 -0500

Support both for both.

Brian

P.S. If only more IDs were as short. :-)

On Wed, Nov 14, 2012 at 1:34 PM, Keyur Patel (keyupate)
<[email-masked]>wrote:

> >> Title:                Deprecation of BGP Path Attributes DPA,
> ADVERTISER and
> >>RCID_PATH / CLUSTER_ID

---

From: Hannes Gredler <[email-masked]>
Date: Thu, 15 Nov 2012 09:07:51 +0100

support;

---

From: <[email-masked]>
Date: Thu, 15 Nov 2012 08:57:31 +0000

Support for both.

>From: Keyur Patel (keyupate)
>
>Support for both.
>
>Regards,
>Keyur
>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jie Dong <[email-masked]>
Date: Thu, 15 Nov 2012 09:09:24 +0000

Support both.

Best regards,
Jie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of John G.
> Scudder
> Sent: Thursday, November 15, 2012 2:17 AM
> To: idr@ietf. org
> Subject: [Idr] Requesting WG adoption and WGLC of
> draft-scudder-deprecate-dpa-etal-00.txt
> 
> Hi,
> 
> I would like to ask the WG to adopt the draft. Since the draft is so trivial, I would
> like to also request a WGLC, to run in parallel.
> 
> Since many WG members will be on holiday for part of next week, let's have the
> call for adoption + WGLC end on December 3. Please send any comments
> before December 3.
> 
> adoption, or indeed the expedited procedure itself), let's have only the call for
> adoption end on December 3, and then we can do a normal WGLC when
> appropriate.
> 
> Thanks,
> 
> http://www.ietf.org/internet-drafts/draft-scudder-deprecate-dpa-etal-00.txt
> > Status:

---

From: Chandra Appanna <[email-masked]>
Date: Thu, 15 Nov 2012 09:37:45 -0800 (PST)

Support for both..

Chandra.

________________________________
 From: John G. Scudder <[email-masked]>
To: "idr@ietf. org" <[email-masked]> 
Sent: Wednesday, November 14, 2012 10:16 AM
Subject: [Idr] Requesting WG adoption and WGLC of draft-scudder-deprecate-dpa-etal-00.txt
 
Hi,

1.  Introduction

2.  IANA Considerations

Thanks,

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 15 Nov 2012 19:37:43 +0000

Yes/support

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John G. Scudder
Sent: Wednesday, November 14, 2012 10:17 AM
To: idr@ietf. org
Subject: [Idr] Requesting WG adoption and WGLC of draft-scudder-deprecate-dpa-etal-00.txt

Hi,

1.  Introduction

2.  IANA Considerations

Thanks,

Begin forwarded message:

> has been successfully submitted by John Scudder and posted to the IETF 
> repository.
>

---

From: Warren Kumari <[email-masked]>
Date: Fri, 16 Nov 2012 21:19:58 -0500

… and the support text is now longer than the entire draft (- boilerplate ) :-)

Support for both…

W

-- 
"He who laughs last, thinks slowest." 
    -- Anonymous

---

From: Randy Bush <[email-masked]>
Date: Sat, 17 Nov 2012 15:58:27 +0700

read and support.

when you cut the draft-ietf-idr version, it might reduce confusion if it
made clear that CLUSTER_ID != CLUSTER_LIST

randy

---

From: "Susan Hares" <[email-masked]>
Date: Sat, 17 Nov 2012 20:48:07 -0500

<chair hat off> 
+1 support 
Sue Hares

-----Original Message-----
From: John G. Scudder [mailto:[email-masked]] 
Sent: Wednesday, November 14, 2012 1:17 PM
To: idr@ietf. org
Cc: Susan Hares
Subject: Requesting WG adoption and WGLC of

Hi,

Nobody responded to my note of November 8 ("Deprecating path attributes DPA,
ADVERTISER and RCID_PATH / CLUSTER_ID"). Accordingly, I've submitted the
below tiny Internet Draft. The substantive text of the draft is:

1.  Introduction

2.  IANA Considerations

Since many WG members will be on holiday for part of next week, let's have
the call for adoption + WGLC end on December 3. Please send any comments
before December 3.

Also, regarding the out-of-the-ordinary expedited WGLC: If there's any
disagreement whatsoever (with the content or wording of the draft, its
adoption, or indeed the expedited procedure itself), let's have only the
call for adoption end on December 3, and then we can do a normal WGLC when
appropriate.

Thanks,

---

From: "Pradosh Mohapatra (pmohapat)" <[email-masked]>
Date: Mon, 19 Nov 2012 06:49:47 +0000

John,

>   entries for DPA, ADVERTISER, and RCID_PATH / CLUSTER_ID as

Given that these have never been used/deployed, won't it be better to
reuse the values? Something like "Unavailable" for six months followed by
"Unassigned"?

- Pradosh

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 20 Nov 2012 16:03:27 -0500

That's basically the point of "deprecated". I see no rush to reuse the values given we're nowhere near exhausting the space. <knocks wood>

--John

---

From: Jon Mitchell <[email-masked]>
Date: Sat, 24 Nov 2012 19:28:06 -0500

Support

-Jon

---

From: Danny McPherson <[email-masked]>
Date: Wed, 28 Nov 2012 12:49:55 -0500

> Nobody responded to my note of November 8 ("Deprecating path attributes DPA, ADVERTISER and RCID_PATH / CLUSTER_ID"). Accordingly, I've submitted the below tiny Internet Draft. The substantive text…
...

> The rest is boilerplate, references, etc. 

John, 
I support this as well.  Might I offer this trivial changes to remove 
potential ambiguities:

=====
2.  IANA Considerations

   This document requests IANA to mark the BGP Path Attributes registry
   entries for DPA (Value 11), ADVERTISER (Value 12), and RCID_PATH / 
   CLUSTER_ID (Value 13) as "Deprecated".

=====

If we ever get to a point where there is a lack of code points, the IESG 
would then confirm changing the deprecated values to be unassigned 
for use, or so it goes..

-danny

---

From: David Farmer <[email-masked]>
Date: Wed, 28 Nov 2012 16:53:42 -0600

Support Both.

...

-- 
================================================
David Farmer               Email: [email-masked]
Office of Information Technology
University of Minnesota
2218 University Ave SE     Phone: 1-612-626-0815
Minneapolis, MN 55414-3029  Cell: 1-612-812-9952
================================================