Subject: [Idr] Fwd: Some background on the L3VPN Service YANG Model work

From: Benoit Claise <[email-masked]>
Date: Wed, 04 Mar 2015 14:55:09 +0100

FYI. Sorry for the potential duplicates.

Regards, Benoit

-------- Forwarded Message --------
Subject: 	Some background on the L3VPN Service YANG Model work
Date: 	Wed, 04 Mar 2015 14:40:52 +0100
From: 	Benoit Claise <[email-masked]>
To: 	[email-masked]

Dear all,

Let me give you some background on this new piece of work: The Layer 
Three Virtual Private Network Service Model (L3SM)

Three months ago, Adrian Farrel and I set up a design team to create a 
L3VPN _service _YANG model.
It needs to be clearly understood that this L3VPN _service _model is not 
an L3VPN configuration model. That is, it does not provide details for 
configuring network elements or protocols. Instead it contains the 
characteristics of the service, as discussed between the operators and 
their customers.  Therefore, that design team was composed of operators 
only.

That design team created a first draft: 
http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
Now that the draft has been posted, the work and discussion should 
continue in a public forum, i.e. this [email-masked] mailing list.

Next step? we're busy trying to create a new short-lived WG, focusing 
solely on this L3VPN service YANG model.
See the proposal at https://datatracker.ietf.org/doc/charter-ietf-l3sm/
If this WG is created (This proposal is on the IESG telechat this week 
for external review approval), this would be a good test for the IETF 
community: are we ready to standardize a first service YANG model? 
Personally, I believe we are.
IMO, the advantage/driver for this work is explained in the charter 
proposal:

    The deliverable from this working group will provide information to evaluate the
    set of YANG models that have already been developed or are under development,
    and will help identify any missing models or details.  The deliverable can be
    viewed as driving requirements for protocol configuration model so that the
    service parameters can be mapped into inputs used by the protocol models.

Don't hesitate to forward this email.
     List address: [email-masked]
     Archive: http://www.ietf.org/mail-archive/web/l3sm/
     To subscribe: https://www.ietf.org/mailman/listinfo/l3sm

Regards, Benoit

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 4 Mar 2015 09:46:33 -0500

Benoit:

Will there be interaction between the layers of the modules (L3VPN service), and BGP module? 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, March 04, 2015 8:55 AM
To: [email-masked]
Subject: [Idr] Fwd: Some background on the L3VPN Service YANG Model work

Regards, Benoit 

-------- Forwarded Message -------- 

Subject: 

Some background on the L3VPN Service YANG Model work

Date: 

Wed, 04 Mar 2015 14:40:52 +0100

From: 

Benoit Claise  <mailto:[email-masked]> <[email-masked]>

To: 

[email-masked]

Dear all,

Let me give you some background on this new piece of work: The Layer Three Virtual Private Network Service Model (L3SM)

Three months ago, Adrian Farrel and I set up a design team to create a L3VPN service YANG model.
It needs to be clearly understood that this L3VPN service model is not an L3VPN configuration model. That is, it does not provide details for configuring network elements or protocols. Instead it contains the characteristics of the service, as discussed between the operators and their customers.  Therefore, that design team was composed of operators only.

That design team created a first draft: http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/ 
Now that the draft has been posted, the work and discussion should continue in a public forum, i.e. this [email-masked] mailing list.

Next step? we're busy trying to create a new short-lived WG, focusing solely on this L3VPN service YANG model.
See the proposal at https://datatracker.ietf.org/doc/charter-ietf-l3sm/
If this WG is created (This proposal is on the IESG telechat this week for external review approval), this would be a good test for the IETF community: are we ready to standardize a first service YANG model? Personally, I believe we are. 
IMO, the advantage/driver for this work is explained in the charter proposal:

Regards, Benoit

---

From: <[email-masked]>
Date: Thu, 5 Mar 2015 15:58:00 +0000

Hi Susan,

Not directly, L3VPN service module is really an abstraction (no interaction with network elements). But we may expect that systems instantiating this module will translate these abstractions to configuration of network elements that can be done also through NetConf/Yang and here BGP module may be called.

Hope it helps,

Stephane

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Wednesday, March 04, 2015 15:47
To: 'Benoit Claise'; [email-masked]
Subject: Re: [Idr] Fwd: Some background on the L3VPN Service YANG Model work

Benoit:

Sue

From: Idr [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, March 04, 2015 8:55 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] Fwd: Some background on the L3VPN Service YANG Model work

Regards, Benoit

-------- Forwarded Message --------
Subject:

Date:

From:

Benoit Claise <[email-masked]><mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

Dear all,

That design team created a first draft: http://datatracker.ietf.org/doc/draft-l3vpn-service-yang/
Now that the draft has been posted, the work and discussion should continue in a public forum, i.e. this [email-masked]<mailto:[email-masked]> mailing list.

    List address: [email-masked]<mailto:[email-masked]>

Regards, Benoit

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.