Subject: Re: [Idr] draft-cgray-ietf-bgp-exceptions

From: Cameron Gray <[email-masked]>
Date: Mon, 27 Jul 2015 05:27:36 +0000

> On 27 Jul 2015, at 02:20, Mike Dubrovskiy (mdubrovs) <[email-masked]> wrote:
>
> Look at
> https://tools.ietf.org/html/rfc5575

Mike,

Thank you for replying.  I am indeed aware of FlowSpec, however despite being put forward as a proposed standard in 2009 almost zero commercial providers will offer it (at least in the UK/EU and nLayer/GTT removed support for it August 2013).  I was trying to propose something more lightweight that could gain critical mass more quickly to gain its utility.

My solution is closer to RTBH than anything else, but RTBH has no formal specification - all RFCs are informational (3882, 5635).

Regards,

Cameron

Rhif Elusen Gofrestredig 1141565 - Registered Charity No. 1141565

Gall y neges e-bost hon, ac unrhyw atodiadau a anfonwyd gyda hi, gynnwys deunydd cyfrinachol ac wedi eu bwriadu i'w defnyddio'n unig gan y sawl y cawsant eu cyfeirio ato (atynt). Os ydych wedi derbyn y neges e-bost hon trwy gamgymeriad, rhowch wybod i'r anfonwr ar unwaith a dilewch y neges. Os na fwriadwyd anfon y neges atoch chi, rhaid i chi beidio a defnyddio, cadw neu ddatgelu unrhyw wybodaeth a gynhwysir ynddi. Mae unrhyw farn neu safbwynt yn eiddo i'r sawl a'i hanfonodd yn unig ac nid yw o anghenraid yn cynrychioli barn Prifysgol Bangor. Nid yw Prifysgol Bangor yn gwarantu bod y neges e-bost hon neu unrhyw atodiadau yn rhydd rhag firysau neu 100% yn ddiogel. Oni bai fod hyn wedi ei ddatgan yn uniongyrchol yn nhestun yr e-bost, nid bwriad y neges e-bost hon yw ffurfio contract rhwymol - mae rhestr o lofnodwyr awdurdodedig ar gael o Swyddfa Cyllid Prifysgol Bangor.

This email and any attachments may contain confidential material and is solely for the use of the intended recipient(s). If you have received this email in error, please notify the sender immediately and delete this email. If you are not the intended recipient(s), you must not use, retain or disclose any information contained in this email. Any views or opinions are solely those of the sender and do not necessarily represent those of Bangor University. Bangor University does not guarantee that this email or any attachments are free from viruses or 100% secure. Unless expressly stated in the body of the text of the email, this email is not intended to form a binding contract - a list of authorised signatories is available from the Bangor University Finance Office.

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 27 Jul 2015 11:37:30 +0200

​Cameron,​

> Thank you for replying.  I am indeed aware of FlowSpec, however despite
> being put forward as a proposed standard in 2009 almost zero commercial
> providers will offer it (at least in the UK/EU and nLayer/GTT removed
> support for it August 2013).  I was trying to propose something more
> lightweight that could gain critical mass more quickly to gain its utility.
>

Have you ​done analysis and comparison of flowspec with your solution to
establish the base for the assertion that your solution is:

a) "more lightweight" then RFC5575

b) will be deployed more quickly then RFC5575

c) is as secure as RFC5575 with automatic validation

I would love to see such data.

Likewise in fact it would be helpful to also compare your solution with
RTBH.

Best regards,
Robert.

---

From: Cameron Gray <[email-masked]>
Date: Thu, 30 Jul 2015 14:27:13 +0000

> On 27 Jul 2015, at 10:37, Robert Raszuk <[email-masked]> wrote:
>
> ​Cameron,​
>
> Have you ​done analysis and comparison of flowspec with your solution to establish the base for the assertion that your solution is:
>
> Likewise in fact it would be helpful to also compare your solution with RTBH.

Sorry to reply late to this, I have begun work on this comparison but in the form of an academic paper to aid weight to my studies.  I will share the results of this with the group as soon as it is completed.

Regards,

Cameron Gray
Doctoral Student
School of Computer Science

Email: [email-masked]

Bangor University, Bangor, Gwynedd, LL57 2DG