Subject: Re: [Idr] Comment on flow-spec Routing Policy Distribution (RPD) from IDR WG Meeting

From: "Wunan (Eric)" <[email-masked]>
Date: Thu, 30 Jul 2015 09:36:58 +0000

Acee,

Thank you so thoughtfully to put this on the list, sorry for didn't take all your points during IDR meeting.
That is the reason why it will be better to have the dialogue displayed at the screen bottom when you are watching a TV show.

Your observation on outbound is correct, and yes, it is a different scenario from DDOS.
The motivation behind this draft is that we may need one mechanism to solve both outbound and inbound traffic engineering on different networks, even those without MPLS dataplane.

By the way, I changed cc from [email-masked] to [email-masked]. I assumed this is a typo since your mail didn't show in the list.

Regards
Eric

-----邮件原件-----
发件人: Acee Lindem (acee) [mailto:[email-masked]] 
发送时间: 2015年7月28日 21:58
收件人: Wunan (Eric)
抄送: [email-masked]
主题: Comment on flow-spec Routing Policy Distribution (RPD) from IDR WG Meeting 

Hi Eric, 

Let me explain the comment I was trying to articulate in IDR meeting. Flow Spec NLRI has traditionally been used for traffic filtering to mitigate DDOS attacks.  Now that it is being proposed for outbound traffic control, the policy controller will also need to peer with all the egress routers to learn the available IPv4/IPv6 paths. This is necessary so that the policy controller doesn’t install a filer rule that will blackhole traffic. This may seem obvious but the it is a different scenario from today’s RFC 5575 deployments. 

I think segment routing is a better way to solve this problem but then this is not an entirely unbiased opinion since I’m working on segment routing. 

Thanks,
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 30 Jul 2015 15:35:36 +0000

Hi Eric, 

> On Jul 30, 2015, at 5:36 AM, Wunan (Eric) <[email-masked]> wrote:
> 
> Acee,
> 
> The motivation behind this draft is that we may need one mechanism to solve both outbound and inbound traffic engineering on different networks, even those without MPLS data plane.

That is how I understood the suite of drafts presented on Friday - basically using the Flow-Spec SAFI for Traffic Engineering. 

> By the way, I changed cc from [email-masked] to [email-masked]. I assumed this is a typo since your mail didn't show in the list.

Yes - didn’t notice the auto-completion of the wrong list. 

Thanks,
Acee