Subject: [Idr] YANG data models in IDR: extraction and compilation feedback

From: Benoit Claise <[email-masked]>
Date: Tue, 1 Dec 2015 10:03:32 +0100

Dear all,

I looked at the YANG models in the IDR WG documents, from a compilation 
point of view (NOT from a YANG design point of view):
http://datatracker.ietf.org/doc/draft-ietf-idr-bgp-model/

See the compilation results, updated daily, at 
http://www.claise.be/IETFYANGPageCompilation.html

For the 5 data models, you 're missing double quotes for the file names. 
As an example:

OLD:

    <CODE BEGINS> file bgp.yang
    module bgp {

NEW:

    <CODE BEGINS> file "bgp.yang"
    module bgp {

Now that this document is an IETF WG document, you must correct this one 
error type (for the 5 data models), given by pyang --ietf

    bgp-types.yang:1: warning: RFC 6087: 4.1: the module name should
    start with one of the strings "ietf-" or "iana-"
    bgp-types.yang:3: warning: RFC 6087: 4.8: namespace value should be
    "urn:ietf:params:xml:ns:yang:bgp-types"

As an example:
OLD:

    module bgp-types {
         yang-version "1";
         namespace "http://openconfig.net/yang/bgp-types";
         prefix "bgp-types";

NEW:

    module ietf-bgp-types {
         yang-version "1";
         namespace "urn:ietf:params:xml:ns:yang:ietf-bgp-types";
         prefix "bgp-types";

Please update your draft accordingly.

Regards, Benoit

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 1 Dec 2015 07:45:16 -0500

Benoit: 

Thank you for this notification.  I will work on updating this yang data model. 

Sue 

From: Benoit Claise [mailto:[email-masked]] 
Sent: Tuesday, December 01, 2015 4:04 AM
To: [email-masked]; [email-masked]
Subject: YANG data models in IDR: extraction and compilation feedback

Dear all,

I looked at the YANG models in the IDR WG documents, from a compilation point of view (NOT from a YANG design point of view):
http://datatracker.ietf.org/doc/draft-ietf-idr-bgp-model/

See the compilation results, updated daily, at http://www.claise.be/IETFYANGPageCompilation.html

For the 5 data models, you 're missing double quotes for the file names. As an example:

OLD:

NEW:

Now that this document is an IETF WG document, you must correct this one error type (for the 5 data models), given by pyang --ietf

bgp-types.yang:1: warning: RFC 6087: 4.1: the module name should start with one of the strings "ietf-" or "iana-"
bgp-types.yang:3: warning: RFC 6087: 4.8: namespace value should be "urn:ietf:params:xml:ns:yang:bgp-types"

As an example:
OLD:

module bgp-types {
    yang-version "1";
    namespace  <http://openconfig.net/yang/bgp-types> "http://openconfig.net/yang/bgp-types";
    prefix "bgp-types";

NEW:

module ietf-bgp-types {
    yang-version "1";

Regards, Benoit