Subject: [Idr] adoption of five flowspec drafts [was: Re: WG Adoption call for drafts for Flow Specification option 1 (RFC5575 additions (filters/actions) 3/25 to 4/8/2016 ]

From: "John G. Scudder" <[email-masked]>
Date: Tue, 10 May 2016 10:59:42 -0400

Dear WG,

The following drafts are accepted as WG documents:

draft-eddy-idr-flowspec-packet-rate
draft-hao-idr-flowspec-nvo3
draft-liang-idr-bgp-flowspec-label
draft-litkowski-idr-flowspec-interface-set
draft-yong-idr-flowspec-mpls-match

The authors should resubmit as draft-ietf-idr-XXX. (draft-liang-idr-bgp-flowspec-label resubmit as draft-ietf-idr-flowspec-label, for consistency.)

Authors (and the WG) should note that we're also still discussing the issues of how to best address ordering and action conflict issues. We think it's likely we'll have a 5575bis coming along, and possibly a v2 as well, and related documents (all of the above) will probably need to be updated to fit into whatever framework we end up with. Just FYI for the moment.

Thanks,

--John and Sue

> On Mar 25, 2016, at 10:47 AM, Susan Hares <[email-masked]> wrote:
> 
> IDR WG: 
>  
> This begins a 2 week WG Call (3/25 to 4/8/2016) for the set of drafts to be considered in RFC5575 additions. These options are filters, actions or critical security additions.  The flow specification work has been a part of the interims since IETF 94
> https://www.ietf.org/proceedings/interim/2016/02/08/idr/proceedings.html <https://www.ietf.org/proceedings/interim/2016/02/08/idr/proceedings.html>
> https://www.ietf.org/proceedings/interim/2016/03/07/idr/proceedings.html <https://www.ietf.org/proceedings/interim/2016/03/07/idr/proceedings.html>
>  
> There will be a brief flow specification presentation at IETF 95, and the email list has select to start with option 1 – extending RFC5575.  We also will be gathering details on the SDN/NFV use case for option 2 (new NLRI and Wide Communities support). 
>  
> This is a group call for the drafts to be considered in the flow specification work.  For each of the drafts you wish to be considered Option 1, please indicate: 
>  
> 1)      If this option is valuable for the DDoS deployments or another critical deployments,  
> 2)      Do you feel this draft is useful, but not ready for adoption, 
> 3)      Do you feel this draft is a good start for this work. 
>  
> The drafts to consider are: 
> https://datatracker.ietf.org/doc/draft-eddy-idr-flowspec-packet-rate/ <https://datatracker.ietf.org/doc/draft-eddy-idr-flowspec-packet-rate/>
> https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-nvo3/ <https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-nvo3/>
> https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-redirect-tunnel/ <https://datatracker.ietf.org/doc/draft-hao-idr-flowspec-redirect-tunnel/>
> https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-sid/ <https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-sid/>
> https://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/ <https://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/>
> https://datatracker.ietf.org/doc/draft-litkowski-idr-flowspec-interfaceset/ <https://datatracker.ietf.org/doc/draft-litkowski-idr-flowspec-interfaceset/>
>  <https://datatracker.ietf.org/doc/draft-li-idr-flowspec-redirect-generalized-sid/>https://datatracker.ietf.org/doc/draft-vandevelde-idr-flowspec-path-redirect/ <https://datatracker.ietf.org/doc/draft-vandevelde-idr-flowspec-path-redirect/>
> https://datatracker.ietf.org/doc/draft-yong-idr-flowspec-mpls-match/ <https://datatracker.ietf.org/doc/draft-yong-idr-flowspec-mpls-match/>
>  
> And for the ordering of these filters and actions drafts – the Option 1 section out of this 
> https://datatracker.ietf.org/doc/draft-hares-idr-flowspec-combo/ <https://datatracker.ietf.org/doc/draft-hares-idr-flowspec-combo/>
> (A revised draft with just Option 1 will be posted) 
>  
> Sue Hares and John Scudder

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 10 May 2016 11:10:50 -0400

Dear WG,
 
The WG has demonstrated interest in the subject area addressed by these drafts:
 
draft-vandevelde-idr-flowspec-path-redirect
draft-li-idr-flowspec-redirect-generalized-sid
draft-hao-idr-flowspec-redirect-tunnel
 
Furthermore, there's clear consensus that the WG should select only one approach to proceed forward with. 
 
Although during the WG adoption call there was some substantive discussion of the differences in approach between the three drafts, the chairs were not convinced that it was sufficient to allow us to conclude. For this reason, we're asking the respective authors to prepare short presentations outlining key differences only for discussion at our upcoming interim on May 16. These will be recorded and distributed by May 14th, so that the interim time itself can be used for Q/A/discussion only (and not for presenting slides). 
 
Please also use the mailing list for discussion, there is no requirement to wait until the interim time slot. This will be our only topic for the May 16 interim. (If we get enough engagement on the mailing list beforehand, we might even be able to cancel the interim.)

We especially encourage review and comment by WG members who haven't contributed yet.
 
After the interim, the chairs will make a decision about which draft to move forward with as a good starting point for WG work. 
 
Thanks, and thanks in advance for your efforts over the next week or so.
 
Regards,
 
--John and Sue