Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

From: [email-masked]
Date: Wed, 08 Jun 2016 06:26:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing of the IETF.

        Title           : Applying BGP flowspec rules on a specific interface set
        Authors         : Stephane Litkowski
                          Adam Simpson
                          Keyur Patel
                          Jeff Haas
	Filename        : draft-ietf-idr-flowspec-interfaceset-01.txt
	Pages           : 14
	Date            : 2016-06-08

Abstract:
   BGP Flow-spec is an extension to BGP that allows for the
   dissemination of traffic flow specification rules.  The primary
   application of this extension is DDoS mitigation where the flowspec
   rules are applied in most cases to all peering routers of the
   network.

   This document will present another use case of BGP Flow-spec where
   flow specifications are used to maintain some access control lists at
   network boundary.  BGP Flowspec is a very efficient distributing
   machinery that can help in saving OPEX while deploying/updating ACLs.
   This new application requires flow specification rules to be applied
   only on a specific subset of interfaces and in a specific direction.

   The current specification of BGP Flow-spec ([RFC5575]) introduces the
   notion of flow specification (which describes the matching criterion)
   and traffic filtering actions.  The flow specification is encoded as
   part of the NLRI while the traffic filtering actions are encoded as
   extended communities.  The combination of a flow specification and
   one or more actions is known as a flow specification rule.  [RFC5575]
   does not detail where the flow specification rules need to be
   applied.

   Besides the flow specification and traffic filtering actions, this
   document introduces the notion of traffic filtering scope in order to
   drive where a particular rule must be applied.  In particular, this
   document introduces the "interface-set" traffic filtering scope that
   could be used in parallel of traffic filtering actions (marking,
   rate-limiting ...).  The purpose of this extension is to inform
   remote routers about groups of interfaces where the rule must be
   applied.

   This extension can also be used in a DDoS mitigation context where a
   provider wants to apply the filtering only on specific peers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-flowspec-interfaceset/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-idr-flowspec-interfaceset-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-flowspec-interfaceset-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Wed, 8 Jun 2016 13:29:19 +0000

Hi IDR,

This is a new version of the interface-set flowspec extension.

As there was some misinterpretation of what the interface-set is (it is not a match (as not part of NLRI) and it is not an action), we defined the notion of traffic filtering scope. Interface-set would be the first traffic filtering scope defined, and nothing prevents to create new ones if required.

Best Regards,

Stephane

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, June 08, 2016 15:26
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Lucy yong <[email-masked]>
Date: Wed, 8 Jun 2016 19:21:02 +0000

Hi Stephane, et al,

I read this draft and have some comments.

*         I like this approach to treat interfaceset as FS scope, not as matching, nor as action.

*         Instead of using group-identifier to express interfaceset in the EC, IMO: it is better to use interface type to identify the interfaceset and have IANA registry for each interface type. This will make interworking/automation easier. Any thought on that?

*         IMO: Content in Sn 6 is very useful, however it does not belong to this draft. These rules for processing permanent configured and BGP FS apply to all BGP FS. It should be documented in one draft and apply to all BGP FS drafts. FS ACL is just one type of BGP FS, there are others as well. The rules should be described in general term.

*         I am not clear what first sentence means in Sn 7. Does it say that some interfaces may not be able to support the rules? Pls explain.

Thanks,

Lucy

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, June 08, 2016 8:29 AM
To: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

Hi IDR,

Best Regards,

Stephane

-----Original Message-----

From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>

To: [email-masked]<mailto:[email-masked]>

Cc: [email-masked]<mailto:[email-masked]>

                          Adam Simpson

                          Keyur Patel

                          Jeff Haas

      Pages           : 14

      Date            : 2016-06-08

Abstract:

   network.

   applied.

   applied.

Idr mailing list

[email-masked]<mailto:[email-masked]>

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

Thank you.

Idr mailing list

[email-masked]<mailto:[email-masked]>

---

From: <[email-masked]>
Date: Fri, 10 Jun 2016 09:23:26 +0000

Hi Lucy,

Pls find some comments inline.

Thanks,

Stephane

From: Lucy yong [mailto:[email-masked]]
Sent: Wednesday, June 08, 2016 21:21
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

Hi Stephane, et al,

[SLI] Bruno Decraene raised on similar comment at the beginning of the draft , proposing some "well-known" interface-set. There was not a strong support for it considering that having a group-id will enable any scenario. Now regarding your proposal of having a specific interface type defined, I think it's really restrictive. I'm not opposite that someone creates new scope for specific interface types later but I would like to keep the generic approach in this draft. Creating well known group-ids may also be reconsidered.

I agree that there may be more iteractions to describe like Policy Based routing. But I think that this draft is a good place to describe it. The base flowspec does not precise where the rules must be applied, so it becomes up to implementation to place the rule where it best fits and manage interaction with other mechanism.

Now with this draft, we know that the rules will be pushed on a pr interface basis interacting with well known interface features. We cannot describe all for sure. I will try in the next revision to be more generic and still giving examples.

[SLI] That's a question of scaling. With the base FS, the rule is applied in a single place, while here it may be "duplicated" in the forwarding plane and implementations will need to look at optimizations to prevent to create unnecessary states in the forwarding plane. I will see how to reword it.

Thanks,

Lucy

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, June 08, 2016 8:29 AM
To: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

Hi IDR,

Best Regards,

Stephane

-----Original Message-----

                          Adam Simpson

                          Keyur Patel

                          Jeff Haas

      Pages           : 14

      Date            : 2016-06-08

Abstract:

   network.

   applied.

   applied.

Idr mailing list

Thank you.

Idr mailing list

---

From: Lucy yong <[email-masked]>
Date: Fri, 10 Jun 2016 13:06:31 +0000

Hi Stephane,

Pls see inline below.

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 10, 2016 4:23 AM
To: Lucy yong; [email-masked]
Subject: RE: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

Hi Lucy,

Thanks,

Stephane

From: Lucy yong [mailto:[email-masked]]
Sent: Wednesday, June 08, 2016 21:21
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]<mailto:[email-masked]>
Subject: RE: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

Hi Stephane, et al,

[Lucy] From interworking perspective and consistent behavior, it is necessary for all vendors to have  common understanding about interface types. If someone creates a new  interface type later, that will need to be supported by vendors so it is better to be standardized and have code point in a IANA registry.

[Lucy] IMO: These rules should apply to BGP FS whether interfaceset scope is used or not. If you want to keep them in this draft, need to be clarify that. In addition, good to describe them in term of processing rules for permanent configured and BGP FS.

[Lucy] Thx.

Thanks,

Lucy

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Wednesday, June 08, 2016 8:29 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-interfaceset-01.txt

Hi IDR,

Best Regards,

Stephane

-----Original Message-----

                          Adam Simpson

                          Keyur Patel

                          Jeff Haas

      Pages           : 14

      Date            : 2016-06-08

Abstract:

   network.

   applied.

   applied.

Idr mailing list

Thank you.

Idr mailing list

Thank you.