Subject: Re: [Idr] draft-ietf-idr-bgp-extended-messages-12 WG LC (5/24 to 6/7)

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Jun 2016 14:22:50 -0400

Robert and Bruno: 

https://trac.tools.ietf.org/wg/idr/trac/wiki/draft-ietf-idr-bgp-extended-implementations

is the location to put information regarding draft-ietf-idr-bgp-extended-implementations.   It is a wiki – so anyone can add details to it. 

The location of all implementation reports are now on the IDR wiki at: 

https://trac.tools.ietf.org/wg/idr/trac/wiki 

I will be asking the authors to fill this in and do a final spin of the draft. 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Thursday, May 26, 2016 7:20 AM
To: Bruno Decraene
Cc: Keyur Patel (keyupate); [email-masked]; Susan Hares
Subject: Re: [Idr] draft-ietf-idr-bgp-extended-messages-12 WG LC (5/24 to 6/7)

Hi Bruno/all,

“A protocol designer or network operator needing to advertise, outside of its AS, a BGP route which size would require a BGP message larger than 4096 octets should take into account that it has no guarantee that its route will be propagated as expected as a downstream BGP speaker might not be compliant or might not has enabled BGP extended messages and hence will not propagate the route. This is especially the case if one expect Internet wide propagation of its route, which seems highly improbable until a few years/decades”.

​The above text which very true triggered few more observations:

​- As this is WG last call implementation report (even on the wiki should be available) Can we get a pointer to it ? I do not see it on the IETF page:

https://www.ietf.org/iesg/implementation-report.html

- Did implementation report (if even completed) included the set of test cases say with large AS_PATH or long Extended Community (stuffing a lot of RTs as described in RTC backwards compatibility work) to make sure that most popular BGP implementation can handle such large attributes without crashing ? Otherwise enabling this would be an excellent attack vector in the Internet.

- Do we have an agreement that this will not be "ON" by default, but will be enabled only with a knob ? 

- How do we detect if this is supported across the private AS/public Internet zoo of routers ? Should we have a protocol tool which would allow to detect support of extended messages at each BGP speaker and if not report this as an error to the originator of the large message ? Sending large BGP message if not supported by any remote peer by any BGP speaker along the propagation would trigger reporting it back with new ICMP error could be one approach. I am sure there would be others ...

Thx,

r.

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 6 Jun 2016 15:14:59 -0400

Randy, Keyur and Dave: 

This draft has receive several comment, but the support for publication is
almost 100%.   Once we have a revised version and implementation reports, we
should be able to proceed.

Would you do the following: 

1)      Publish a version of the draft with revision suggested on the list, 

2)      Update the wiki with implementation information 

<https://trac.tools.ietf.org/wg/idr/trac/wiki/draft-ietf-idr-bgp-extended-im
plementations>
https://trac.tools.ietf.org/wg/idr/trac/wiki/draft-ietf-idr-bgp-extended-imp
lementations

After these are updated, we will confirm with the list that the issues have
been addressed, and then proceed with the publication request.

 Sue Hares and John Scudder 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, May 24, 2016 4:42 PM
To: [email-masked]
Cc: 'Keyur Patel (keyupate)'; 'David Ward'
Subject: [Idr] draft-ietf-idr-bgp-extended-messages-12 WG LC (5/24 to 6/7)

This begins a 2 week WG LC on draft-ietf-idr-bgp-extended-messages (5/24 to
6/7). The draft can be found at: 

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-extended-messages/

In your comments please provide the following information: 

1)      Support/"no-support" of this draft being ready for publication,

2)      You know of an implementation for this draft, please report the
implementation to the IDR Wiki

https://trac.tools.ietf.org/wg/idr/trac/wiki/draft-ietf-idr-bgp-extended-imp
lementations 

3)      Do you have any concerns about extending the BGP messages. 

Sue Hares and John Scudder