Subject: Re: [Idr] Regarding segment routing capability bit set in ŒRouter Informational Capabilities TLV¹ of RI LSA

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 23 Nov 2016 11:53:36 +0000

Hi Veerandranath,

Since an algorithm and SID/Label range is required for segment-routing operation in OSPF, no bit is necessary. If a bit were to be allocated, it would go in the RI functional capabilities rather than the informational capabilities.

Thanks,
Acee

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 23, 2016 at 4:48 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: IDR List <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Regarding segment routing capability bit set in ‘Router Informational Capabilities TLV’ of RI LSA

Dear Authors,
While advertising Segment Routing capabilities in RI LSA, as per draft there is ‘no bit’ is allocated in ‘Router Informational Capabilities TLV’  for segment routing capability.

9.  IANA Considerations

   This specification updates several existing OSPF registries.

9.1.  OSPF Router Information (RI) TLVs Registry

   o 8 (IANA Preallocated) - SR-Algorithm TLV

   o 9 (IANA Preallocated) - SID/Label Range TLV

   o 12 - SR Local Block Sub-TLV

   o 13 - SRMS Preference Sub-TLV

Whether bit set in ‘Router Informational Capabilities TLV’  is not required for segment routing capability , to notify neighbors?

Regards,
Veerendranath

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Thu, 24 Nov 2016 01:56:32 +0000

Thanks to Acee and Hannes for your reply.
I got it.

Regards,
Veerendranath

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: 23 November 2016 17:24
To: Veerendranatha Reddy Vallem <[email-masked]>; [email-masked]
Cc: [email-masked]' <[email-masked]>
Subject: Re: [Idr] Regarding segment routing capability bit set in ŒRouter Informational Capabilities TLV¹ of RI LSA

Hi Veerandranath,

Thanks,
Acee

Dear Authors,

9.  IANA Considerations

Regards,
Veerendranath