Subject: Re: [Ieprep] requirements document(s)

From: [email-masked]
Date: Fri, 20 Sep 2002 15:45:06 EDT

In a message dated 9/20/2002 12:58:16 PM Eastern Standard Time, 
[email-masked] writes:

> Any QoS control mechanism needs three parts:
>     - a means for end systems to indicate their urgency needs.  To use a 
> diff-serv example, this means setting the DS byte in datagrams accordingly.
>     - a means for the plumbing infrastructure to treat the urgent traffic 
> with 
> expeditious service.  In diff-serv example this is accomplished by giving 
> the 
> urgent traffic head-of-line privs in the router queues.  You could do this 
> by 
> throttling ingress, but the complexity of that problem strikes me as 
> boggling.
>     - an authentication means so that the labeled service is not abused by 
> people and for purposes that aren't 'urgent'.  
> 

[MAP] I don't fully agree. Your third bullet I presume is talking about 
people who are authorized to use "urgent" but not really for what they are 
actually using it for.
The QoS mechanism could not possibly use authentication to prevent such an 
authorized person from abusing a "label". This is not a requirement. Yes, 
"precedence creep" has always been a problem, but the system or network is 
not responsible for preventing it.

The requirement is for "an authentication means so that the labeled service 
is only used by people who are authorized to use it".

In order to detect abuse (after the fact) there needs to be accounting 
mechanisms to record the use of labels, so that someone (off-line) can 
determine "abuse".

Mike Pierce
Artel

---

From: Rex Buddenberg <[email-masked]>
Date: Fri, 20 Sep 2002 14:00:00 -0700

Mike,  I think you're disagreeing with the hints I dropped about how to go 
about preventing precedence creep.  But we seem to be agreeing that _some_ 
means of controlling precedence creep is necessary.  Therefore, at 
requirements time, we simply state that.  (either crib the second sentence in 
this paragraph or the 3rd bullet below -- and drop the modifier 
'authentication'.

On Friday 20 September 2002 12:45 pm, [email-masked] wrote:
> >     - a means for the plumbing infrastructure to treat the
> > urgent traffic with
> > urgent traffic head-of-line privs in the router queues.  You could do
> > this by
> >     - an authentication means so that the labeled service is not abused
> > by people and for purposes that aren't 'urgent'.
>

-- 
b
_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep

---

From: senthil ayyasamy <[email-masked]>
Date: Mon, 23 Sep 2002 18:10:43 -0700 (PDT)

> > Any QoS control mechanism needs three parts:
[...]
> > people and for purposes that aren't 'urgent'.  
[...]
> mechanisms to record the use of labels, so that
 It seems to be that you are suggesting *accounting*
as a means for carrying out  authetication function.
So, authetication is still a requirement.
 Though the question is out of scope for the 
requirement draft, How do you do accounting of Labels
? RADIUS or something. Is their any standard practised
method? 

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com
_______________________________________________
Ieprep mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ieprep