Subject: Re: [ietf-dkim] [Technical Errata Reported] RFC6376 (3192)

From: Barry Leiba <[email-masked]>
Date: Sat, 14 Apr 2012 18:25:08 -0400

I've checked this, and it's correct.  We copied the examples from 4871, and
made the editorial error of adding a space without changing the hash.  I'll
mark it as Verified if i hear no objections soon.

Barry

On Saturday, April 14, 2012, RFC Errata System wrote:

>
> The following errata report has been submitted for RFC6376,
> "DomainKeys Identified Mail (DKIM) Signatures".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6376&eid=3192
>
> --------------------------------------
> Type: Technical
> Reported by: John Hawthorn <[email-masked] <javascript:;>>
>
> Section: Appendix A
>
> Original Text
> -------------
>   From: Joe SixPack <[email-masked] <javascript:;>>
>   To: Suzie Q <[email-masked] <javascript:;>>
>   Subject: Is dinner ready?
>   Date: Fri, 11 Jul 2003 21:00:37 -0700 (PDT)
>   Message-ID: <[email-masked]<javascript:;>
> >
>
>   Hi.
>
>   We lost the game.  Are you hungry yet?
>
>   Joe.
>
> Corrected Text
> --------------
>   From: Joe SixPack <[email-masked] <javascript:;>>
>   To: Suzie Q <[email-masked] <javascript:;>>
>   Subject: Is dinner ready?
>   Date: Fri, 11 Jul 2003 21:00:37 -0700 (PDT)
>   Message-ID: <[email-masked]<javascript:;>
> >
>
>   Hi.
>
>   We lost the game. Are you hungry yet?
>
>   Joe.
>
> Notes
> -----
> This text appears three times, in A.1., A.2., and A.3.
> Notice the double space after "game.", which renders the body hashes from
> A.2. and A.3. invalid.
> The corrected text is the same as that in RFC 4871.
>
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC6376 (draft-ietf-dkim-rfc4871bis-15)
> --------------------------------------
> Title               : DomainKeys Identified Mail (DKIM) Signatures
> Publication Date    : September 2011
> Author(s)           : D. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed.
> Category            : DRAFT STANDARD
> Source              : Domain Keys Identified Mail
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Barry Leiba <[email-masked]>
Date: Sat, 14 Apr 2012 18:30:33 -0400

FWIW, the error was introduced by the RFC Editor, who surely used
double-space-between-sentences style, and didn't know that in that
particular case, the space matters.  And we didn't notice it in AUTH48
reviews.  Something we need to remember to check for, in the rare cases
where it does matter.

Barry

On Saturday, April 14, 2012, Barry Leiba wrote:

> I've checked this, and it's correct.  We copied the examples from 4871,
> and made the editorial error of adding a space without changing the hash.
>  I'll mark it as Verified if i hear no objections soon.
>
> Barry
>
>> Reported by: John Hawthorn <[email-masked]>
>>
>> Section: Appendix A
>>
>> Original Text
>> -------------
>>   From: Joe SixPack <[email-masked]>
>>   To: Suzie Q <[email-masked]>
>>   Message-ID: <[email-masked]>
>>
>>   Hi.
>>
>>   From: Joe SixPack <[email-masked]>
>>   To: Suzie Q <[email-masked]>
>>   Message-ID: <[email-masked]>
>>
>>   Hi.
>>

---

From: Dave Crocker <[email-masked]>
Date: Sat, 14 Apr 2012 15:26:27 -0700 (PDT)

+1

/d

--

Dave Crocker
bbiw.net

-----Original Message-----
From: Barry Leiba <[email-masked]>
To: RFC Errata System <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Sent: Sat, 14 Apr 2012 3:25 PM
Subject: Re: [Technical Errata Reported] RFC6376 (3192)

Barry

---

From: Dave Crocker <[email-masked]>
Date: Sat, 14 Apr 2012 15:32:13 -0700 (PDT)

raises a small question of needing notes to the editor advising hands off for such segments.

/d

--

Dave Crocker
bbiw.net

-----Original Message-----
From: Barry Leiba <[email-masked]>
To: Barry Leiba <[email-masked]>
Cc: RFC Errata System <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Sent: Sat, 14 Apr 2012 3:30 PM
Subject: Re: [Technical Errata Reported] RFC6376 (3192)

Barry

---

From: Dave Crocker <[email-masked]>
Date: Mon, 16 Apr 2012 08:15:07 -0700

On 4/16/2012 8:10 AM, RFC Editor wrote:
> Just a heads up that we will be reviewing this one internally with the
> team to raise our awareness of the issue.  Additionally, we agree with
> Dave, and encourage the inclusion of notes to help avoid such errors
> in the future.   

My guess is that the existing notation for communicating inline to the RFC
editor is sufficient.  That is, I'd expect the real issue being one of getting
us all to tell you what not to format, rather than one of creating a new notation.

d/
-- 

  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net
_______________________________________________
NOTE WELL: This list operates according to 
http://mipassoc.org/dkim/ietf-list-rules.html