Subject: Re: [ietf-dkim] [Technical Errata Reported] RFC6376 (5070)

From: Dave Crocker <[email-masked]>
Date: Sat, 15 Jul 2017 09:22:36 -0700

On 7/15/2017 9:10 AM, RFC Errata System wrote:
> Original Text
> -------------
>     tag-spec  =  [FWS] tag-name [FWS] "=" [FWS] tag-value [FWS]
>     tag-name  =  ALPHA *ALNUMPUNC
>     tag-value =  [ tval *( 1*(WSP / FWS) tval ) ]
>                       ; Prohibits WSP and FWS at beginning and end
> 
> Corrected Text
> --------------
>     tag-spec  =  [FWS] tag-name [FWS] "=" [FWS] [tag-value [FWS]]
>     tag-name  =  ALPHA *ALNUMPUNC
>     tag-value =  tval *( 1*(WSP / FWS) tval )
>                       ; Prohibits WSP and FWS at beginning and end
> 
> Notes
> -----
> The ABNF in the document permits two FWS rules to appear in the row. This results in permitting a line with only whitespace in the header which falls into obsolete syntax in RFC 5322 (Appendix B rule 12). The corrected text disallows this by eliding the second FWS when the tag-value is empty/omitted.

Hitting 'obsolete' RFC5322 syntax doesn't bother me all that much, given 
that there is now a long history of non-enforcement; the constructs were 
never seriously deprecated.

But the proposed change does seem cleaner to me.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net
_______________________________________________
NOTE WELL: This list operates according to
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Dave Crocker <[email-masked]>
Date: Sat, 15 Jul 2017 09:52:06 -0700

(resent, to get a working murray address. /d)

d/

---

From: Dave Crocker <[email-masked]>
Date: Sat, 15 Jul 2017 10:29:11 -0700

(sigh.  re-re-sent to try for a valid tony address too...)
(resent, to get a working murray address. /d)

d/

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 20 Jul 2017 13:25:08 +0000

On 7/15/17, 1:29 PM, "Dave Crocker" <[email-masked]> wrote:

    

Right, “FWS optional-tval FWS” to “FWS optional-(tval and FWS)” is indeed cleaner.

	Tony