Subject: [ietf-dkim] Fwd: SendGrid, GetResponse and Hubspot being used over DKIM "patent"

From: Steve Atkins <[email-masked]>
Date: Tue, 5 Dec 2017 09:54:21 -0800

I thought this might be of interest to DKIM implementers.

> Begin forwarded message:
> 
> From: Laura Atkins <[email-masked]>
> 
> A company called TrueMail is suing the above 3 companies claiming DKIM is an infringement of 3 patents they own. 
> 
> Docs are up:  
> 
> https://www.courtlistener.com/docket/6173128/truemail-technologies-llc-v-getresponse-inc/
> https://www.courtlistener.com/docket/6178679/truemail-technologies-llc-v-hubspot-inc/
> https://www.courtlistener.com/docket/6173696/truemail-technologies-llc-v-sendgrid-inc/
> 
> I’ve only taken the briefest look through one of the complaints. Here’re the relevant bits: 
> 
> The Asserted Patents share a common specification. 
> 
> 21. The ’126 patent claims, among other inventions, a method for identifying unwanted email messages, by which the sender is assigned a unique, private, digital signature. The sender, in turn, agrees to conform to a set of rules of conduct, and the recipients receive the email with a public digital signature, which allows them to verify the identity of the sender. This method allows for the monitoring of the number of substantially identical emails being sent to different recipients, and allows for distinguishing a given email message from unsolicited and unwanted email messages. See ’126 patent, 7:6-48 
> 
> 22. The ’126 patent specification describes an email system in which a sender is limited in transmitting identical emails to a predetermined number of recipients over a specified period of time. The sender, who is identified by its unique digital signature, also manifests a promise to not solicit business or contain unsolicited advertising. The unique digital signature provides a method to distinguish unsolicited email messages from ones in which the sender has promised that the recipient has made a prior request or granted permission to receive said email. This promise is legally binding and traceable to the sender by its unique digital signature. See ’126 patent, 7:6-67 & 8:11-64.
> 
> 23. The ’655 patent claims, among other inventions, a method for identifying unwanted email messages, by which the sender is assigned a unique, private, digital signature. The sender, in turn, agrees to conform to a set of rules of conduct, and the recipients receive the email with a public digital signature, which allows them to verify the identity of the sender. This method allows for the monitoring of the number of substantially identical emails being sent to different recipients, and allows for distinguishing a given email message from unsolicited and unwanted email messages. See ’655 patent, 7:11-45. 
> 
> 24. The ’655 patent specification describes an email system in which a sender is limited in transmitting identical emails to a predetermined number of recipients over a specified period of time. The sender, who is identified by its unique digital signature, also manifests a promise to not solicit business or contain unsolicited advertising. The sender also promises that no further email messages will be sent to the recipients upon receipt of a cancellation request by the recipients. The unique digital signature provides a method to distinguish unsolicited email messages from ones in which the sender has promised that the recipient has made a prior request or granted permission to receive said email. This promise is legally binding and traceable to the send by its unique digital signature. See ’655 patent, 7:46-67 & 8:1-9:31. 
> 
> 25. The ’084 patent claims, among other inventions, a method for identifying unwanted email messages, by which the sender is assigned a unique, private, digital signature. The sender, in turn, agrees to conform to a set of rules of conduct, and the recipients receive the email with a public digital signature, which allows them to verify the identity of the sender. This method allows for the monitoring of the number of substantially identical emails being sent to different recipients, and allows for distinguishing a given email message from unsolicited and unwanted email messages. See ’084 patent, 7:17-8:9.
> 
> 26. The ’084 patent specification describes an email system in which a sender is limited in transmitting identical emails to a predetermined number of recipients over a specified period of time. The sender, who is identified by its unique digital signature, also manifests a promise to not solicit business or contain unsolicited advertising. The unique digital signature provides a method to distinguish unsolicited email messages from ones in which the sender has promised that the recipient has made a prior request or granted permission to receive said email. This promise is legally binding and traceable to the send by its unique digital signature. See ’084 patent, 8:10-56.
> 
> laura 
> 
> -- 
> Having an Email Crisis?  We can help! 800 823-9674 
> 
> Laura Atkins
> Word to the Wise
> [email-masked]
> (650) 437-0741		
> 
> Email Delivery Blog: https://wordtothewise.com/blog	
> 
> 
> 
> 
> 
> 
> 

_______________________________________________
NOTE WELL: This list operates according to
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: "Mark Delany" <[email-masked]>
Date: 5 Dec 2017 20:50:38 +0000

> The Asserted Patents share a common specification.

Did the claimants vacuum up the IP of the now defunct Goodmail? Reads
somewhat similar to what they were once trying to sell. Particularly
the "contractual" obligations of the senders.

From what I can glean, the plan is to digitally sign the email along
the lines of S/MIME (PKI and CAs are referred to extensively and
exclusively) and the sender include a "pledge" about the contents such
as "no more than 5 recipients will get this email". Recipients can act
on the pledge in the knowledge that senders apparently won't lie in
their pledge. Or if they do lie something will happen to them -
exactly what or how is not specified.

How the pledge is validated across the whole of Internet email is
undefined as is what to do to the sender if the pledge is known to be
a lie.

There are no references to DNS, no reference to how they determine
identical mail (canonicalization), no reference to S/MIME or DKIM in
any of their filings.

I guess the "pledge" on the part of the sender is vaguely novel but
there is no equivalent in DKIM as far as I recall. Maybe the vendors
you refer to have features that emulates pledges when sending email?

For moral equivalence, the Date: header is a pledge as to when the
email was composed/sent and Content-Type: is a pledge as to how the
MIME part has been encoded so the novelty is not even that there are
pledges in the email, just the nature of the pledge.

To me they seem to have invented a new mail header.

Mark.

---

From: Dave Crocker <[email-masked]>
Date: Tue, 5 Dec 2017 13:01:49 -0800

On 12/5/2017 12:50 PM, Mark Delany wrote:
> email was composed/sent

I've done only two user studies in my life.  The first -- for the Rand 
system --produced the email command name 'reply'.  The second -- for the 
DRUMS production of RFC2822, I believe, clarifying RFC822 -- was for the 
semantics of the Date: field.  It's meaning was not lear in 822 and the 
result of the survey of users I did was to define it as the time of 
posting.  Hence the 'send' you cite, rather than the 'compose'.

Thank you for tolerating this distraction.  You are now returned to 
matters of substance...

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net
_______________________________________________
NOTE WELL: This list operates according to
http://mipassoc.org/dkim/ietf-list-rules.html

---

From: Suresh Ramasubramanian <[email-masked]>
Date: Wed, 6 Dec 2017 05:54:11 +0530

The pledge idea isn’t terribly novel either 

Anne Mitchell used a habeas haiku and then contract law to enforce that any email with that haiku in the headers had to be complaint with anti Spam best practices or would get sued.

--srs

> On 06-Dec-2017, at 2:20 AM, Mark Delany <[email-masked]> wrote:
>

---

From: "Mark Delany" <[email-masked]>
Date: 6 Dec 2017 00:33:05 +0000

On 06Dec17, Suresh Ramasubramanian allegedly wrote:
> The pledge idea isn???t terribly novel either 
> 
> Anne Mitchell used a habeas haiku

Gosh. The Haiku. How could I have possibly forgotten that beauty! But,
if you really want to intimidate spammers with poetry I recommend the
very effective Haka instead.

Mark.

---

From: Suresh Ramasubramanian <[email-masked]>
Date: Wed, 6 Dec 2017 06:34:19 +0530

Works for me. I could never look anything but ridiculous though .. 6 ft 40ish potbellied indian guy sticking his tongue out and trying to look like a scary Maori warrior, nope.

--srs

> On 06-Dec-2017, at 6:03 AM, Mark Delany <[email-masked]> wrote:
>

---

From: Roland Turner <[email-masked]>
Date: Wed, 6 Dec 2017 09:09:07 +0800

> very effective Haka instead.

(wonders whether the possible applications of Vogon poetry have been 
adequately explored)

- Roland

---

From: Daniel Dreymann <[email-masked]>
Date: Tue, 5 Dec 2017 18:05:46 -0800

> the "contractual" obligations of the senders.

Goodmail indeed sold its patent portfolio, but none of the three patents
asserted is related to Goodmail's intellectual property.

Ironically, Gmail placed Steve's original message in my spam folder.

DTD