Subject: Re: [Ietf-languages] Forms for July 2017 changes to ISO 15924

From: "Doug Ewell" <[email-masked]>
Date: Mon, 31 Jul 2017 08:46:48 -0700

Peter Constable wrote:

> The entries for Naxi Dongba and Naxi Geba have phonemic
> transcriptions. I'm not sure where those came from. Does anyone know
> whether those are Naxi pronunciations of the names, or Mandarin
> pronunciations?

To answer one possible interpretation of Peter's question, which is
"what are they doing here?", the script subtag 'Nkgb' for Nakhi Geba has
had one of these since it was added in 2009:

Description: 'Na-'Khi ²Ggŏ-¹baw

RFC 5646 says Description fields are not supposed to be used for
transcriptions and translations, but also says that we try to match them
to the reference name(s) in the core standard (language, extlang,
region, script). So we already have Lengua de señas catalana and
Llengua de Signes Catalana, and finlandssvenskt teckenspråk and
suomenruotsalainen viittomakieli, and 'Na-'Khi ²Ggŏ-¹baw, and the
current proposals add "na²¹ɕi³³ to³³ba²¹ and na²¹ɕi³³
gʌ²¹ba²¹. In all likelihood we would not have added any of these if
they weren't in the ISO standard.
 
--
Doug Ewell | Thornton, CO, US | ewellic.org

---

From: Mark Davis ☕️ <[email-masked]>
Date: Mon, 31 Jul 2017 18:53:08 +0200

Adding a name in a core language to help distinguish an entry from others
is good.

But is "na²¹ɕi³³ to³³ba²¹" really the way the script is really is spelled
in a native language using that script?

Mark

(https://twitter.com/mark_e_davis)

On Mon, Jul 31, 2017 at 5:46 PM, Doug Ewell <[email-masked]> wrote:

> _______________________________________________
> Ietf-languages mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-languages
>

---

From: Peter Constable <[email-masked]>
Date: Mon, 31 Jul 2017 17:16:39 +0000

I was not asking "what are they doing here". My only concern is that, if we are providing a phonetic transcription of a language name, that it should be the autoglossonym as pronounced by a native speaker.

Peter

-----Original Message-----
From: Doug Ewell [mailto:[email-masked]] 
Sent: Monday, July 31, 2017 8:47 AM
To: Peter Constable <[email-masked]>; ietf-languages <[email-masked]>
Subject: RE: [Ietf-languages] Forms for July 2017 changes to ISO 15924

> whether those are Naxi pronunciations of the names, or Mandarin 

To answer one possible interpretation of Peter's question, which is "what are they doing here?", the script subtag 'Nkgb' for Nakhi Geba has had one of these since it was added in 2009:

RFC 5646 says Description fields are not supposed to be used for transcriptions and translations, but also says that we try to match them to the reference name(s) in the core standard (language, extlang, region, script). So we already have Lengua de señas catalana and Llengua de Signes Catalana, and finlandssvenskt teckenspråk and suomenruotsalainen viittomakieli, and 'Na-'Khi ²Ggŏ-¹baw, and the current proposals add "na²¹ɕi³³ to³³ba²¹ and na²¹ɕi³³ gʌ²¹ba²¹. In all likelihood we would not have added any of these if they weren't in the ISO standard.

---

From: John Cowan <[email-masked]>
Date: Mon, 31 Jul 2017 13:17:53 -0400

On Mon, Jul 31, 2017 at 12:53 PM, Mark Davis ☕️ <[email-masked]> wrote:

> in a native language using that script?

Unlikely.  But though all languages have endonyms, 90% cannot be written in
native script (because there is none), so that is no objection.

-- 
 John Cowan          http://vrici.lojban.org/~cowan        [email-masked]
A rabbi whose congregation doesn't want to drive him out of town isn't
a rabbi, and a rabbi who lets them do it isn't a man.    --Jewish saying

---

From: Mark Davis ☕️ <[email-masked]>
Date: Mon, 31 Jul 2017 20:15:43 +0200

The purpose in the registry of a name for ascript is to enable people to
distinguish it from other scripts. So the question is whether any
significant community would be unable to distinguish Naxi Geba from other
scripts, but would be able if "na²¹ɕi³³ to³³ba²¹" were another description.

Mark

On Mon, Jul 31, 2017 at 7:17 PM, John Cowan <[email-masked]> wrote:

> Unlikely.  But though all languages have endonyms, 90% cannot be written
> in native script (because there is none), so that is no objection.
>
> --