Subject: [Ietf-message-headers] Registration request for EntityId, Isolation, OData-MaxVersion, and OData-Version

From: Chet Ensign <[email-masked]>
Date: Wed, 29 Aug 2018 14:17:25 -0400

This message contains the information needed for Permanent Registration of
the OData specific request headers with IANA as covered in RFC 3864 -
Registration Procedures for Message Header Fields.

---

PERMANENT MESSAGE HEADER FIELD REGISTRATION TEMPLATE:

Header field name:

EntityId

Applicable protocol:

OASIS Open Data Protocol (OData)

Status:

Standard

Author/Change controller:

OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification
editor. Mark Biamonte ([email-masked]), Progress Software
editor for registration template.

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderEntityIdODataEntityId

Related information:
The EntityId header was named OData-EntityId in OData version 4.0.

####

Header field name:

Isolation

Applicable protocol:

OASIS Open Data Protocol (OData)

Status:

Standard

Author/Change controller:

OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification
editor. Mark Biamonte ([email-masked]), Progress Software
editor for registration template.

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderIsolationODataIsolation

Related information:
       The Isolation header was named OData-Isolation in OData version 4.0.

####

Header field name:

OData-MaxVersion

Applicable protocol:

OASIS Open Data Protocol (OData)

Status:

Standard

Author/Change controller:

OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification
editor. Mark Biamonte ([email-masked]), Progress Software
editor for registration template.

Specification document(s):

OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataMaxVersion

Related information:

<none>

####

Header field name:

OData-Version

Applicable protocol:

OASIS Open Data Protocol (OData)

Status:

Standard

Author/Change controller:

OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification
editor. Mark Biamonte ([email-masked]), Progress Software
editor for registration template.

Specification document(s):

OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataVersion

Related information:

<none>

---

/chet
----------------
Chet Ensign
Chief Technical Community Steward
OASIS: Advancing open standards for the information society
http://www.oasis-open.org

Primary: +1 973-996-2298
Mobile: +1 201-341-1393

---

From: Ted Hardie <[email-masked]>
Date: Wed, 29 Aug 2018 11:58:45 -0700

Hi Chet,

I'm a little confused on one point.  The Isolation header states that it
was called OData-Isolation in version 4.0, but the linked ABNF document
says:

isolation  = [ "OData-" ] "Isolation" ":" OWS "snapshot"

That seems to indicate that both ODate-Isolation and Isolation are expected
to be valid for this token.  The ABNF for EntityID is similar:

entityid   = [ "OData-" ] "EntityID" ":" OWS IRI-in-header

Can you clarify the intent here?  Are both expressions of this token
expected to continue?

In general, "Isolation" seems to be a very general concept, and the
reservation of it, unadorned, for a single token use ("snapshot") is
somewhat surprising compared to the more-obviously scoped OData-isolation.
EntityID seems similar board in possible usage outside the OData
specification.

regards,

Ted Hardie

On Wed, Aug 29, 2018 at 11:17 AM, Chet Ensign <[email-masked]>
wrote:

> OASIS. Michael Pizzo ([email-masked]), Microsoft primary
> specification editor. Mark Biamonte ([email-masked]),
> Progress Software editor for registration template.
>
> http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-
> part1-protocol.html#sec_HeaderEntityIdODataEntityId
> <http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol..html#sec_HeaderEntityIdODataEntityId>
>
>
> Related information:
> OASIS. Michael Pizzo ([email-masked]), Microsoft primary
> specification editor. Mark Biamonte ([email-masked]),
> Progress Software editor for registration template.
>
> http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-
> part1-protocol.html#sec_HeaderIsolationODataIsolation
>
> Related information:
> OASIS. Michael Pizzo ([email-masked] <mikep@microsoft..com>),
> Microsoft primary specification editor. Mark Biamonte (
> [email-masked]), Progress Software editor for registration
> template.
>
> http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-
> part1-protocol.html#sec_HeaderODataMaxVersion
>
> Related information:
>
> <none>
>
> ####
>
> Header field name:
>
> OData-Version
>
> Applicable protocol:
>
> OASIS. Michael Pizzo ([email-masked]), Microsoft primary
> specification editor. Mark Biamonte ([email-masked]),
> Progress Software editor for registration template.
>
> http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-
> part1-protocol.html#sec_HeaderODataVersion
>
> Related information:
>
> <none>
>
> ---
>
> /chet
> ----------------
> Chet Ensign
> _______________________________________________
> Ietf-message-headers mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-message-headers
>
>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 30 Aug 2018 09:15:20 +1000

"Applicable protocol" should be "http", I think.

Cheers,

> On 30 Aug 2018, at 4:17 am, Chet Ensign <[email-masked]> wrote:
> 
> This message contains the information needed for Permanent Registration of the OData specific request headers with IANA as covered in RFC 3864 - Registration Procedures for Message Header Fields.
> 
> ---
> 
> 	OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification editor. Mark Biamonte ([email-masked]), Progress Software editor for registration template. 
> 
> 	OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification editor. Mark Biamonte ([email-masked]), Progress Software editor for registration template. 
> 
> 	OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification editor. Mark Biamonte ([email-masked]), Progress Software editor for registration template. 
> 
> 	OASIS. Michael Pizzo ([email-masked]), Microsoft primary specification editor. Mark Biamonte ([email-masked]), Progress Software editor for registration template. 
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Biamonte <[email-masked]>
Date: Fri, 31 Aug 2018 01:49:13 +0000

Hi Ted,

I am a member of the OData Technical Committee (TC).  Chet submitted the request for OASIS on behalf of the OData TC.  You are correct, in OData 4.0 the Headers were titled OData-Isolation and OData-EntityID.  In the latest OData 4.01 spec the header name was changed to just Isolation and EntityID.  The OData- prefixed versions are still supported for backwards compatibility.  This change was made based on feedback for users and implementors of the OData standard.  I gather your preference would be that we use the OData-prefixed version for the registrations.  If so I will need to discuss that with the TC and get back to you.

Mark Biamonte
Progress Software
Morrisville, NC

---------- Forwarded message ----------
From: Ted Hardie <[email-masked]<mailto:[email-masked]>>
Date: Wed, Aug 29, 2018 at 2:58 PM
Subject: Re: [Ietf-message-headers] Registration request for EntityId, Isolation, OData-MaxVersion, and OData-Version
To: Chet Ensign <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>, "Mark Biamonte (Progress)" <[email-masked]<mailto:[email-masked]>>

Hi Chet,

I'm a little confused on one point.  The Isolation header states that it was called OData-Isolation in version 4.0, but the linked ABNF document says:

isolation  = [ "OData-" ] "Isolation" ":" OWS "snapshot"
That seems to indicate that both ODate-Isolation and Isolation are expected to be valid for this token.  The ABNF for EntityID is similar:

Can you clarify the intent here?  Are both expressions of this token expected to continue?

In general, "Isolation" seems to be a very general concept, and the reservation of it, unadorned, for a single token use ("snapshot") is somewhat surprising compared to the more-obviously scoped OData-isolation.  EntityID seems similar board in possible usage outside the OData specification.

regards,

Ted Hardie

On Wed, Aug 29, 2018 at 11:17 AM, Chet Ensign <[email-masked]<mailto:[email-masked]>> wrote:
This message contains the information needed for Permanent Registration of the OData specific request headers with IANA as covered in RFC 3864 - Registration Procedures for Message Header Fields.

---

Header field name:

EntityId

Applicable protocol:

Status:

Standard

OASIS. Michael Pizzo ([email-masked]<mailto:[email-masked]>), Microsoft primary specification editor. Mark Biamonte ([email-masked]<mailto:[email-masked]>), Progress Software editor for registration template.

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderEntityIdODataEntityId<http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol..html#sec_HeaderEntityIdODataEntityId>

Related information:

####

Header field name:

Isolation

Applicable protocol:

Status:

Standard

OASIS. Michael Pizzo ([email-masked]<mailto:[email-masked]>), Microsoft primary specification editor. Mark Biamonte ([email-masked]<mailto:[email-masked]>), Progress Software editor for registration template.

Specification document(s):
OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderIsolationODataIsolation<http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderIsolationODataIsolation>

Related information:

####

Header field name:

OData-MaxVersion

Applicable protocol:

Status:

Standard

OASIS. Michael Pizzo ([email-masked]<mailto:mikep@microsoft..com>), Microsoft primary specification editor. Mark Biamonte ([email-masked]<mailto:[email-masked]>), Progress Software editor for registration template.

OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataMaxVersion<http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataMaxVersion>

Related information:

<none>

####

Header field name:

OData-Version

Applicable protocol:

Status:

Standard

OASIS. Michael Pizzo ([email-masked]<mailto:[email-masked]>), Microsoft primary specification editor. Mark Biamonte ([email-masked]<mailto:[email-masked]>), Progress Software editor for registration template.

OData Version 4.01 Part 1: Protocol -
http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataVersion<http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderODataVersion>

Related information:

<none>

---

/chet
----------------
Chet Ensign
Chief Technical Community Steward
OASIS: Advancing open standards for the information society
http://www.oasis-open.org<http://www.oasis-open.org>

Primary: +1 973-996-2298
Mobile: +1 201-341-1393

_______________________________________________
Ietf-message-headers mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf-message-headers<https://www.ietf.org/mailman/listinfo/ietf-message-headers>

--

/chet
----------------

Looking forward to Borderless Cyber 2018<https://us18.borderlesscyber.org/en/>, 3-5 Oct, Washington, D.C.
Organized by The World Bank, OASIS, and Georgetown University

Chet Ensign
Chief Technical Community Steward
OASIS: Advancing open standards for the information society
http://www.oasis-open.org<http://www.oasis-open.org>

Primary: +1 973-996-2298
Mobile: +1 201-341-1393

---

From: Mark Biamonte <[email-masked]>
Date: Fri, 31 Aug 2018 01:58:09 +0000

Mark,

I was thinking that the protocol was the standard that defined the header, but looking at the existing registrations, I agree the Applicable protocol should be http.

Regards
Mark Biamonte
Progress Software
Morrisville, NC

From: Mark Nottingham <[email-masked]>
Sent: Wednesday, August 29, 2018 7:15 PM
To: Chet Ensign <[email-masked]>
Cc: [email-masked]; Mark Biamonte <[email-masked]>
Subject: Re: [Ietf-message-headers] Registration request for EntityId, Isolation, OData-MaxVersion, and OData-Version

Cheers,

> On 30 Aug 2018, at 4:17 am, Chet Ensign <[email-masked]<mailto:[email-masked]>> wrote:
>
> http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderEntityIdODataEntityId<http://docs.oasis-open.org/odata/odata/v4.01/odata-v4.01-part1-protocol.html#sec_HeaderEntityIdODataEntityId>
>
> Related information:
>

--
Mark Nottingham https://www.mnot.net/<https://www.mnot.net/>

---

From: Ted Hardie <[email-masked]>
Date: Fri, 31 Aug 2018 09:54:12 -0700

Hi Mark,

On Thu, Aug 30, 2018 at 6:49 PM, Mark Biamonte <[email-masked]>
wrote:

> Hi Ted,
>
>
>
> I am a member of the OData Technical Committee (TC).  Chet submitted the
> request for OASIS on behalf of the OData TC.  You are correct, in OData 4.0
> the Headers were titled OData-Isolation and OData-EntityID.  In the latest
> OData 4.01 spec the header name was changed to just Isolation and
> EntityID.  The OData- prefixed versions are still supported for backwards
> compatibility.
>

Okay; I was probing to find out if this superseded the previous header, but
it sounds like you expect both to be used at least during the compatibility
period.

> This change was made based on feedback for users and implementors of the
> OData standard.  I gather your preference would be that we use the
> OData-prefixed version for the registrations.  If so I will need to discuss
> that with the TC and get back to you.
>
>
>

While that would be my personal preference, it is simply that:  my opinion
as an individual.  I'm primarily concerned that other, unregistered or
pre-registration uses of these more general concepts may occur.  While
recording them in the registry will help avoid collisions, there is always
some risk and the more general the term, the higher the risk.

regards,

Ted Hardie

> From: *Ted Hardie* <[email-masked]>
> Subject: Re: [Ietf-message-headers] Registration request for EntityId,
> Isolation, OData-MaxVersion, and OData-Version
> Cc: [email-masked], "Mark Biamonte (Progress)" <
> [email-masked]>
>
> Hi Chet,
>
>
>
> That seems to indicate that both ODate-Isolation and Isolation are
> expected to be valid for this token.  The ABNF for EntityID is similar:
>
>
>
> Looking forward to Borderless Cyber 2018
> <https://us18.borderlesscyber.org/en/>, 3-5 Oct, Washington, D.C.
>
> *Organized by The World Bank, OASIS, and Georgetown University*
>
>
>
> Chet Ensign

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 1 Sep 2018 09:48:43 +1000

> On 1 Sep 2018, at 2:54 am, Ted Hardie <[email-masked]> wrote:
> 
>> This change was made based on feedback for users and implementors of the OData standard.  I gather your preference would be that we use the OData-prefixed version for the registrations.  If so I will need to discuss that with the TC and get back to you.
> 
> 
> While that would be my personal preference, it is simply that:  my opinion as an individual.  I'm primarily concerned that other, unregistered or pre-registration uses of these more general concepts may occur.  While recording them in the registry will help avoid collisions, there is always some risk and the more general the term, the higher the risk.
> 

Speaking personally, I'd second that concern. It's least confusing when headers that are specific to an application (in this case, OData) include that application's name in their field name. 

Cheers,