Subject: [Ietf-message-headers] Permanent message header field registration for traceparent and tracestate

From: Philippe Le Hegaret <[email-masked]>
Date: Thu, 24 Mar 2022 11:58:52 -0400

I'd like to update two entries from provisional to permanent.

This is a follow-up to
 
https://mailarchive.ietf.org/arch/msg/ietf-message-headers/AUPU45d0Pr30TEjx-yo4hvCwYQw/

The specification was updated in November 2021 to address the comments.

[[
Header field name: traceparent
Applicable protocol: http
Status: permanent
Change Controller:
    Distributed Tracing Working Group
    https://www.w3.org/groups/wg/distributed-tracing
    [email-masked]
Specification:
    https://www.w3.org/TR/trace-context/#traceparent-header

Header field name: tracestate
Applicable protocol: http
Status: permanent
Change Controller:
    Distributed Tracing Working Group
    https://www.w3.org/groups/wg/distributed-tracing
    [email-masked]
Specification:
    https://www.w3.org/TR/trace-context/#tracestate-header
]]

Thank you,

Philippe

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 25 Mar 2022 07:46:40 +1100

Hi Philippe,

HTTP field registrations are now tracked in a separate registry:
  https://www.iana.org/assignments/http-fields/http-fields.xhtml

... which contains instructions for requesting new registrations (see, in particular, <https://github.com/protocol-registries/http-fields>). 

This list is no longer used for that purpose.

Cheers,

> On 25 Mar 2022, at 2:58 am, Philippe Le Hegaret <[email-masked]> wrote:
> 
> _______________________________________________
> Ietf-message-headers mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-message-headers

--
Mark Nottingham   https://www.mnot.net/