Subject: [ietf-types] Registration for application/ttml+xml

From: Philippe Le Hegaret <[email-masked]>
Date: Thu, 06 Sep 2012 10:19:29 -0400

Hello,

This is Appendix C of TTML 1.0.

http://www.w3.org/TR/ttaf1-dfxp/#media-type-registration

Comments on this registration would be greatly appreciated.

Type name:
        
        application
        
Subtype name:
        
        ttml+xml
        
Required parameters:
        
        None.
        
Optional parameters:
charset
        
        Same as application/xml media type, as specified in [XML Media
        Types] or its successors.
        
profile
        
        The document profile of a TTML document may be specified using
        an optional profile parameter, which, if specified, the value of
        which must adhere to the syntax and semantics of ttp:profile
        parameter defined by Section 6.2.8 ttp:profile of the published
        specification.
        
Encoding considerations:
        
        Same for application/xml. See [XML Media], Section 3.2.
        
Security considerations:
        
        As with other XML types and as noted in [XML Media] Section 10,
        repeated expansion of maliciously constructed XML entities can
        be used to consume large amounts of memory, which may cause XML
        processors in constrained environments to fail.
        
        In addition, because of the extensibility features for TTML and
        of XML in general, it is possible that "application/ttml+xml"
        may describe content that has security implications beyond those
        described here. However, if the processor follows only the
        normative semantics of the published specification, this content
        will be outside TTML namespaces and may be ignored. Only in the
        case where the processor recognizes and processes the additional
        content, or where further processing of that content is
        dispatched to other processors, would security issues
        potentially arise. And in that case, they would fall outside the
        domain of this registration document.
        
Interoperability considerations:
        
        The published specification describes processing semantics that
        dictate behavior that must be followed when dealing with, among
        other things, unrecognized elements and attributes, both in TTML
        namespaces and in other namespaces.
        
        Because TTML is extensible, conformant "application/ttml+xml"
        processors must expect that content received is well-formed XML,
        but it cannot be guaranteed that the content is valid to a
        particular DTD or Schema or that the processor will recognize
        all of the elements and attributes in the document.
        
Published specification:
        
        Timed Text Markup Language (TTML) 1.0.
        
Applications that use this media type:
        
        TTML is used in the television industry for the purpose of
        authoring, transcoding and exchanging timed text information and
        for delivering captions for television material repurposed for
        the internet.
        
        There is partial and full support of TTML in components used by
        several Web browsers plugins, and in a number of caption
        authoring tools.
        
Additional information:
Magic number(s):
File extension(s):
        
        .ttml
        
Macintosh file type code(s):
        
        "TTML"
        
Fragment identifiers:
        
        For documents labeled as application/ttml+xml, the fragment
        identifier notation is intended to be used with xml:id
        attributes, as described in section 7.2.1 of the Timed Text
        Markup Language (TTML) 1.0 specification.
        
Person & email address to contact for further information:
        
        Timed Text Working Group ([email-masked])
        
Intended usage:
        
        COMMON
        
Restrictions on usage:
        
        None
        
Author:
        
        The published specification is a work product of the World Wide
        Web Consortium's Timed Text (TT) Working Group.
        
Change controller:
        
        The W3C has change control over this specification.

---

From: Philippe Le Hegaret <[email-masked]>
Date: Thu, 06 Sep 2012 16:10:35 -0400

> Comments on this registration would be greatly appreciated.

Someone kindly pointed out that the version in the reference and below
don't match. So here is a report of the registration template:
MIME media type name:
        
        application
        
MIME subtype name:
        
        ttml+xml
        
Required parameters:
        
        None.
        
Optional parameters:
charset

profile

Encoding considerations:

Restrictions on usage:
        
        None.
        
Security considerations:

        

        
Published specification:
        
        This media type registration is extracted from Appendix C Media
        Type Registration of the Timed Text Markup Language (TTML) 1.0
        specification.
        
Additional information:
Magic number(s):
File extension(s):
        
        .ttml

        "TTML"
        
Macintosh Universal Type Identifier code:
        
        org.w3c.ttml conforms to public.xml
        
Windows Clipboard Name:
        
        "Timed Text Document"

        
Intended usage:
        
        COMMON
        
Author/Change controller:
        
        The published specification is a work product of the World Wide
        Web Consortium's Timed Text (TT) Working Group. The W3C has
        change control over this specification.