Subject: IANA split and RFC Editor

From: "William Allen Simpson" <[email-masked]>
Date: Tue, 24 Feb 98 16:58:27 GMT

In addition to splitting IANA, I am also concerned that the RFC
Editorship might get lumped into the "new" corporation.  This would be a
Bad Thing.

Therefore, to emphasize the distinction already codified in the IAB
Charter, I recommend that Joyce Reynolds be designated the RFC Editor by
the IAB.

Of course, as we all know, Joyce has been doing the actual work for the
better part of a decade.  I still remember when Joyce went on vacation,
and Jon actually published some RFCs.  I got flak for 6 months about the
bad re-formatting and misspelling (of the month, on every page).

I see that Joyce is leaving the IESG, and this could be done as a "thank
you" of sorts (acknowledging her long work).

That would leave Jon to concentrate on the IANA transitions.

And help keep our publications out of the control of the USG.

[email-masked]
    Key fingerprint =  17 40 5E 67 15 6F 31 26  DD 0D B9 9B 6A 15 2C 32

---

From: "William Allen Simpson" <[email-masked]>
Date: Tue, 24 Feb 98 20:44:56 GMT

> From: [email-masked]
> The RFC Editor task will not be part of the "new IANA corporation", and
> will be a separate function to managed and funded by the
> IETF/IESG/IAB/ISOC.
>
Well, I am certainly glad to hear it.  And the ISoc and IAB et alia
established a fine group to organize the solution to the DNS TLDs, and
that has been a deterrent to USG interference, as we all have seen.

My recommendation stands.  For all the reasons given.

[email-masked]

---

From: "Simon Spero" <[email-masked]>
Date: Tue, 24 Feb 1998 22:16:59 -0500

-----Original Message-----
From: Theodore Y. Ts'o <[email-masked]>

>people, then perhaps we have some responsibility to assure that someone
>can't just ask random porn (protocol porn or sexual porn) to be

What about IPP? If that isn't plain-brown-wrapper protocol I don't know what
is. And why do I have a mental picture of MIB breaking in to ISI, kidnapping
Joyce, taking her to Area 51 and making her edit RFCs with a bunch of
two-headed interns.

---

From: Vernon Schryver <[email-masked]>
Date: Tue, 24 Feb 1998 20:51:00 -0700 (MST)

>    The RFC Editor task is primarily a Publication
>    Service. The IETF/IESG/IAB is JUST one of the
>    users/customers of the the RFC Publication Service.
>    There is an obvious inherent problem with allowing a
>    common Publication Service be managed and funded by
>    one of its users. The problem is that IETF/IESG/IAB is
>    likely to claim control over the entire RFC
>    Publication Service and delay the publication or
>    exclusion of protocols coming from outside of it.
>
> It's already the case that the RFC editor task has a dotted-line
> relationship to the IAB, and you can't just squirt out a random RFC
> without some consultation between the RFC editor and the IESG.
> ...

The first paragraph is dangerously wrong on several counts, and the second
paragraph understates the situation.

The only reason people want to publish their documents as RFC's is to
share in the prestige of the old RFC's.  The only reason the RFC's have
any prestige is that they document the protocols that are now commonly
said to be the property of the IETF.  The prestige of the label is due
entirely to the fact that what is now the "IETF/IESG/IAB" has in fact
"[controlled] the entire RFC Publication Service."

The first paragraph demands that the RFC Editor become a general technical
publisher, and evidently without even the filtering by the editors and
reviewers that commercial publishers employee to maintain their minimal,
often rather low standards of accuracy and relevance.  It is basically a
demand to receive from the RFC Editor that which is not the property of
the RFC Editor to give, the prestige of the authors of the RFCs (except,
of course, to the significant extent that the Editor is also a major RFC
author who did a lot to create that prestige).  Letting the RFC Editor
publish everything that comes along would kill the golden goose, the
prestige of the appellation.

The office of the RFC Editor must remain the captive of the IETF.  It
exists only to publish the protocols of the IETF.  Should it ever become
a general publisher, it should be disbanded as an office and "out-sourced"
to one of the many commercial technical publishers.

People tell me I see parallels where there are none...still, I see
similarities between this demand that the RFC Editor annoint the work of
any random author or company that asks and the demand that DNS name space,
the protocol number space, and the IP address spaces be handed over to
people whose only apparent qualification or recommendation is their burning
ambition to Participate.

Vernon Schryver    [email-masked]

---

From: Jim Fleming <[email-masked]>
Date: Wed, 25 Feb 1998 01:51:38 -0600

On Tuesday, February 24, 1998 9:16 PM, Simon Spero[SMTP:[email-masked]] wrote:
@
@-----Original Message-----
@From: Theodore Y. Ts'o <[email-masked]>
@
@>people, then perhaps we have some responsibility to assure that someone
@>can't just ask random porn (protocol porn or sexual porn) to be
@
@
@What about IPP? If that isn't plain-brown-wrapper protocol I don't know what
@is. And why do I have a mental picture of MIB breaking in to ISI, kidnapping
@Joyce, taking her to Area 51 and making her edit RFCs with a bunch of
@two-headed interns.
@
@

You might want to review some of the history of NSI...

@@@@ http://rs.internic.net/nsf/nis/proposal-toc.html

Section M: Personnel Qualifications

@@@@ http://rs.internic.net/nsf/nis/sectionM.html

...
M.3 IANA Manager and Advisory Panel Chairman

Network Solutions proposes Mr. Jon Postel as the IANA Manager and
Chairman of the Advisory Panel for the NREN NIS Manager project. He
will provide services as an employee of USC's Information Sciences Institute (ISI),
subcontractor to Network Solutions.

...
M.4 Coordination Services Manager

Network Solutions proposes Ms. Joyce Reynolds as manager of coordination
services for the NREN NIS Manager project. She will continue the activity
ISI has established in the leadership of the User Services Area Council (USAC)
and participate in meetings of groups such as RARE and RIPE to promote
international coordination and cooperation. She will provide services as an
employee of USC's Information Sciences Institute (ISI), subcontractor to
Network Solutions. 

@@@@@@@@@@@@@@@@@@@@@

Jim Fleming
Unir Corporation
IBC, Tortola, BVI

---

From: "William Allen Simpson" <[email-masked]>
Date: Sat, 28 Feb 98 14:09:45 GMT

> From: "Michael A Quinlan" <[email-masked]>
> From: [email-masked] <[email-masked]>
> How is the IETF/IESG/IAB/ISOC funded now? I know the ISOC gets corporate and
> individual membership fees, but that doesn't seem like very much.
>
The answer should probably be on the IETF and ISoc web pages.

The IETF/IESG is self-funding, through its meeting attendance fees.

The IAB/ISoc (and presumably RFC Editor) are funded by the ISoc
membership fees and grants.

I think the Secretariat is funded by IETF, but maybe ISoc helps there,
too.

[email-masked]

---

From: Jim Fleming <[email-masked]>
Date: Sat, 28 Feb 1998 08:42:56 -0600

On Saturday, February 28, 1998 8:09 AM, William Allen Simpson[SMTP:[email-masked]] wrote:
<snip>
@
@The IAB/ISoc (and presumably RFC Editor) are funded by the ISoc
@membership fees and grants.
@

Note..."RFC editing" below...

@@@@ http://rs.internic.net/nsf/nis/sectionH.html

"H.1 The NREN Internet Network Information Services Center Team"
 
"Our Team is composed of Network Solutions, the incumbent manager and operator
of the DISA NIC, and ISI, a leading computer science research organization, which
has provided the IANA, RFC editing, .us Domain structuring and registration, Monthly
Report coordination, editing, and production, and similar services to the Internet for
many years. Network Solutions has teamed with ISI to take advantage of their many
years of experience with providing services to the Internet and to provide the additional
knowledge and skills needed for this solicitation. The relationship between Network
Solutions and ISI is a solid one, based on mutual respect for the complementary skills
and knowledge each brings to network services. We are already accustomed to operating
as an integrated team, with ISI subcontracted to Network Solutions to provide assignment
of TCP service port numbers and other protocol parameters, and with ISI (as the IANA)
having delegated to the DISA NIC the registration of users for the Internet. The proposed
 organization of the Internet Network Information Services Center (INISC) is illustrated in
the figure below. The qualifications of the key personnel proposed are well known to users
of the Internet."

@@@@@@@@@@@@@@@@@
-
Jim Fleming
Unir Corporation
IBC, Tortola, BVI