Subject: New TLD BOF @ LA IETF '98

From: Bob Allisat <[email-masked]>
Date: Sun, 1 Feb 1998 00:36:58 -0500

Respectfully I will repeat my
 call for a BOF at the upcoming
 IETF Meeting in Los Angeles in
 March. Also with respect your
 collective dismissal of very
 real technical questions such
 as those adressed in my proposal
 will only lead to further errosion
 of the already shaken relevance
 of your otherwise rather cool
 state of mind.

 Furthermore I will moderate this
 BOF in co-operation with a panel
 representative of all views in this
 debate. We will strictly maintain
 discussions centering around
 TECHNICAL issues as detailed in
 the proposal which may be viewed
 at <http://www.fcn.net/bof.html>.

 This BOF will *not* be a discussion
 of policy. We must work within the
 technical limits of the medium being
 careful not to allow artificial or
 factually incorrect limitations to
 skew the free expression of extant
 Internet capabilities. We must
 collectively understand what these
 capabilities actually are in order
 to act appropriately.

 TeleVirtually Yours,

 Bob Allisat

 Director, World TeleVirtual Network             http://www.wtv.net
 PO Box 191 St E Toronto Canada M6H 4E2                 [email-masked]

---

From: John Curran <[email-masked]>
Date: Sun, 01 Feb 1998 02:14:31 -0500

At 12:36 AM 2/1/98 -0500, Bob Allisat wrote:
> March. 

Bob,
 
You're seeking a BOF for discussion of three basic issues:
 
    1.  Requirements for Root Name servers
    2.  Requirements for Domain Name Registries
    3.  Total TLD capacity of the DNS system

Given the existing workload on IETF participants, I'd
rather not see a BOF unless there's clearly technical
work that needs to be done and we have a good chance 
of successful output.  I can't speak for the other IESG
folks but it's probably safe to assume that we're all
operating under similar goals for IETF productivity.

Looking at your principal goals for the BOF, there 
doesn't seem to be any protocol or standards work 
that would result (or, at least, not obvious to me.)

With respect to #1 (Root Server Requirements), RFC2010 
seems relevant.  If you have suggestions for edits, I 
would send them to the authors or submit a draft with 
an alternative view. There's no need for a WG in either 
case and we're dealing with "Informational" RFC status.

With respect to #2 (Registry/Registrar Requirements), it 
appears that the most useful forum is now provided by the
recent Green Paper release.  Appendix 1 of that document
provides an interesting initial starting point, and there 
is an explicit request for feedback if you have strong 
views on this issue.
 
With respect to the final point (TLD capacity of the DNS),
I've enjoyed several months of discussion on this topic and
hence am somewhat skeptical that rough consensus is readily
achievable by convening a BOF.  Again, if you have a certain
viewpoint regarding the DNS system's total TLD capacity, you
can gain immediate visibility by submitting your analysis as 
an informational RFC.   No WG is necessary for this purpose.

When there is standards work to be done, we can launch WG's
fairly quickly (some folks believe we do it far too quickly 
at times :-)   In this case, there isn't any substance to 
warrant a working group and hence the lukewarm response to 
the offer.

/John

---

From: Einar Stefferud <[email-masked]>
Date: Sun, 01 Feb 1998 14:07:59 -0800

I concur with John Curran's assessment of the DNS situation.

I do not see any significant technical problems to be resolved, and
the IETF is not widely known for its usefulness in solving political
problems.  

What we need is an open political forum and the collective will to
cooperate there-in.  I recommend that it also have set rules for civil
discourse and monitors to guard against abuse of civility.

Civility has been one of the greatest lacks in the entire DNS
imbrogio.

I see no reason to wait until April to start;-)...\Cheers...\Stef

[No comments inerted below this line.]

>From John Curran's message Sun, 01 Feb 1998 02:14:31 -0500:
}
}At 12:36 AM 2/1/98 -0500, Bob Allisat wrote:
}>
}> Respectfully I will repeat my
}> call for a BOF at the upcoming
}> IETF Meeting in Los Angeles in
}> March. 
}
}Bob,
} 
}You're seeking a BOF for discussion of three basic issues:
} 
}    1.  Requirements for Root Name servers
}    2.  Requirements for Domain Name Registries
}    3.  Total TLD capacity of the DNS system
}
}Given the existing workload on IETF participants, I'd
}rather not see a BOF unless there's clearly technical
}work that needs to be done and we have a good chance 
}of successful output.  I can't speak for the other IESG
}folks but it's probably safe to assume that we're all
}operating under similar goals for IETF productivity.
}
}Looking at your principal goals for the BOF, there 
}doesn't seem to be any protocol or standards work 
}that would result (or, at least, not obvious to me.)
}
}With respect to #1 (Root Server Requirements), RFC2010 
}seems relevant.  If you have suggestions for edits, I 
}would send them to the authors or submit a draft with 
}an alternative view. There's no need for a WG in either 
}case and we're dealing with "Informational" RFC status.
}
}With respect to #2 (Registry/Registrar Requirements), it 
}appears that the most useful forum is now provided by the
}recent Green Paper release.  Appendix 1 of that document
}provides an interesting initial starting point, and there 
}is an explicit request for feedback if you have strong 
}views on this issue.
} 
}With respect to the final point (TLD capacity of the DNS),
}I've enjoyed several months of discussion on this topic and
}hence am somewhat skeptical that rough consensus is readily
}achievable by convening a BOF.  Again, if you have a certain
}viewpoint regarding the DNS system's total TLD capacity, you
}can gain immediate visibility by submitting your analysis as 
}an informational RFC.   No WG is necessary for this purpose.
}
}When there is standards work to be done, we can launch WG's
}fairly quickly (some folks believe we do it far too quickly 
}at times :-)   In this case, there isn't any substance to 
}warrant a working group and hence the lukewarm response to 
}the offer.
}
}/John
}

---

From: "NASA_man" <[email-masked]>
Date: Sun, 01 Feb 98 17:33:08 PST

TAKE ME OFF THIS FUCKING MAILING LIST!

----------

---

From: "NASA_man" <[email-masked]>
Date: Sun, 01 Feb 98 18:12:17 PST

IM GONNA EMAILBOMB THE SHIT OUTTA YALL UNLESS THE FUCKNUT WHO PUT ME ON THIS ANAL-RETENTIVE PENCILNECK LIST TAKES ME THE FUCK OFF NOW! COMPUTER ENGINEERS ARE A DISGRACE TO THE REST OF US.

----------

---

From: Tomas Fasth <[email-masked]>
Date: Mon, 02 Feb 1998 17:43:27 +0100

> the IETF is not widely known for its usefulness in solving political

Telling from postings in the past there still exist persons who continue
to assert that there really do exist significant technical problems in
this area besides the political ones.
And maybe it does, but not on the protocol level, is that correct?
As I can recall, substantial concern have been brought forward in the
past regarding legacy software involved in handling and replication of
DNS top level domain (TLD) information and such, of which IETF do not
have control or responsibility of.

Suppose we need a companion body to IETF, lets call it Internet
Infrastructure Task Force (IITF).
Is there such a creature, probably with a different name, already in
existence today?

And is there a consensus in IETF that the TLD problem area is not an
issue for protocol engineering?
I ask because I could easily imagine a need for a certain level of
interoperability similar to what is currently engineered in the
distributed directory service area, the Commom Index Protocol in
particular.

Isn't part of the TLD problem a question of how to distribute/delegate
top level domain registries without having a single top level authority?
If so, could this not imply a need for interoperability in the process
of joining disperate registries for unified global access?
And finally, if so, isn't this need best addressed by asking IETF to
define a protocol for interoperable exchange of TLD registry
information?

Just curious,
//Tomas

---

From: John Curran <[email-masked]>
Date: Mon, 02 Feb 1998 11:54:24 -0500

>top level domain registries without having a single top level authority?

The DNS system appears to have adaquate mechanisms for delegation
of TLDs (although there is debate regarding capacity), but these
mechanisms are dependent upon an authoritative configuration file
which must be maintained by some entity.   Are you suggesting that
we explore technical means (automated voting/consensus measuring) 
to eliminate the dependency on any "top-level" entity?   

/John

---

From: Tomas Fasth <[email-masked]>
Date: Mon, 02 Feb 1998 20:52:12 +0100

> to eliminate the dependency on any "top-level" entity?

IMHO, I'm not really in a position to make suggestions in this area. I
know far too little about the core mechanisms of current TLD information
deployment.
But there might be some aspects of the TLD problem domain that actually
are possible subjects for IETF work. I can't really tell, due to my
personal lack of competence in this specific area.
It's just that I get a feeling of dejavue when I read about legacy
software (is it really legacy?) relying on single file transfers to
propagate TLD data among the root servers. This sounds not have been
engineered having in mind the scaling requirements imposed when the
number of registries grows over time.
In that regard a technical exploration might not hurt.
Note that I agree completely with your basic standpoint (and IETF's as
well through rough consensus) that if actual work are going to be done
within IETF in this area it has to concern interoperability on a
protocol level, nothing else.

Humble thoughts,

  Tomas

---

From: "Donald E. Eastlake 3rd" <[email-masked]>
Date: Thu, 12 Feb 1998 10:22:19 -0500 (EST)

On Mon, 2 Feb 1998, Tomas Fasth wrote:

> Date: Mon, 02 Feb 1998 20:52:12 +0100
> From: Tomas Fasth <[email-masked]>
> 
> ...

Incremental zone transfer and change notification facilities have been added
to the DNS so that full zone transfers need not always be done.  These
facilities are not yet widely deployed.  (See RFCs 1995 and 1996.)

> ...

Donald
=====================================================================
Donald E. Eastlake 3rd     +1 978-287-4877(tel)     [email-masked]
   318 Acton Street        +1 978-371-7148(fax)     [email-masked]
Carlisle, MA 01741 USA     +1 703-620-4200(main office, Reston, VA)
http://www.cybercash.com           http://www.privacy.org/ipc