Subject: Re: draft-ietf-nat-protocol-complications-02.txt

From: Masataka Ohta <[email-masked]>
Date: Mon, 1 May 2000 17:42:00 +0859 ()

Vint;

> that's right - they use iMODE on the DOCOMO mobiles. iMODE and
> WAP seem to have that in common: a non-IP radio link protocol
> and an application gateway. Of course, this limits the applications
> to those that can be "translated" in the gateway, while an end to
> end system (such as the Ricochet from Metricom) would allow 
> essentially any application on an Internet server to interact
> directly with the mobile device because the gateway would merely
> be an IP level device, possibly with NAT functionality.
> With a JAVA interpreter or other similar capability in the
> mobile, one could imagine considerable competition for development
> of new applications. As it stands, only the applications NTT
> chooses to implement in the translating gateway are accessible.

An interesting thing is that iMODE is so successful that DOCOMO
is suffering from the usual problems (lack of scalability and
robustness) caused by violating the end to end principle.

iMODE is now infamous for its frequent service interruption.

DOCOMO users are refunded for the interruption.

> Since HTTP is one of the "applications" served, there is still
> a lot of room for competition, I suppose.

To make the competition fair, the important questions are:

	Is it fair if providers using iMODE or WAP are advertised
	to be ISPs?

	Is it fair if providers using NAT are advertised to be ISPs?

My answer to both questions is

	No, while they may be Internet Service Access Providers and
	NAT users may be IP Service Providers, they don't provide
	Internet service and are no ISPs.

Any oppositions?

						Masataka Ohta

---

From: Jon Crowcroft <[email-masked]>
Date: Mon, 01 May 2000 11:55:50 +0100

In message <[email-masked]>, Masataka Ohta ty
 
 >>	Internet service and are no ISPs.

i agree:
in the UK, i would say that someone claiming internet access via WAP
would be in breach of the trades description act.

 >>Any oppositions?
 
not from here (for wap - i dont know enough about iMODE to comment)
 >>						Masataka Ohta

 cheers

   jon