Subject: RE: Addresses and ports and taxes -- oh my!

From: "Dawson, Peter D" <[email-masked]>
Date: Thu, 3 Aug 2000 15:59:04 -0000

v6 address space works out to about 1500 address 
per sq  mtr of the earth's surface...
NOW..how many house fit on 1 sqm ?

->-----Original Message-----
->From: Parkinson, Jonathan [mailto:[email-masked]]
->Sent: Thursday, August 03, 2000 10:23 AM
->To: 'Rakers, Jason'; 'Dennis Glatting'; [email-masked]
->Subject: RE: Addresses and ports and taxes -- oh my!
->
->
->Err I think that would take some thinking about ? How many 
->houses are there
->in the world!
->
->-----Original Message-----
->From: Rakers, Jason [mailto:[email-masked]]
->Sent: Thursday, August 03, 2000 2:41 PM
->To: 'Dennis Glatting'; [email-masked]
->Subject: RE: Addresses and ports and taxes -- oh my!
->
->
->When household appliances begin becoming IP addressable, I 
->think we will see
->a move towards assigning an Internet IP address per household 
->(much like
->today's street address).  The household will perform NAT for 
->all devices
->within (one street address can house many people, not just one).
->
->

---

From: Rick H Wesson <[email-masked]>
Date: Thu, 3 Aug 2000 11:49:49 -0700 (PDT)

peter,

who said all the addresses were going to be used only on earth?

-r

---

From: "Anthony Atkielski" <[email-masked]>
Date: Fri, 4 Aug 2000 08:49:19 +0200

> NOW..how many house fit on 1 sqm ?

Not relevant.  IPv6 will be exhausted by overly-generous allocation of
address space, just like IPv4.  I've already explained in the past why this
must be so.  In part, it comes from the subjective impression that any new
address space is "more than we'll ever need" and the tendency to
overallocate in consequence, until it's too late; this is probably the most
common engineering mistake in IT history.  Another reason why IPv6 is not
nearly as large as it appears to be is that IP addresses are closely linked
to routing, instead of being randomly assigned; and this routing imposes
severe restrictions on how the address space can be used.  Both issues are
routinely and completely overlooked, even though they are responsible for
the pending exhaustion of IPv4 today, even though we don't have four billion
computers on the Internet yet.

In the past, I've suggested open-ended IP addressing to permanently solve
this (similar to the way telephone numbers are assigned today), but there
wasn't much interest.  Perhaps a few years from now, when it becomes
necessary to go to IPv12, which will have "more space than we'll ever need,"
I'll try again.

---

From: Steve Deering <[email-masked]>
Date: Fri, 4 Aug 2000 10:02:58 -0700

At 8:49 AM +0200 8/4/00, Anthony Atkielski wrote:
>routinely and completely overlooked,...

They have not been overlooked by those who have been working on IPv6
address allocation policy.

Steve

---

From: "Anthony Atkielski" <[email-masked]>
Date: Sat, 5 Aug 2000 01:47:39 +0200

> They have not been overlooked by those who have been
> working on IPv6 address allocation policy.

What's the solution?  Hint:  No policy of advance address allocation will
help, and neither will any form of address-based routing, no matter how
clever.