Subject: RE: Addresses and ports and taxes -- oh my!

From: "Evstiounin, Mikhail" <[email-masked]>
Date: Thu, 3 Aug 2000 10:12:54 -0400

Wasn't avoiding NAT one of the goal of IPv6? I recall a pretty big
discussion here some time ago about NAT and IPv6. 

> -----Original Message-----
> From:	Rakers, Jason [SMTP:[email-masked]]
> Sent:	Thursday, August 03, 2000 9:41 AM
> To:	'Dennis Glatting'; [email-masked]
> Subject:	RE: Addresses and ports and taxes -- oh my!
> 
> When household appliances begin becoming IP addressable, I think we will
> see
> a move towards assigning an Internet IP address per household (much like
> today's street address).  The household will perform NAT for all devices
> within (one street address can house many people, not just one).
> 
> > -----Original Message-----
> > From:	Dennis Glatting
> [SMTP:[email-masked]]
> > Sent:	Thursday, August 03, 2000 8:32 AM
> > To:	[email-masked]
> > Subject:	Addresses and ports and taxes -- oh my!
> > 
> > 
> > I've been thinking about the issue of ARIN fees from last night's
> plenary
> > and arrived at two philosophical questions.
> > 
> > I run my business out of my home and my DSL link is an important part of
> > my business. About six months ago my ISP started charging me a $20/mo.
> fee
> > for my /27 because "ARIN is now charging us." I am unhappy about this
> fee
> > but I understand its motivation -- conversation of IP space, though I
> > believe fees do not really effect the true wasters of this space and the
> > fee, or as it is called in some circles, a tax, is probably misguided.
> > Nonetheless, with IPv6, I naively hoped, until last night, the
> > conservation of space issues would go away, and thus the fees. Big duh!
> > 
> > If we look at today's marketing hype and think forward a bit there is a
> > thrust to "Internet enable" appliances, such as dryers, ovens, and
> > stereos. Assuming ARIN fees persist, my first philosophical question is
> > whether any consumer of these appliances MUST periodically (e.g.,
> monthly)
> > drop coins in the ARIN fountain?
> > 
> > Thinking laterally, the reserved port space (<1024) is tight. Using the
> > same IP space conversation logic, should fees be charged to conserve
> port
> > space? If so, my second philosophiocal question is what is our role, as
> > protocol designers and IETF volunteers, in creating, what is slowly
> > becoming, an Internet consumption taxation model?
> > 
> > Imagine for a moment the effect of a fee against the allocation or use
> of
> > port 80 or 443, maybe even port 25 or 53.
> > 
> > 
> > 
> > 
> >

---

From: "Parkinson, Jonathan" <[email-masked]>
Date: Thu, 3 Aug 2000 15:23:21 +0100

Err I think that would take some thinking about ? How many houses are there
in the world!

-----Original Message-----
From: Rakers, Jason [mailto:[email-masked]]
Sent: Thursday, August 03, 2000 2:41 PM
To: 'Dennis Glatting'; [email-masked]
Subject: RE: Addresses and ports and taxes -- oh my!

When household appliances begin becoming IP addressable, I think we will see
a move towards assigning an Internet IP address per household (much like
today's street address).  The household will perform NAT for all devices
within (one street address can house many people, not just one).

> From:	Dennis Glatting [SMTP:[email-masked]]
> I've been thinking about the issue of ARIN fees from last night's plenary
> my business. About six months ago my ISP started charging me a $20/mo. fee
> for my /27 because "ARIN is now charging us." I am unhappy about this fee
> whether any consumer of these appliances MUST periodically (e.g., monthly)
> same IP space conversation logic, should fees be charged to conserve port
> Imagine for a moment the effect of a fee against the allocation or use of

---

From: "Kay, Rodney" <[email-masked]>
Date: Thu, 3 Aug 2000 13:27:09 -0500

Why would internet-enable appliances necessarily have to incur a charge?
Although internet-enabled, they could also be defined as 10. address within
your LAN (a.k.a. home).  They would be visible to the outside only through
your personal server - for which you are already paying a charge.  Whatever
security you ran on your PC would protect you from someone, say, turning
your heat up to around 90 degrees F while you were gone on vacation.

Regards,

Rodney H. Kay
Department of Veterans Affairs
Puget Sound Health Care System
Systems Manager
Seattle, Washington

-----Original Message-----
From: vinton g. cerf [mailto:[email-masked]]
Sent: Thursday, August 03, 2000 7:51 AM
To: Dennis Glatting; [email-masked]
Subject: Re: Addresses and ports and taxes -- oh my!

Dennis

thanks for drawing attention to this question. One of the reasons
for fees, of course, is that the Address Registries also have responsibility
to support ICANN so they have some new costs in addition to their operating
costs (or if you like, their operating costs include support for ICANN).

It is a very good question whether one's internet-enabled household
appliances
will induce a monthly charges - do you suppose there would be a way to have
a
one-time charge to "pay" for some number of such addresses - perhaps built
into
the cost of the appliance (and paid by the manufacturer who "burns" an
address
into the device - at least the low order 64 bits or something to make it
end-to-end unique)? 

Please don't flame me for thinking out loud - Dennis' point is a good one
and
we ought to discuss - perhaps in a smaller group than the whole of ietf
announce
list!

Vint Cerf

>port 80 or 443, maybe even port 25 or 53.

=================================================================
I moved to a new MCI WorldCom facility on Nov 11, 1999

MCI WorldCom
22001 Loudoun County Parkway
Building F2, Room 4115, ATTN: Vint Cerf
Ashburn, VA 20147
Telephone (703) 886-1690
FAX (703) 886-0047

"INTERNET IS FOR EVERYONE!" 
INET 2001: Internet Global Summit 
5-8 June 2001 
Sweden International Fairs 
Stockholm, Sweden 
http://www.isoc.org/inet2001

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 03 Aug 2000 14:16:38 -0400

At 05:32 03/08/2000 -0700, Dennis Glatting wrote:
>for my /27 because "ARIN is now charging us."

if the USD 2500/year fee Scott mentioned in the plenary is even 
approximately right, your ISP is recovering its ARIN costs from a base of 
around 10 customers.

Small ISP.

                    Harald

--
Harald Tveit Alvestrand, [email-masked]
+47 41 44 29 94
Personal email: [email-masked]

---

From: "Evstiounin, Mikhail" <[email-masked]>
Date: Thu, 3 Aug 2000 14:33:50 -0400

Well, there are 8 computers in my house, and I don't count future IP enabled
appliances. At my work place (building take probably about 0.7 hectares or
less and this only one site) more than 700 computers:-). In any case, my
point is that we should consider 3rd dimension also:-)

> From:	Dawson, Peter D [SMTP:[email-masked]]
> Sent:	Thursday, August 03, 2000 11:59 AM
> To:	[email-masked]
> v6 address space works out to about 1500 address 
> per sq  mtr of the earth's surface...
> NOW..how many house fit on 1 sqm ?
> 
> ->-----Original Message-----
> ->From: Parkinson, Jonathan [mailto:[email-masked]]
> ->Sent: Thursday, August 03, 2000 10:23 AM
> ->To: 'Rakers, Jason'; 'Dennis Glatting'; [email-masked]
> ->Subject: RE: Addresses and ports and taxes -- oh my!
> ->
> ->
> ->Err I think that would take some thinking about ? How many 
> ->houses are there
> ->in the world!
> ->
> ->-----Original Message-----
> ->From: Rakers, Jason [mailto:[email-masked]]
> ->Sent: Thursday, August 03, 2000 2:41 PM
> ->To: 'Dennis Glatting'; [email-masked]
> ->Subject: RE: Addresses and ports and taxes -- oh my!
> ->
> ->
> ->When household appliances begin becoming IP addressable, I 
> ->think we will see
> ->a move towards assigning an Internet IP address per household 
> ->(much like
> ->today's street address).  The household will perform NAT for 
> ->all devices
> ->within (one street address can house many people, not just one).
> ->
> ->

---

From: "David A. Higginbotham" <[email-masked]>
Date: Thu, 3 Aug 2000 14:43:08 -0400

hmm... in Manahattan that may be more than one, in Silk Hope, North Carolina
it is less than one

---

From: "Evstiounin, Mikhail" <[email-masked]>
Date: Thu, 3 Aug 2000 15:53:01 -0400

I would say 12G * 4 ( at least ), but still OK. Reasoning behind this is
that
I'd like to have real IP for each computer in the house, plus mobile IPs 
for everybody, plus appliances, plus hotels, planes, cars, trains, etc

> From:	Brian E Carpenter [SMTP:[email-masked]]
> Sent:	Thursday, August 03, 2000 1:22 PM
> To:	[email-masked]
> "Rakers, Jason" wrote:
> > Better question:  How many households are there in the world on the
> > Internet?
> 
> Wrong question. The correct question is how many should we plan for.
> Right now 12 billion people seems to be a reasoanble estimate -
> unthinkable for IPv4, but easily covered by IPv6.
> 
>    Brian

---

From: Scott Bradner <[email-masked]>
Date: Thu, 3 Aug 2000 16:02:54 -0400 (EDT)

as long as we do not care about fragmentation of the routing space this
idea is neat

Scott

---
Vinton's idea has much merit. A scheme to allocate blocks of addresses to
manufacturers would be much easier to support than an organization
attempting to process individual email requests, or CGI scripted forms from
a webpage, or a world-wide DHCP server for Amana ( and one for Maytag, etc.)
to register a refrigerator. And easier administration should translate into
lower cost...... :-) My apologies in advance for polluting the IETF announce
list. Btw, did we ever find out how many people were on that elevator? :-)

-----Original Message-----
From: vinton g. cerf [mailto:[email-masked]]
Sent: Thursday, August 03, 2000 10:51 AM
To: Dennis Glatting; [email-masked]
Subject: Re: Addresses and ports and taxes -- oh my!

Dennis

Vint Cerf

MCI WorldCom

---

From: Alan Simpkins <[email-masked]>
Date: Thu, 3 Aug 2000 16:49:11 -0700 (PDT)

NAT would definitely serve a purpose for those wishing to not pay a fee for Intert addresseable address space. It would seem though that if one pays for Internet access this should in fact be included in the price.

  "Evstiounin, Mikhail" <[email-masked]> wrote: 
Wasn't avoiding NAT one of the goal of IPv6? I recall a pretty big
discussion here some time ago about NAT and IPv6. 

> > port 80 or 443, maybe even port 25 or 53.
AT would d3efinet

---------------------------------
Do You Yahoo!?
Kick off your party with Yahoo! Invites.

---

From: "Evstiounin, Mikhail" <[email-masked]>
Date: Fri, 4 Aug 2000 11:08:17 -0400

Toaster is much more quite, even it takes more time. And all your mail will
have brown-gold colour, while in blender you get everything mixed up:-)

> From:	Steven Cotton [SMTP:[email-masked]]
> Sent:	Friday, August 04, 2000 5:05 AM
> To:	[email-masked]
> On Fri, 4 Aug 2000, Anthony Atkielski wrote:
> 
> > The mere fact that something is technically possible doesn't mean that
> it
> > should be done.
> 
> Definitely - what benefit can I get from my toaster having Internet
> conectivity when I will be able to use my blender to read mail?
> 
> -- 
> steven
>

---

From: Vernon Schryver <[email-masked]>
Date: Fri, 4 Aug 2000 09:46:11 -0600 (MDT)

> From: =?iso-8859-1?Q?M=E5ns?= Nilsson <[email-masked]>

> > good point... but I do wonder how the border edge
> > router will handle a datagram with
> > TTL approx > 240 sec's
> > ( i.e min time required for msg to pass between earth <=> mars) ?
> > what about jitters, latency ,dropped packets, icmpv6 err msg.... well
> > whatever....
>
> Well, back to UUCP, then :-) *nearly just kidding*

Which of the UUCP protocols would tolerate such RTT's?
Don't you remember why Telebit had to add "UUCP spoofing"?
The g protocol had a pretty small maximum sized window.
of course e and t don't count since they assume a loss-free wire.

TCP with large windows already works where UUCP never did.

That's not to disagree with the notion the UUCP has a lot to recommend
itself even today, or that you couldn't make a new and different UUCP
protocol that would tolerate the RTT to Pluto.

Vernon Schryver    [email-masked]

---

From: "Parkinson, Jonathan" <[email-masked]>
Date: Fri, 4 Aug 2000 17:01:09 +0100

The world connected
Hmm Now I'm thinking Virus's

/Jon/div

---

From: "Parkinson, Jonathan" <[email-masked]>
Date: Fri, 4 Aug 2000 18:06:20 +0100

>all we need is programmers that remember to actually CHECK that string
>lengths are in bounds.

Lets hope they are X-Microsoft programmers, That should keep all us support
staff busy and in secure jobs ;-)

I know, Its Friday !

Jon

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, August 04, 2000 5:35 PM
To: Mahadevan Iyer
Cc: [email-masked]
Subject: Re: Addresses and ports and taxes -- oh my! 

On Fri, 04 Aug 2000 01:26:55 PDT, Mahadevan Iyer said:
> At first glance, it seems sheer idiocy to use an open network like the
> Internet to control critical matter-of-life-and-death public
> infrastructure like power systems. What do you think?

At first glance, it seems sheer idiocy to use something like a telco switch
to control critical matter-of-life-and-death public infrastructure like the
US 911 system.

Telco switches are hackable.  And I submit to you that the 911 system is
as life-and-death critical as it gets.  Hasn't seemed to have been a
problem so far, even though 911 systems *have* been hacked, subjected
to denial of service attacks, and all the other problems they are subject
to.

> Or do you think, it is possible to build ultra-reliable secure real-time
> communication channels in the Internet? Maybe..

It may be impossible to build ultra-reliable secure systems.  On the other
hand, remember that it's about *risk management*.  Nuclear launch codes
are one of the *very* few "zero failures acceptable" things we have.

We accept that on the order of 1 out of every million airplane takeoffs
ends badly.  We accept that the power grid fails in scattered areas
during the summer.  We accept that doctors, drug interactions,  and
hospitals accidentally kill a number of patients every year.  I don't
see the whole class of Aleve/Naprosyn painkillers being pulled off the
market, even though an amazing number of people die every year from
gastric bleeding.

We actually know almost all of what we need to build such systems. Now
all we need is programmers that remember to actually CHECK that string
lengths are in bounds. ;)

				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: [email-masked]
Date: Fri, 4 Aug 2000 10:54:51 -0700

I believe that we are looking at a wireless solution here, and the justification
for building alternate dimension networks could be difficult to justify unless
we have an overcrowding problem on earth. That in turn would open up all sorts
of other possibilities. You can see the advertisements now :

"Moving into a different reality, don't end up in the Dungeon Dimensions, Talk
to John Doe, you friendly neighbourhood inter-dimentional Realtor"

However the Network Engineers that implemented it, would make a killing, They
would be on the clock in several dimensions simultaneously, especially if you
think that you can have different dimensions occupying the same physical space.
this scenario presents interesting opportunities :

1. you could carry out a full days work by doing 1 hour in each of 8 realities,
OR

really bust the budget and

2. by working 8 hours in 8 different realities simultaneously, therefore
achieving 64 hours work in one work day (8 hours)
(1/3 of the time it takes for an orbital rotation of earth, assuming 24 hours is
the time it takes,( I believe the completely accurate time is 23h 56m to one
rotation))
and lets be honest here, how many Engineers do you know that work 8 hour days ?

3. based on the standard working model, in the course of one "normal" working
day (8 hours), you could do your standard 40 hour week plus 24 hours overtime
and take the rest of the week off to go hiking in the mountains.

The added double whammy is that in the state of California, anything over 40
hours is time and a half, so the bank balance looks healthy too. The only
possible problem is whether you can be considered to be in California and
simultaneously in 7 other dimensions and still charge time and a half.

The lawyers and politicians are going to have fun making a law for this work
ethic.

ah... Mr. President, welcome to quantum physics 101 ;->

Jim

*******************************************************************************************************
My opinions are my own and do not represent the technical direction of 3Com or
any of it's subsidiaries

*******************************************************************************************************

[email-masked] on 04/08/2000 05:58:52

Sent by:  [email-masked]

To:   Jim Stephenson-Dunn/C/HQ/3Com
cc:   [email-masked]
Subject:  Re: Addresses and ports and taxes -- oh my!

On Thu, 03 Aug 2000 16:52:25 PDT, [email-masked] said:
> why not consider all the dimentions, ever heard of polyfractal space ?

Fabricating the router connections would be interesting....  WHat sort of
crimping tool would it take to make a 2.75D connector stay on the cable? ;)