Subject: Re: more on IPv6 address space exhaustion

From: [email-masked] (Sean Doran)
Date: Mon, 14 Aug 2000 22:25:04 +0200 (CEST)

Mike Trutkowski writes:

| Maybe I read this wrong... but it sounds like you are 
| tieing a domain name to domain content?  Is this true?

No, I am tying a domain's acceptable use policy to the
registered owner of the domain.   One possible AUP requires
that any data associated with any of its subdomains is compliant
with some criterion or other.

For example, data associated with "cisco.com" is supposed to
advance the interests of the investors in Cisco Systems Inc.,
and I'd guess there are rules about what clearly does not do so,
and trangressors are separated from the domain in one way or another.

Extending this to (as a hypothetical example) "guaranteedsafe4kids.com"
does not seem to be that much of a stretch -- if you violate the rules
of the use of the domain, you are separated from it in one way or another.

What a committee with the fellow behind PSI (an ISP, no less!) on it
is proposing is clever: use the same general principle with a range
of IPv6 addresses.  If you violate the rules, you are separated
from the prefix.   In combination ".kids" or the like, and a particular
well-known IPv6 prefix, seems like a superior form of partitioning
bad people away from the "Kid-Safe Internet" than merely using the DNS.
Moreover, by managing its address space, an entity like "disney.com"
would not also have to manage "disney.guaranteedsafe4kids.com".  They
just simply add yet another IPv6 address to the interfaces of their
various machines, which is how IPv6 multihoming works, and PRESTO!, they
are in the kid-safe address space, assuming they have logical connectivity
to the rest of the kid-safe address space, or announce a subnet of it
to the world at large.   A DNS AAAA lookup then returns perhaps
several addresses, one of which will be in the kid-safe TLA.

Consider the IPv6 [SELECT] draft -- if you have an algorithm in 
your host which allows only "kid-safe" connections (e.g., if you get
back several AAAA RRs, discard any that are not "kid-safe") -- then
you can connect to the "www.disney.com" servers (and they to you),
but not to the "www.veryhotsexnow.com" ones, since either they
would not have AAAA RRs in the first place, or those addresses
would not be reachable on the Internet.

I can imagine a range of "ratings" being handled in this way.
Therefore, IPv6 is wonderful because it allows for a full-fledged
V-Chip Connectivity Policy, thanks to the difference between
the way it handles multihoming from classical IPv4.

	Sean.

---

From: "Anthony Atkielski" <[email-masked]>
Date: Tue, 15 Aug 2000 11:24:37 +0200

> What a committee with the fellow behind PSI (an
> ISP, no less!) on it is proposing is clever: use
> the same general principle with a range
> of IPv6 addresses.

It isn't really that clever.  For one thing, the standards for any given
category of addresses will vary from one community to another, and so it
will be impossible to reach a consensus on which entities should be included
in or excluded from that category.  Another problem is that the very
categories themselves will vary from one community to another.  Smallville
USA might well endorse a "kids-only" address space, but what about an Arab
country that wants a "Jew-free" address space, or another country that wants
a "men-only" address space?  The number of required addresses spaces might
be infinite, and there would be no universal consensus on the vast majority
of them.

---

From: Thomas Narten <[email-masked]>
Date: Tue, 15 Aug 2000 10:48:39 -0400

> the way it handles multihoming from classical IPv4.

Sigh. There once again appears to be a major misrepresentation about
what is *required* by IPv6 versus what is *one* of *multiple* possible
approaches to a particular issue.  So, once again, it appears
necessary to point out that approaches that work fine in IPv4 work
just as well in IPv6. But IPv6 also enables new approaches as well,
some of which are not really practical in IPv4.

Thomas

---

From: Sean Doran <[email-masked]>
Date: 15 Aug 2000 18:39:58 +0200

"Anthony Atkielski" <[email-masked]> writes:

> It isn't really that clever.  For one thing, the
> standards for any given category of addresses will vary
> from one community to another,

Ah, no - the clever thing is partitioning the address
space at all.  Whether or not this particular partition is
clever is something I do not address -- it is merely possible.

Moreover, it is possible with a trade-off in the Internet
between transport cost and efficiency versus extra
globally-visible routing information.   There are some
added costs on the host side, but surely the folks behind
draft-ietf-ipngwg-default-addr-select-01.txt need to work
that out for the general case of multihoming anyway.

> [many different partitions]
> The number of required addresses spaces might be
> infinite, and there would be no universal consensus on
> the vast majority of them.

The IPv6 address space is pretty vast, or so we keep being told.

This surely should be considered a huge victory for
IPv6... We were forced to abandon the original structure
of (classful) IPv4 because of address space constraints,
and have been under pressure not to revise the current
CIDR structure, because of space-conservation policies.

Now with a much larger address space, and the allowance
for support for multiple per-interface addresses in hosts
and routers, we can explore totally different structures,
such as partitioning on boundaries other than "large
site", "medium site", "small site", and the CIDR
refinements thereto (/32-sized-site, /31-sized-site, etc.).

        Sean.