Subject: Bit pattern Matching

From: "Ashish Sood" <[email-masked]>
Date: Tue, 1 Aug 2000 16:57:43 +0530

Hi all
Can anyone suggest me an efficient technique of bit pattern matching in a
stream of bits.
Thanks
Ashish

---

From: John Day <[email-masked]>
Date: Tue, 1 Aug 2000 08:55:03 -0400

At 4:57 PM +0530 8/1/00, Ashish Sood wrote:
>Hi all
>
>Can anyone suggest me an efficient technique of bit pattern matching 
>in a stream of bits.

Have checked Ullman's book on Algorithms?

---

From: [email-masked]
Date: Tue, 01 Aug 2000 10:26:30 -0400

> Can anyone suggest me an efficient technique of bit pattern matching in a

The first question is, of course, whether you are trying to match a known
fixed bit pattern, or a variable one.

The second one is, of course, whether a hardware solution is usable, or if
it has to be in software.

The third one is, of course, the average speed of the bits - solutions that
are very efficient at (for instance) DS1 speeds may not scale to an OC12,
and the OC12 solution may be too costly for slow speeds.
-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech