Subject: RE: Addresses and ports and taxes -- oh my!

From: "Rakers, Jason" <[email-masked]>
Date: Thu, 3 Aug 2000 10:30:48 -0400

Better question:  How many households are there in the world on the
Internet?

> -----Original Message-----
> From:	Parkinson, Jonathan [SMTP:[email-masked]]
> Sent:	Thursday, August 03, 2000 10:23 AM
> To:	'Rakers, Jason'; 'Dennis Glatting'; [email-masked]
> Subject:	RE: Addresses and ports and taxes -- oh my!
> 
> Err I think that would take some thinking about ? How many houses are
> there
> in the world!
> 
> -----Original Message-----
> From: Rakers, Jason [mailto:[email-masked]]
> Sent: Thursday, August 03, 2000 2:41 PM
> To: 'Dennis Glatting'; [email-masked]
> Subject: RE: Addresses and ports and taxes -- oh my!
> 
> 
> When household appliances begin becoming IP addressable, I think we will
> see
> a move towards assigning an Internet IP address per household (much like
> today's street address).  The household will perform NAT for all devices
> within (one street address can house many people, not just one).
> 
> > -----Original Message-----
> > From:	Dennis Glatting
> [SMTP:[email-masked]]
> > Sent:	Thursday, August 03, 2000 8:32 AM
> > To:	[email-masked]
> > Subject:	Addresses and ports and taxes -- oh my!
> > 
> > 
> > I've been thinking about the issue of ARIN fees from last night's
> plenary
> > and arrived at two philosophical questions.
> > 
> > I run my business out of my home and my DSL link is an important part of
> > my business. About six months ago my ISP started charging me a $20/mo.
> fee
> > for my /27 because "ARIN is now charging us." I am unhappy about this
> fee
> > but I understand its motivation -- conversation of IP space, though I
> > believe fees do not really effect the true wasters of this space and the
> > fee, or as it is called in some circles, a tax, is probably misguided.
> > Nonetheless, with IPv6, I naively hoped, until last night, the
> > conservation of space issues would go away, and thus the fees. Big duh!
> > 
> > If we look at today's marketing hype and think forward a bit there is a
> > thrust to "Internet enable" appliances, such as dryers, ovens, and
> > stereos. Assuming ARIN fees persist, my first philosophical question is
> > whether any consumer of these appliances MUST periodically (e.g.,
> monthly)
> > drop coins in the ARIN fountain?
> > 
> > Thinking laterally, the reserved port space (<1024) is tight. Using the
> > same IP space conversation logic, should fees be charged to conserve
> port
> > space? If so, my second philosophiocal question is what is our role, as
> > protocol designers and IETF volunteers, in creating, what is slowly
> > becoming, an Internet consumption taxation model?
> > 
> > Imagine for a moment the effect of a fee against the allocation or use
> of
> > port 80 or 443, maybe even port 25 or 53.
> > 
> > 
> > 
> > 
> >

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 03 Aug 2000 12:21:46 -0500

> Better question:  How many households are there in the world on the

Wrong question. The correct question is how many should we plan for.
Right now 12 billion people seems to be a reasoanble estimate -
unthinkable for IPv4, but easily covered by IPv6.

   Brian

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 03 Aug 2000 18:41:29 +0100

in an ideal world, this would be worked out thru a non linear dynamic
pricing model  the same way the airlines do differentiated seat
pricing .... 

we haev ipv4 and ipv6 addresses; they have different cost recovery
models and different utility functions and different marketing dweebs
selling the,em, and different incentiveve requirements...

so by then, the price would be very very low as the cost of dealing
with the possible future admin of assigning more addresses will be
vanishingly small....

In message <[email-masked]>, "Rakers, Jason" t

 >>> > port 80 or 443, maybe even port 25 or 53.

 cheers

   jon

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 3 Aug 2000 22:06:13 +0100 (BST)

> pricing model  the same way the airlines do differentiated seat

in an ideal world, airlines don't _have_ differentiated seat pricing.

> with the possible future admin of assigning more addresses will be

...which is where any analogy with DNS registration pricing and
administration would presumably break down.

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: [email-masked]
Date: Fri, 04 Aug 2000 00:00:57 -0400

> in an ideal world, airlines don't _have_ differentiated seat pricing.

Of course, in reality, they split them into coach and tolerable. ;)
-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech