Subject: RE: Sequentially assigned IP addresses--why not?

From: "Rakers, Jason" <[email-masked]>
Date: Fri, 11 Aug 2000 07:51:56 -0400

This is some sort of urban legend. If a routeable prefix was given
to
	every human, using a predicted world population of 11 billion, we
would
	consume about 0.004% of the total IPv6 address space.

....that's what they said about never needing more than 640kb of memory in a
computer......
we'll never need more than that!

Jason

> -----Original Message-----
> From:	Brian E Carpenter [SMTP:[email-masked]]
> Sent:	Thursday, August 10, 2000 4:31 PM
> To:	Corzine, Gordie
> Cc:	[email-masked]'
> Subject:	Re: Sequentially assigned IP addresses--why not?
> 
> "Corzine, Gordie" wrote:
> > 
> > Seriously,
> > 
> > As was pointed out recently, IPV6 will croak much sooner than it needs
> to
> > for the simple reason that we structure routing intelligence into the
> > address assignment.
> 
> This is some sort of urban legend. If a routeable prefix was given to
> every human, using a predicted world population of 11 billion, we would
> consume about 0.004% of the total IPv6 address space.
> 
> (The actual calculation is 11*10^9/2^48 since there are 48
> bits in an IPv6 routing prefix. Or
> 11,000,000,000 / 281,474,976,710,656 = 0.000039 )
> 
> - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
> Brian E Carpenter 
> Program Director, Internet Standards & Technology, IBM 
> On assignment for IBM at http://www.iCAIR.org 
> Board Chairman, Internet Society http://www.isoc.org
> Non-IBM email: [email-masked]

---

From: Steven Cotton <[email-masked]>
Date: Fri, 11 Aug 2000 14:30:05 +0200 (CEST)

On Fri, 11 Aug 2000, Rakers, Jason wrote:

> 	This is some sort of urban legend. If a routeable prefix was
> given to every human, using a predicted world population of 11
> billion, we would consume about 0.004% of the total IPv6 address
> space.
> 

As soon as some resource becomes available, something is developed that
uses as much of that resource as possible - this is a fact of life and is
natural progression, it's how we develop new technology. Progression in
any area is a Good Thing, I would be worried if we didn't use IPv6 to it's
full extent.

-- 
steven