Subject: Re: IETF logistics

From: Danny McPherson <[email-masked]>
Date: Tue, 19 Dec 2000 15:49:54 -0700

It did indeed seem that the significant majority of 
time was spent 'viewing presentations/tutorials', 
while the WG chairs frequently employed RED/discard 
on the folks that occupied the queues at the 
microphones in order to more promptly begin the 
next tutorial and finish within the alloted time.

This is unfortunate, as the main idea behind meeting 
is to hash out design issues, not to get overly 
verbose presentations that typically aren't required
by those that read the drafts.

-danny

> 	Some compare/contrast about then and now, followed by
> some (perhaps radical) thoughts to ponder.  I'm NOT interested
> in quibbles about the timeframe for THEN or minor differences
> in perception about either THEN or NOW, so I'll ignore any
> troll-like responses.  This is intended as a very high-level
> set of comments -- high-level necessarily implies a certain
> lack of crispness.
> 
> THEN:
> 	- Presentations at IETF normally did NOT rehash 
> 	  material available in the I-Ds in tutorial style.
> 	- Viewgraphs were hand-scribbled the night before,
> 		often after some lobby bof before the meeting.
> 	- More people read the I-Ds before the meeting, though there
> 	  was griping about inadequate preparation then also.
> 	- Working Group sessions actually did work, designing
> 	  in real-time, discussing technical issues in real-time,
> 	  resolving open technical issues in a higher bandwidth
> 	  environment.
> 	- Interim WG meetings were rare.
> 	- Folks who had read the drafts could generally get into
> 	  and participate in meetings of interest.
> 
> NOW:
> 	- Presentations mostly do rehash material in the I-Ds
> 	- Viewgraphs with fancy cartoon graphics, company logos,
> 	  that required lots of time to create the week before
> 	  the meeting are shown.
> 	- Few people (as a percentage of WG attendees) have actually
> 	  read the I-Ds beforehand, relying instead on the 	  presentations.
> 	- Working Group sessions are mostly educational overviews,
> 	  without significant real-time discussion or resolution
> 	  of technical issues.
> 	- Interim WG meetings are much more frequent, in part 
> 	  because only people deeply interested in the topic
> 	  bother to travel for such meetings.
> 	- Folks who have read the drafts often cannot get into
> 	  the meetings they have prepared for.  I had abysmal luck
> 	  at actually attending sessions where I had read the drafts
> 	  and am actually involved in implementation or use of
> 	  a specification.
> 
> 	In the short term, IETF have signed contracts for
> 3 meetings per year.  We don't want to break any existing
> contracts.  What we can do for future IETFs is make the current
> sporadic practice of reserving the front few rows of seats for
> folks who have actually read the drafts and are involved in
> implementation.  We can also end the de facto practice of 
> using the sessions as tutorials and discontinue fancy prepared
> presentations of the material already in the I-Ds.  While 
> tutorials are a fine thing, they are appropriate for USENIX
> or Interop, not IETF WG sessions, IMHO.
> 
> 	However, I'd like to propose that we experiment 
> with only having 2 all-area IETF meetings per year when we
> can do so without breaking any contracts.
> 
> 	Further, I'd suggest that each area would have the
> option (discretion of the relevant ADs) of having a single 
> Area Meeting someplace.  This would last only perhaps 2 days.
> It could be held at a rather larger number of venues
> (due to smaller attendance) -- a college/university or large
> corporate location might well be a very good choice for such
> a meeting.  In addition, WGs ought to be encouraged to hold
> at least one WG interim meeting per year, to provide a vehicle
> for meaty discussion of technical issues by folks who are 
> current in the WG, involved in implementation or deployment
> of that WG's material, and so forth.  
> 
> Sincerely,
> 
> Ran
> [email-masked]
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 19 Dec 2000 20:20:12 -0500

> by those that read the drafts.

Just some personal thoughts...

FWIW, I suggested to a couple of WG/BOF chairs last week that,
if they _must_ have presentations (and I really like Pete
Resnick's idea), they consider insisting on

    (i) Getting the materials in advance
    
    (ii) Consolidating all of the presentations onto a single
    machine, to be controlled by the Chair.
    
    (iii) Warning presenters that the presentations will be
    appropriately "accelerated" if they contain too much
    marketing hype, drift off-topic, or go wandering into the
    weeds.  

I would also favor equipping Chairs with long poles with hooks
at the end for dragging performers offstage, or at least on/oiff
switches for microphones :-)

I think we have several different problems that are reinforcing
each other, but we can probably attack at least some of them
even if we don't have comprehensive solutions.

   john

---

From: John Hawkinson <[email-masked]>
Date: Wed, 20 Dec 2000 12:20:19 -0500

> switches for microphones :-)

The "Bradner method" has long functioned for this. The Chair (or AD)
walks up to a microphone and taps it until the speaker stops using
the microphone.

It requires the Chair be willing to do this, but so does a switch.

We have the technology (such as it were), what we perhaps need is the
Chairs to be empowered, or cognizant of this sort of requirement.

--jhawk