Subject: RE: Internationalization and the IETF

From: TOMSON ERIC <[email-masked]>
Date: Tue, 12 Dec 2000 17:03:45 +0100

Here is my contribution to the requested definitions.
--

Directory service = a software system that responds to requests for information about entities, e.g. people in an organization. It's a system for managing access to computer resources, keeping track of the users of a network,... from a single point of administration. It allows a network administrator to set up and control a database of users and resources and manage them using a directory (by example with an easy-to-use GUI, Graphical User Interface). Users, computers, sites,... can be added, updated and managed centrally ; applications can be distributed electronically.

Microsoft Active Directory, Network Information Service (NIS), Novell Directory Service (NDS) and X.500 are examples of directory services.
--

Address registry = a registry of numbers or addresses with some corresponding data, e.g. names. Such a registry helps maintain names, which are identifiers that are mapped to numbers or addresses.

Let's say a Directory Service is multi-dimensional, in the sense it involves many types of data, many levels of information you have to search in, while an Address Registry has one dimension, in the sense it just maps addresses to their corresponding name, like a telephone registry, DNS, WINS, the "hosts" file or the "lmhosts" file.
--

So, what is DNS? In the TCP/IP world, the Domain Name System (DNS) is a distributed database that provides the mapping between IP addresses and hostnames. It's just an address registry.
--

E.T.

-----Original Message-----
From: Gabriel Landowski [mailto:[email-masked]]

For the sake of a good discussion can we please have a
definition of "directory service" and "address
registry" to make sure we are all on the same page. 

I think we will find that defining these may be the
issue, and this will clarify the discussion to
something that we can get our arms around.

Gabriel Landowski
Mindangle Consulting

--- "Durah, Kheder" <[email-masked]> wrote:
> Dear Colleagues.
> 
> This is my first transmission to IETF, and would
> like to second the fact
> that DNS is an address registry and not a directory
> service.
> 
> RGDS
> 
> Kheder Durah, Ph.D.
> 
> -----Original Message-----
> From: [email-masked]
> 
> As I recall, didn't we (members of the IETF list)
> almost have a holy (flame)
> war, about wheather DNS was a directory service
> about 6 months ago......
> 
> Once more into the breech dear friends........ (with
> apologies to
> Shakespeare)
> 
> Jim
> 
> 
> Randy Bush <[email-masked]> on 12/08/2000 08:49:24 PM
> 
> Sent by:  Randy Bush <[email-masked]>
> 
> > Buzzt.  1000 times on the chauk board:
> >    The DNS is not a directory service...
> 
> but it's an address registry?

---

From: "Kyle Lussier" <[email-masked]>
Date: Wed, 13 Dec 2000 12:11:13 -0500

I hate to butt in here, I've been listening to these discussions for
some time.  (I am incredibly impressed with how smart everyone in these
IETF groups is).

But, what about NMS directories that contain devices (non-computer),
physical
location, automations, histories, provisioning, and acquisition information?

There seems to be a debate to split "DNS" from "Directory" services,
whereas, in long term, it is inevitable that DNS will merge with
Directory services, even if current technology isn't that way.
Pushing for a conceptual split in theory will slow the convergence
of DNS/Directory. I would argue, that this convergence is very valuable,
and is the natural progression (in long term).

The concept of a directory should be a large database, with pre-defined
standards for how different types of common knowledge is built in,
but should also allow for user defined types, for which no existing
standard exists.  DNS should ultimately become one standard data type
of this theoretical global directory.  As should what we want to do,
which is storing automations, configurations, and histories in the
directory.

The IETF community should be aware that it is probable that it is
impossible to predict *what* one would want to store in a Directory,
but that there is standard information that should be well-defined
to extract from the directory.

This is a passionate issue for us as no existing directory implementations
have supported all of the requirements for our NMS and we built on SQL
databases.

Ultimately, we believe a directory service should be just like a massive
SQL database, but include standard "Tables" for standard things, like
user accounts, DNS, computers, etc.  It should all be centrally accessible
in a common manner, but support custom user types, in addition to standards
for standard things.

It is dangerous to say "DNS is not Directory".  While in today's existing
implementations that is true, ask yourself the question, in the long
term, will this still be true?  And if it will be, is that good or bad?

I would argue, that in the long term, DNS *should* merge with Directory
services.

Kyle Lussier

> Directory service = a software system that responds to requests
> for information about entities, e.g. people in an organization.
> It's a system for managing access to computer resources, keeping
> track of the users of a network,... from a single point of
> administration. It allows a network administrator to set up and
> control a database of users and resources and manage them using a
> directory (by example with an easy-to-use GUI, Graphical User
> Interface). Users, computers, sites,... can be added, updated and
> managed centrally ; applications can be distributed electronically.
>
> Microsoft Active Directory, Network Information Service (NIS),
> Novell Directory Service (NDS) and X.500 are examples of
> directory services.
> --
>
> Address registry = a registry of numbers or addresses with some
> corresponding data, e.g. names. Such a registry helps maintain
> names, which are identifiers that are mapped to numbers or addresses.
>
> Let's say a Directory Service is multi-dimensional, in the sense
> it involves many types of data, many levels of information you
> have to search in, while an Address Registry has one dimension,
> in the sense it just maps addresses to their corresponding name,
> like a telephone registry, DNS, WINS, the "hosts" file or the
> "lmhosts" file.
> --
>
> So, what is DNS? In the TCP/IP world, the Domain Name System
> (DNS) is a distributed database that provides the mapping between
> IP addresses and hostnames. It's just an address registry.
> --

---

From: "Pan Jung" <[email-masked]>
Date: Wed, 13 Dec 2000 10:43:49 -0700

Hello,
I am new here but one note:
Even in long term, would "Services in Rich Application Classes" = directory
service
could be treated differently from "Services in System Operation Classes" =
DNS ?
Depending on the importance for systems operations? Maybe even as
sub-classes.

Pan Jung
Programmer/Consultant
[email-masked]

-----Original Message-----
From: Kyle Lussier [mailto:[email-masked]]
Sent: Wednesday, December 13, 2000 10:11 AM
To: TOMSON ERIC; 'Gabriel Landowski'
Cc: [email-masked]; [email-masked]; [email-masked]; 'Dave
Crocker'; Durah, Kheder; Randy Bush; [email-masked];
[email-masked]
Subject: RE: Internationalization and the IETF

Kyle Lussier

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 14 Dec 2000 06:19:42 +0859 ()

Kyle;

> Directory services, even if current technology isn't that way.

Huh?

URLs are the result of such merge.

URLs have ASCII domain name part followed by a path and search part.

You can put any local characters with any local encoding scheme to
path or search part of a URL. Browsers further encode them with %
escape. Localized web servers to recognize such a URL are available.

That's all and it's working.

							Masataka Ohta