Subject: Re: Example of dns (non) fun

From: John C Klensin <[email-masked]>
Date: Mon, 04 Dec 2000 18:31:10 -0500

I suggest you look in on the IDN working group, review their
documents if you have not done so, and then take this
discussion up on theiir mailing list if you aren't satisfied
with the answers you get.

    john

-------------------

--On Monday, December 04, 2000 5:00 PM -0500 Dan Kolis
<[email-masked]> wrote:

> In the present regime, its not surprising the frist below does
> not resolve and the second does:
> > http://www.déjà.fr/
> http://www.deja.fr/
> > > In the proposed regime, its not obvious what to do from a
> purely consumer point of view. Verisigns view would be each is
> completely unique. ICANN's dispute resolution would say there
> completely identifical and one has to go! But ICANN's
> resolution makes this problem appear in the first place.
> > Whoops, its not pretty.
> > Dan K
> > >

---

From: Richard Shockey <[email-masked]>
Date: Mon, 04 Dec 2000 19:09:27 -0500

At 05:00 PM 12/4/2000 -0500, Dan Kolis wrote:
>In the present regime, its not surprising the frist below does not resolve
>and the second does:
>
>http://www.déjà.fr/
>http://www.deja.fr/
>
>
>In the proposed regime, its not obvious what to do from a purely consumer
>point of view.

Depends on who is the consumer... to the French the difference here is 
completely obvious... and this whole problem is just "another Anglo-Saxon 
plot" etc...

>Verisigns view would be each is completely unique. ICANN's
>dispute resolution would say there completely identifical and one has to go!
>But ICANN's resolution makes this problem appear in the first place.

---

From: vint cerf <[email-masked]>
Date: Tue, 05 Dec 2000 03:37:38 -0500

from a purely mechanical point of view, if the character encoding
of these two strings makes them distinct, one might have to treat
them as distinct registrations - unless a very mechanical means of
converting them both into some canonical form were available to 
make them "match" - one would imagine that such canonicalization
process might require language-specific knowledge and that sounds
pretty challenging.

Vint

At 07:09 PM 12/4/2000 -0500, Richard Shockey wrote:
>Depends on who is the consumer... to the French the difference here is completely obvious... and this whole problem is just "another Anglo-Saxon plot" etc...
>
>

---

From: Stephen Dyer <[email-masked]>
Date: Tue, 05 Dec 2000 10:14:26 +0000

Hi,

There is also an interesting legal problem lurking with
http://www.deja.fr/   and  http://www.bq--aduwvya.fr/

A court might find me guilty of trademark violation of "deja" with the 
first URL, but I can't see them upholding the same for "bq--aduwvya"

Steve Dyer

---

From: "Dassa" <[email-masked]>
Date: Tue, 5 Dec 2000 21:36:45 +1100

Hi

Actually IMHO, it would not be such a jump for them to make.  They
impose trademark restrictions on DNS entries and the URDP has been
used to capture some generic wording.  As the by--aduwvya actually
translates to a similar wording I don't see it holding up the courts
or the URDP for long.

Dassa

|>-----Original Message-----
|>From: Stephen Dyer [mailto:[email-masked]]
|>Sent: Tuesday, December 05, 2000 9:14 PM
|>To: vint cerf; Richard Shockey; Dan Kolis; [email-masked]
|>Subject: Re: Example of dns (non) fun
|>
|>
|>Hi,
|>
|>There is also an interesting legal problem lurking with
|>http://www.deja.fr/   and  http://www.bq--aduwvya.fr/
|>
|>A court might find me guilty of trademark violation of "deja"
|>with the
|>first URL, but I can't see them upholding the same for "bq--aduwvya"

---

From: [email-masked] (Claus Färber)
Date: 05 Dec 2000 15:31:00 +0100

> first URL, but I can't see them upholding the same for "bq--aduwvya"

A domain name is, technically speaking, a sequence of octets. It is only  
interpreted as the letters "deja.fr" by some convention or standard. In  
this case, it's the DNS spec which refers to ASCII.

Why should it be different if another standard does not refer to ASCII,  
but another encoding?

Claus

-- 
http://www.faerber.muc.de