Subject: Re: Example of dns (non) fun iv

From: John C Klensin <[email-masked]>
Date: Wed, 06 Dec 2000 11:43:12 -0500

--On Wednesday, 06 December, 2000 10:22 -0500 Dan Kolis
<[email-masked]> wrote:

> Dan K says:
> 1) your right. with your tld .de I assume for the moment you
> also speak German. The difference is what you 'try' when a url
> doesn't work. If you tried:
> > http://ßrehct.de
> > and it didn't work you would probably try:
> > http://brehct.de

Dan, I suggest that many German-speakers (and even more
automated systems) would probably try, not the above, but
  http://ssrehct.de/
which would, I believe, be the algorithmic rendering of the
non-ASCII character.   And, while this isn't a good example for
a number of reasons (my memory is poor, but I don't recall ever
seeing Eszett at the beginning of a word and am not sure it is
possible), therein lies much of the problem because the mapping
is not reversible unless one infers from the presence in .DE
that German-language mapping rules must apply (a *very* risky
assumption).

     john

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 06 Dec 2000 14:00:33 -0500

> that German-language mapping rules must apply (a *very* risky

No ß at the beginning of words (and the author Brecht certainly doesn't
have any ß's), but even if you know the language, the mapping is not
reversible. ss, ae, oe, ue, etc. are all legal letter pairs, as anybody
who's tried to 8859-1'ify an ASCII text has discovered to their chagrin.
Indeed, there are situations, besides names, where even a dictionary is
not good enough since both words exist (Masse and Maße being one common
example).

> 
>      john
> 
> -
> This message was passed through [email-masked], which
> is a sublist of [email-masked]. Not all messages are passed.
> Decisions on what to pass are made solely by Harald Alvestrand.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs