Subject: RE: Internationalization and the IETF

From: Gabriel Landowski <[email-masked]>
Date: Tue, 12 Dec 2000 05:40:29 -0800 (PST)

For the sake of a good discussion can we please have a
definition of "directory service" and "address
registry" to make sure we are all on the same page. 

I think we will find that defining these may be the
issue, and this will clarify the discussion to
something that we can get our arms around.

Gabriel Landowski
Mindangle Consulting

--- "Durah, Kheder" <[email-masked]> wrote:
> Dear Colleagues.
> 
> This is my first transmission to IETF, and would
> like to second the fact
> that DNS is an address registry and not a directory
> service.
> 
> RGDS
> 
> Kheder Durah, Ph.D.
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Monday, December 11, 2000 7:16 PM
> To: Randy Bush
> Cc: [email-masked]; [email-masked];
> [email-masked];
> [email-masked]
> Subject: Re: Internationalization and the IETF
> 
> 
> 
> 
> As I recall, didn't we (members of the IETF list)
> almost have a holy (flame)
> war, about wheather DNS was a directory service
> about 6 months ago......
> 
> Once more into the breech dear friends........ (with
> apologies to
> Shakespeare)
> 
> Jim
> 
> 
> 
> 
> 
> 
> Randy Bush <[email-masked]> on 12/08/2000 08:49:24 PM
> 
> Sent by:  Randy Bush <[email-masked]>
> 
> 
> To:   Bill Manning <[email-masked]>
> cc:   [email-masked], [email-masked],
> [email-masked] (Jim
>       Stephenson-Dunn/C/HQ/3Com)
> Subject:  Re: Internationalization and the IETF
> 
> 
> 
> > Buzzt.  1000 times on the chauk board:
> >    The DNS is not a directory service...
> 
> but it's an address registry?
> 
> 
> 
> 

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

---

From: Bill Manning <[email-masked]>
Date: Tue, 12 Dec 2000 05:06:03 -0800 (PST)

% 
% For the sake of a good discussion can we please have a
% definition of "directory service" and "address
% registry" to make sure we are all on the same page. 
% 
% I think we will find that defining these may be the
% issue, and this will clarify the discussion to
% something that we can get our arms around.
% 
% Gabriel Landowski
% Mindangle Consulting
% 

	There have been a number of documents drafted on this
	issue over the past few years. You can find the results
	in the IETF meeting minutes archives, going back to at 
	least 1992. There are some old Internet-Drafts that talk
	to this issue (and I've heard that the IETF Secratariat
	is contemplating the creation of an historical ID repository)
	and there was a pretty good coverage of the issue in 
	the IDN workinggroup yesterday by John K. One hopes that
	his presentation will be available online soon.

	Of course, the general IETF mailing list might not
	be the right venue for continued conversation.

--bill

---

From: Dave Crocker <[email-masked]>
Date: Wed, 13 Dec 2000 07:41:04 -0800

>registry" to make sure we are all on the same page.

A Lookup, mapping, or address registry service takes a complete, precise 
query specification and returns a single, corresponding entry.  (The entry 
can have any amount of data, but all the data belongs to a single leaf node.)

A directory service can take a partial specification and can "search", 
returning more than one corresponding entry.

The simple way to refer to the distinction is mapping vs. searching.

d/

=-=-=-=-=
Dave Crocker  <[email-masked]>
Brandenburg Consulting  <www.brandenburg.com>
Tel: +1.408.246.8253,  Fax: +1.408.273.6464

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 12 Dec 2000 09:24:43 -0800

An attempt at writing down a reasonably self-consistent set of definitions 
occured in draft-alvestrand-directory-defs (currently expired).
A new version was posted to the open discussion list 
[email-masked] a few days ago.

I suggest we move the discussion of those definitions there.

At 07:41 13/12/2000 -0800, Dave Crocker wrote:
>-
>This message was passed through [email-masked], which
>is a sublist of [email-masked]. Not all messages are passed.
>Decisions on what to pass are made solely by Harald Alvestrand.

--
Harald Tveit Alvestrand, [email-masked]
+47 41 44 29 94
Personal email: [email-masked]

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 12 Dec 2000 13:58:38 -0500

>         his presentation will be available online soon.

all presentations of the idn wg monday meeting are now available on the wg 
web site: http://www.i-d-n.net.

Marc.

>         be the right venue for continued conversation.

Marc Blanchet
Viagénie inc.
tel: 418-656-9254
http://www.viagenie.qc.ca

----------------------------------------------------------
Normos (http://www.normos.org): Internet standards portal:
IETF RFC, drafts, IANA, W3C, ATMForum, ISO, ... all in one place.