Subject: New idea in TCP

From: "R.Z. Pan" <[email-masked]>
Date: Mon, 2 Apr 2001 14:43:39 +0800

Hi, all:
  I'm a newbie from P.R.China and I do some load balance stuffs. I noticed
that HTTP Protocol has a redirection mechanism to lead user to another web
site. Why TCP Protocol don't use this redirection mechanism to implement
load balancing? In my opinion, the process would be like:
                   SYN
User           ------------>       Load Balancer

                Redirection
Load Balancer  ------------>       User
               Best Server's IP

                   SYN
User          ------------->       Best Server

                   SYN
Best Server   ------------->       User
            ACK

                   ACK
User         -------------->       Best Server

The "Best Server" is one of the load server that be choiced by the Load
Balancer

To implement this, TCP Protocol should add one "redirect" bits. Data with a
redirection control bit we called it a redirection data, the redirection IP
address packed in the "Options" section of the TCP Header. For the TCP data
bring us the port number, so we can also dispatch the job according to the
port. I think load balancing can be resolved by the Operation System in this
way.
Is this a nonsense or a good idea? Please give me a advice. Thanks for your
attention!

---

From: vint cerf <[email-masked]>
Date: Mon, 02 Apr 2001 06:49:10 -0400

there is the problem of spoofing that makes this somewhat
more difficult that is outlined below.

vint

---

From: Alfonso De Gregorio <[email-masked]>
Date: Mon, 2 Apr 2001 16:07:50 +0200

On Mon, Apr 02, 2001 at 02:43:39PM +0800, R.Z. Pan wrote:

Hi,

maybe you can be interested in 'TCP Connection Migration' 
(draft-snoeren-tcp-migrate-00.txt) by A. C. Snoeren and 
H. Balakrishnan.

alfonso
 
> load balancing? In my opinion, the process would be like:

[...omissis...]

---

From: "ashokkp" <[email-masked]>
Date: Wed, 18 Apr 2001 14:40:38 +0530

1) tell me the mgcp packet format
2) how the conferencing is made in the mgcp
3) whether the sdp is used in the mgcp , why it is used
pls clear this doubt
thanx in advance
ashok

-----Original Message-----
From: vint cerf [mailto:[email-masked]]
Sent: Monday, 2 April 2001 4:19 PM
To: R.Z. Pan; IETF
Subject: Re: New idea in TCP

vint