Subject: RE: WG Review: Open Pluggable Edge Services (opes)

From: "Abbie Barbir" <[email-masked]>
Date: Wed, 20 Jun 2001 10:11:53 -0400

Paul,
very good points.

Content/data is/are already being changed/modified/adapted/etc  in transit
and 
the IETF must deal with it sooner or later.

Ensuring that the edge is dumb is not the way to protect the end-to-end
model.
The proper way to do it is to ensure that the edge is an extension of the 
source/origin. OPES can be used as a starting point.

abbie

> -----Original Message-----
> From: Paul Hoffman / IMC [mailto:[email-masked]]
> Sent: Tuesday, June 19, 2001 7:13 PM
> To: [email-masked]; [email-masked]
> Subject: Re: WG Review: Open Pluggable Edge Services (opes)
> 
> 
> Has everyone who has a reallyreallyreally strong opinion on this 
> matter actually read the charter? Right there near the top, it says:
> 
> >Intermediary services provided in this way are not transparent: 
> >Either the content requestor or provider will be aware that a 
> >tranformation has been performed.
> 
> OK, so the spelling is not so great, but it sure is clear. What some 
> people seem to be up in arms about is that the IETF would even think 
> of helping someone change the content in HTTP. Data mungers are doing 
> that already, and it is bad, and it is untraceable. So what should 
> the IETF do?
> 
> - Bury our head in the sand and at the same time keep yelling 
> "end-to-end", thereby getting sand in our mouths and having the other 
> people on the beach laugh at our collective and rapidly-aging rear 
> ends
> 
> - Let some other group create a standard, even though that group 
> probably cares much less about both end-to-end integrity or alerting 
> one or both sides than the IETF does
> 
> - Create a standard that does a really good job of allowing one end 
> (or, hopefully both ends) know what has been changed and why, in an 
> interoperable fashion
> 
> If my data coming or going gets changed, I want to be notified; that 
> cannot happen now.
> 
> As for the argument about "TLS everywhere", you have to ask who is 
> going to pay for it. The end-user cannot demand it; only the server 
> can. TLS is universally available today, and servers rarely use it 
> for anything other than getting credit cards or passwords.
> 
> Data is already being changed, some of in ways that we should really 
> be unhappy about, and there is no way for the folks changing it to 
> tell either end. OPES gives them that capability. Post-OPES, data 
> will still get changed silently without using OPES, but at least 
> there can be pressure put on the changers to use OPES so that someone 
> sees what is happening. Without OPES, they never will.
> 
> --Paul Hoffman, Director
> --Internet Mail Consortium
> 
>

---

From: Keith Moore <[email-masked]>
Date: Wed, 20 Jun 2001 12:18:32 -0400

> Content/data is/are already being changed/modified/adapted/etc  in transit and

that follows only if the IETF can make a useful contribution by "dealing with it".
it's not clear whether this is the case.
 
> Ensuring that the edge is dumb is not the way to protect the end-to-end model.
> source/origin. 

agree, though I would add "or destination" to the end.

but this isn't what's controversial about OPES.  what's controversial is the notion 
that the transformations enabled by OPES might also occur in the interior of the 
network, without being explicitly authorized by either the source or the destination.

Keith

---

From: Paul Hoffman / IMC <[email-masked]>
Date: Wed, 20 Jun 2001 10:24:11 -0700

At 12:18 PM -0400 6/20/01, Keith Moore wrote:
>what's controversial is the notion

Maybe I'm being dense, but I don't see anything in the proposed 
charter that allows that or even supports it.

--Paul Hoffman, Director

---

From: [email-masked]
Date: Wed, 20 Jun 2001 13:22:43 -0400

> network, without being explicitly authorized by either the source or the destination.

Amen.

A lot of things that OPES wants to do, I might want to use as a content provider,
or as a content consumer.  It's that man-in-the-middle thing that bothers me.

-- 
				Valdis Kletnieks
				Operating Systems Analyst
				Virginia Tech

---

From: "Michael W. Condry" <[email-masked]>
Date: Thu, 21 Jun 2001 16:16:51 -0700

>network, without being explicitly authorized by either the source or the 

Explicit authorization will be added to the charter.

>Keith

Michael W. Condry
Director,  Network Edge Technology