Subject: RE: WG Review: Open Pluggable Edge Services (opes)

From: "Christian Huitema" <[email-masked]>
Date: Tue, 19 Jun 2001 08:37:57 -0700

> From: Brian E Carpenter [mailto:[email-masked]]
>
> It seems to me there are 3 ways the world could go, and no 4th option:
> 
> 1. Something OPES-like will be standardised in the IETF
> 
> 2. Something OPES-like will be standardised in another organisation,
> perhaps
>    one with less clue than the IETF about scaling and security.
> 
> 3. Non-standardised OPES-like things will be widely deployed.
> 
> Pick the one you prefer.

What about option 4, "information publishers who don't like interference
by transport providers use TLS/SSL to enforce actual end-to-end
transmission of the content" ? As we gain experience in implementing
TLS, this is a certainly a possibility!

-- Christian Huitema

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 19 Jun 2001 12:28:56 -0500

Option 4 is not a separate option - it's a possible content
provider reaction to whichever of 1, 2 or 3 takes place. As
Mark pointed out, it has major scaling and trust model issues.

If I'm right and OPES-like boxes are inevitable, maybe the
IETF needs to start pre-emptive work on Option 4.

   Brian

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Jun 2001 15:19:35 -0400

> TLS, this is a certainly a possibility!

so we increase the burden on publishers who want content integrity in the
name of decreasing the burden on intermediaries who want to corrupt content?

somehow that doesn't seem like a socially beneficial tradeoff.

Keith