Subject: RE: 2 interfaces on same subnet

From: CARDOSO Jorge Miguel <[email-masked]>
Date: Thu, 31 May 2001 18:41:19 +0100

* Loadbalance feature is something usually implemented and controlled by
routing protocols using metric rules and not by the addressing scheem;
* On case of pure redundancy need (hs), in some systems is common a
definition of a virtual ip address shared by several interfaces - but under
this circunstances, the system should only answer to ARP requests only att
one interface at time for a specific ip address.

This are two common project requests that can be solved without breaking
simple logical and effective engineering rules.

Question:  why is it  logical rule?
-- case study:

Imagine the scenario -> one system with two interfaces : eth0: ip address
10.10.10.1/ 24 and the other 
eth1: 10.10.10.2/ 24.
We have 10 Ip packet to get out to the destination ip address 10.10.10.3.
What destination interface should be used? How to manage the percentage of
traffic that will get out at one or other interface? In case of interface
failure what is the reasonable decision to follow?

> this are typical issues of routing protocols - the decision should be
taken by the routing protocol, and not by the addressing scheeme itself.

Regards,
Jorge Cardoso.
		-----Original Message-----
		From:	John Stracke [mailto:[email-masked]]
		Sent:	Quinta-feira, 31 de Maio de 2001 17:22
		To:	[email-masked]
		Subject:	Re: 2 interfaces on same subnet

		[email-masked] wrote:

		> On Thu, 31 May 2001 17:40:53 +0300,
[email-masked]  said:
		> > I search why we can't have two ethernet interfaces(with
different IP address
		> > of course) on the same subnet?
		> > I know it's impossible but why?
		>
		> It's not impossible.  It's just often difficult to do it
*right*.

		Is it that useful? It'd boost reliability, but would it
boost performance? If
		you've got a card that can keep up with the wire, then you
don't have any
		bottlenecks that having two cards would solve.

		--
	
/==============================================================\
		|John Stracke    | http://www.ecal.com |My opinions are my
own.|
		|Chief Scientist
|=============================================|
		|eCal Corp.      |Help stamp out vi in our lifetime!
|
		[email-masked]|
|
	
\==============================================================/

---

From: Joe Touch <[email-masked]>
Date: Fri, 01 Jun 2001 09:28:44 -0700

John Stracke wrote:
> > On Thu, 31 May 2001 17:40:53 +0300, [email-masked]  said:
> > > I search why we can't have two ethernet interfaces(with different IP address
> > It's not impossible.  It's just often difficult to do it *right*.
> 
> Is it that useful? It'd boost reliability, but would it boost performance? If
> you've got a card that can keep up with the wire, then you don't have any

If they're sitting on a switched links, having two cards can
increase throughput (if the host can handle it).

Also, there are some (older, or based on older technology) systems
that can't quite handle aliasing properly. Using multiple interfaces
can be the only way to effectively do aliasing on those systems.

Joe

---

From: Joe Touch <[email-masked]>
Date: Fri, 01 Jun 2001 09:33:38 -0700

CARDOSO Jorge Miguel wrote:
> 
> Hello.
> 
> The system must decide wich interface will be used on the packet delivery to
> the lan. On this decision process, the subnetmask is used to define wich
> portion of the network will be found on a specific interface with specific
> ip address.

That could mean ARPs should go out both interfaces. But it
doesn't always mean there's a problem. Only one ARP response
will be used. The result could be that only one interface is 
loaded with outgoing packets.

That's why it's tricky.

Joe

---

From: TOMSON ERIC <[email-masked]>
Date: Tue, 5 Jun 2001 15:55:38 +0200

We CAN have 2 Ethernet interfaces with different IP addresses on the same subnet. It's NOT impossible at all. Nothing prevents this.

BUT...

What's the added value? In one of the companies I've been working for, some years ago, we had servers configured that way.
Guess what? It didn't bring any added value. Why? Because of the technology at that time : old servers, shared Ethernet,...

Let's have a look at the technology.

Outgoing frames will just use one interface. They will not be sent twice on the network. So, no added value.
Incoming frames will depend on the kind of network : shared or switched Ethernet.

Shared : one frame can travel on the network at a time. So, no added value.
Switched : OK, 2 frames can simultaneously reach the 2 interfaces. So, the added value will depend on the server...

Old technology : old server, old processor, old software : no ability to handle such traffic. So, no added value.
New technology : new server, new processor, new software : OK, it will be able to handle such traffic.

In conclusion : nowadays, it can bring some added value to use 2 interfaces on a big strong multi-processor server in a switched fast Ethernet environment.

Hope this answers your question.

E.T.

P.S.: in such a case, DISABLE routing between the 2 interfaces, and do NOT install any routing protocol (RIP,...).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]

Hi all,

Thank you.

BR, Fayçal