Subject: RE: on OPES

From: "Abbie Barbir" <[email-masked]>
Date: Fri, 22 Jun 2001 14:56:09 -0400

> -----Original Message-----
> From: Keith Moore [mailto:[email-masked]]
> Sent: Friday, June 22, 2001 2:00 PM

> 
> I think it comes down to this:
> 
> If OPES is building a standard interface which allows a 
> content-provider 
> a lot of flexibility in implementing *its own services*, 
> and/or allows a user
> a lot of flexibility in adapting content to his own needs, that's 
> probably a good thing.

yes, I agree with you here.

> If on the other hand OPES is building an interface which 
> allows a third 
> party to modify content that is obtained from other 
> information providers, 
> I don't see any way that IETF should support it.  Even 
> requiring consent is 
> not enough if the user or provider can be coerced into 
> providing that consent.

yes, I agree with you here also, as I said before and you added that we need
to make the edge an extension of the source (and in between).

> When OPES proponents gloss over the difference between these 
> it doesn't
> give me confidence that they can be trusted to develop 
> appropriate protocol 
> mechanisms to deter abuse, much less recommend policy for the 
> use of OPES.
> 
> Keith
> 

Well, here we need to give the benefit of the doubt. The IETF is an open
process where the input of all is welcommed. I am sure that at the end of
the day the people of the IETF will contribute towards doing the right
thing. 

I know you will give me examples of the contrary, but I am a strong beilver
of the
democratic process.

abbie

---

From: Keith Moore <[email-masked]>
Date: Fri, 22 Jun 2001 17:53:42 -0400

> process where the input of all is welcommed. I am sure that at the end of the
> day the people of the IETF will contribute towards doing the right thing.
> 
> 
> I know you will give me examples of the contrary, but I am a strong beilver of
> the democratic process.

this might sound nit-picky, but IETF does not work by a democratic process.
it works by consensus, which is not the same thing.

the process generally works pretty well as long as:

- the group over which consensus is measured doesn't manage to exclude 
  (by whatever means) competing interests, and

- the group isn't allowed to be derailed by one or two folks who are
  opposed to the rest of the group reaching consensus, and who refuse
  to compromise.

but if you want an IETF working group to approve something which you know is 
controversial, all you have to do is find some way to make it likely that 
the vast majority of people participating in that group share your opinion 
of the appropriate outcome.   one way to do this is by populating your group
with marketing people (or similar) who speak nothing but fully buzzword-
compliant nonsense.  if this happens, the chances are good that any engineers 
who attend will quickly conclude that they are wasting their time, and go
elsewhere.  by the time the group submits its documents to IESG, there is 
strong pressure to accept them or to make only small corrections. problem 
is, the documents don't make enough sense for anyone to come up with good
technical criticism of them.

the best fix is to either get new groups started on the right foot,
or to kill them before they can multiply. 

Keith

---

From: grenville armitage <[email-masked]>
Date: Fri, 22 Jun 2001 18:37:40 -0700

> Abbie Barbir wrote:
	[..]
> I know you will give me examples of the contrary, but I am a strong
> beilver of the
> democratic process.

I once knew a different IETF....

cheers,
gja