Subject: Re: Why IPv6 is a must?

From: [email-masked] (Sean Doran)
Date: Tue, 13 Nov 2001 00:07:56 +0100 (CET)

| at present our locators are AS numbers.

No, Keith, they are not.

The AS number does not describe a location in any sort of topology.
It is simply a representation of a set of routers with the same
routing policy, that should not receive via eBGP NLRI which 
have originated from or passed through said routers.

The AS number is otherwise completely meaningless, although
the AS path itself is a funny sort of non-scalar metric.
(See the work of Ahuja and Labovitz for details on that).

A locator by definition must describe a precise location within 
a network, such that any router will be able to forward traffic
towards that network using only the information in locator.

In IPv4, the locator *is* the IPv4 address, independent of
what inter- or intra-domain routing system is being used.

| if we change the system to use a different kind of locator we still
| need stable addresses, we still have to maintain the mapping 
| function from addresses to locators, and we still need that mapping
| function to be current and reliable.

End-to-end/globally-unique identifiers are very convenient indeed.
However, identifiers and locators are different.
There is no reason to overload them, and it's a bad habit.
It's also a bad habit to think that locators need to be
end-to-end or globally (rather than contextually) unique.

| what we are arguing about is the appropriate granularity of the 
| mapping function, and the appropriate place to maintain that mapping.

No, we are not arguing about that, but these are indeed issues.

	Sean.

---

From: Keith Moore <[email-masked]>
Date: Mon, 12 Nov 2001 18:46:43 -0500

> what inter- or intra-domain routing system is being used.

thanks for the clarification.  I don't pretend to be a routing
expert;  I just get into these discussions in an effort to 
keep the proposed solutions for routing scalability problems
from harming applications. 

but if AS#s aren't usable as locators, it seems like 
it should be possible to use BGP to advertise mappings from 
IP address prefixes to some other kind of locator, and to 
base route computations on *those* locators rather than 
on address prefixes.  that would allow routers to 
effectively aggregate routes for dissimilar prefixes,
at least for the purpose of route computations.
(even if the forwarding table still had to be indexed
by address prefix)

> There is no reason to overload them, and it's a bad habit.

there are plenty of reasons why they are overloaded, it's just that
folks tend to overloook those reasons because they are focusing
on a single problem.  some of them are outlined in another message
that I sent to the IETF list today.

> end-to-end or globally (rather than contextually) unique.

they don't have to be.  it's just that if the locators are 
context-specific then you can only use them for routing
within the context in which they're valid.  (and you want
to make really sure they don't get confused with locators
from other contexts)

> No, we are not arguing about that, but these are indeed issues.

I think that's the fundamental issue - at least, given the other
constraints on the problem that seem to be imposed.

Keith

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 12 Nov 2001 19:37:48 -0500

Note that to some degree, for some people, in some topologies, MPLS does 
exactly what you suggest.  It provides a modest size space of identifiers 
(which are local, an advantage) which can be used for forwarding by many 
devices.  For some situations, all the large table processing can be moved 
to the network edge. Unfortunately, the utilization and application is 
rather more complex.  But this kind of system does have many scaling 
advantages in that for most parts of the system the locator is indeed a 
separate and manageable piece of information.
Signalled systems also have the advantage that the setup can use large 
tables that are NOT in the fast path and therefore can tolerate worse 
scaling behaviors.  Of course, such systems also introduce interesting 
limtations and problems.  For example, scaling the number of paths that are 
setup can be a new and interesting way to choke.

Yours,
Joel M. Halpern

---

From: Keith Moore <[email-masked]>
Date: Mon, 12 Nov 2001 19:51:46 -0500

> exactly what you suggest. 

yes, indeed.  of course, the devil is in the details.  

having a separate pseudo-header with routing locator, for use by the 
routing system seems like a useful approach (though not the only 
possible approach).  OTOH, based on what I've heard I've formed
the impression that there are scaling limitations with the way that 
MPLS tends to be used.

Keith

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 13 Nov 2001 15:53:19 +0100 (CET)

> towards that network using only the information in locator.

Sean,

Towards the network/link or towards the node?

In 8+8 the top 8 bytes are just the locator for the *link* - not the node.
Thus in 8+8 the locator for a node is composed of the locator for the link
plus the identifier of the node.
Thus depending on the detailed definition this may or may not be viewed
as cleanly separating identifier and locator.

   Erik