Subject: Re: POP3 delivers, not deletes

From: [email-masked]
Date: Tue, 09 Sep 2003 02:45:14 -0400

On Tue, 09 Sep 2003 13:29:41 +0800, Shelby Moore said:

> One merely needs to disconnect without using QUIT, if the POP server is RFC
> 1939 compliant.  So this seems to make the whole suggestion implausible, since
> so easily to divert it.

That's a big 'if'.  RFC2821 mandates the acceptance of 'MAIL FROM:<>', but
my site alone gets enough bounces from sites that don't that I've found it useful
to define a macro to submit the site to www.rfc-ignorant.org.

It used to be that protocols only needed be error-resistant.   Nowadays, it seems
they need to be treachery-resistant too.....

---

From: Shelby Moore <[email-masked]>
Date: Tue, 09 Sep 2003 14:34:53 +0800

>That's a big 'if'.

I doubt it, unless a lot of POP servers want to be dropping user's email on common errors (<joke>such as all the times that Windows clients crash :)

Again that is why I asked how prevelant it is, because in my logic it seems implausible suggestion to use it to defend against the misuse the designers intended, when it is trivial to subvert it.

>It used to be that protocols only needed be error-resistant.

Was that before or after wooden bridges and the treacherous harmonics of boots of foreign armies?

>   Nowadays, it 
>seems

Seems like the same thing to me.  It is called engineering.

Shelby Moore
http://AntiViotic.com