Subject: RE: A modest proposal - allow the ID repository to hold xml

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 3 Sep 2003 09:01:10 -0400

Jari

If we have xml in the archive, then there are several tools
that can serve you up your choice of formats from that archive.
I don't think the value of storing the html bits in the archive
is all that much additional value.  One could have a website
that delivered such a thing without storing the html bits.
Such a site would permit the hyperlinking that you are talking
about.  We also avoid heated discussions about what was allowable
in the html, what version of which tools, etc.  This is a contentious
enough issue ("rough consensus and running code" applies, right?),
and making it bigger makes it harder to reach rough consensus.
Let's just do one simple thing -- allow xml, and see how it goes.

Brian

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: Wednesday, September 03, 2003 1:28 AM
> To: Michael Thomas
> Cc: Paul Hoffman / IMC; Rosen, Brian; [email-masked]'
> Subject: Re: A modest proposal - allow the ID repository to hold xml
> 
> 
> Michael Thomas wrote:
> > Paul Hoffman / IMC writes:
> >  > At 1:22 PM -0400 9/2/03, Rosen, Brian wrote:
> >  > >2) Ability to cross reference documents
> >  > 
> >  > That benefit only appears if all, or a significant 
> proportion, of the 
> >  > Internet Drafts are in XML or a similar format. That's 
> not what you 
> >  > proposed.
> > 
> >    It seems to me that a fairly simple hack could be
> >    consed up to generate HTML or whatever for current
> 
> I'd very much like to allow the submission of XML to the
> I-D directories.
> 
> However, in addition I'd like to actually allow the
> submission of HTML, generated by xml2rfc. Why? Because
> I'd really like to browse most drafts through my browser,
> jump to sections,  find the references easily etc. And without
> performing any extra steps by myself.
> 
> (It may be that this is possible via XML as well -- I'm
> not expert in XML so I can't tell if its readily supported
> by everyone's browser without loading lots of DTDs. Does
> someone know?)
> 
> And all of these submission formats should be allowed if
> and only there's a text version to go with it.
> 
> --Jari
>

---

From: Vernon Schryver <[email-masked]>
Date: Wed, 3 Sep 2003 12:04:54 -0600 (MDT)

> From: "Rosen, Brian" <[email-masked]>

> ...
> ...

If that is a problem with HTML (I agree that it is),
why wouldn't it be a bigger problem with XML?

Replacing "HT" with "X" doesn't magically change the politics.  In 
fact it makes them worse, because HTML is by now more stable and
has better consensus reality than XML.

Vernon Schryver    [email-masked]