Subject: POP3 delivers, not deletes

From: [email-masked] (Dan Kolis)
Date: Mon, 8 Sep 2003 09:18:16 -0400

>Although it is theoretically possible, using POP (rather than IMAP) 
>to leave the mail on the server until you pull it again with POP, 
>many servers appear to clear out the mail after POPing it. 

The Client program users LIST and RETR to get the messages than DELE to
remove them. The server/cloud program(s) don't do that. If you/anyone want
to leave mesage a\on a POP3 MTA, selecting a client program (or writing one)
to not DELEte them at your discression is potenetially useful.
regs,
Dan

---

From: Shelby Moore <[email-masked]>
Date: Mon, 08 Sep 2003 21:45:37 +0800

>to not DELEte them at your discression is potenetially useful.

I am already doing it here:

http://MailThentic.com/test.php

See the "Test Only (don't delete)" flag at bottom.

Shelby Moore
http://AntiViotic.com (aka http://MailThentic.com)

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 08 Sep 2003 07:54:48 -0700

--On 8. september 2003 09:18 -0400 Dan Kolis <[email-masked]> 
wrote:

> to leave mesage a\on a POP3 MTA, selecting a client program (or writing
> one) to not DELEte them at your discression is potenetially useful.

A *lot* of POP-using programs have the "Leave Mail On Server" option.
And a lot of people have used "Leave Mail On Server" as a poor man's 
1-folder IMAP, leading POP providers to implement mail retaining policies 
of the "RETR it once and it's gone, whether you DELEted it or not".

This is shown up in RFC 1939 (current definition of POP3) section 8:

>    .....In these situations and others, users and
>    vendors of POP3 clients have discovered that the combination of using
>    the UIDL command and not issuing the DELE command can provide a weak
>    version of the "maildrop as semi-permanent repository" functionality
>    normally associated with IMAP.

...........and in response, server operators are recommended to:

>    *  Enforce a site policy regarding mail retention on the server.
>
>       Sites are free to establish local policy regarding the storage and
>       retention of messages on the server, both read and unread.  For
>       example, a site might delete unread messages from the server after
>       60 days and delete read messages after 7 days.  Such message
>       deletions are outside the scope of the POP3 protocol and are not
>       considered a protocol violation.

Just to show that we've "been there, done that, code in the field".

                   Harald

---

From: John C Klensin <[email-masked]>
Date: Mon, 08 Sep 2003 12:31:28 -0400

--On Monday, September 08, 2003 09:18 -0400 Dan Kolis
<[email-masked]> wrote:

>> Although it is theoretically possible, using POP (rather than
>> IMAP)  to leave the mail on the server until you pull it
>> again with POP,  many servers appear to clear out the mail
>> after POPing it. 
> 
> 
> The Client program users LIST and RETR to get the messages
> than DELE to remove them. The server/cloud program(s) don't do
> that. If you/anyone want to leave mesage a\on a POP3 MTA,
> selecting a client program (or writing one) to not DELEte them
> at your discression is potenetially useful. regs,
> Dan

Dan,

I am pretty sure Vint knows what the protocol says.  So,
certainly, do I.   

In the real world, several ISPs have insisted that their servers
provide an implicit DELE after messages have been successfully
downloaded and the connection closed.  If leaving the mail on
the server (not DELEting them until you tell it to) is
important, you could, of course, choose an ISP that doesn't do
that automatic/ implicit delete.  But, because there are ISPs
that do the automatic delete, Shelby's claim (as I understand
it) that his system will work with any POP3 mailbox and server
is not quite correct.

     john

---

From: [email-masked] (Dan Kolis)
Date: Mon, 08 Sep 2003 13:00:02 -0400

>>       considered a protocol violation.

Dan says:
Well, yes I guess it "their" server (somebody's). There are a few things obviously 
desireble in POPX thet aren't in there. (deliver without Mime attachments as a preview, for 
instance).

Seems like IMAP is kind of too much, and Pop3 is too little for a lot of users.

I wouldn't like it if the server did this. I'd rather have a fixed limit in size, and a 
warning via email when its almost full, and have it reject messages beyond that size. But 
that's me. I guess leaving it to the site is just a part of reality.

A tiny extention to allow "push" email just broadcasting the subject lines; (possible 
encrypted) and headers generally would be cool. Like blackberry's protocol but not 
proprietary.

In any case I think pretty soon a total rethink of email is in order... re 
authentication/encryption/spam. but it's gotta be compatible and this will be tricky, to 
say the least.
regs
Dan

---

From: Shelby Moore <[email-masked]>
Date: Tue, 09 Sep 2003 11:14:41 +0800

This is very important to me because obviously my new service (AntiViotic.com) depends on it, to the degree that IMAP is not widely implemented.

Thus I have some important questions below...

>of the "RETR it once and it's gone, whether you DELEted it or not".

Do you think they also apply this policy to TOP n?

Do you have any idea how prevelant this rather extreme policy might be???

That is a very worrisome revelation for me.  I was aware of the aging policy you mention below from the RFC, but not of the delete after RETR policy you mention above.

>>       considered a protocol violation.

Note that the RFC does not define what a "read" message is, so I wonder if TOP n can apply , given that TOP n implies partial inspection (even if the entire message is returned)?

Thanks,
Shelby Moore
http://AntiViotic.com