Subject: Re: What *are* they smoking? (fwd)

From: [email-masked]
Date: Tue, 16 Sep 2003 00:44:48 -0400

OK guys... this certainly qualifies as "most broken SMTP implementation ever".

Will the protocol police please send out a squad car to pick up the suspects?

(at least now we know how they intend to only do this for HTTP.  Blargh).

Subject: Re: What *are* they smoking?
From: Matthew Sullivan <[email-masked]>
To: "Patrick W. Gilmore" <[email-masked]>
Cc: [email-masked]
Date: Tue, 16 Sep 2003 14:31:53 +1000

Patrick W. Gilmore wrote:

>
> -- On Tuesday, September 16, 2003 00:56 +0200
> -- Niels Bakker <niels=[email-masked]> supposedly wrote:
>
>> A wildcard A record in the net TLD.
>>
>> $ host does.really-not-exist.net
>> does.really-not-exist.net has address 64.94.110.11
>>
>> $ host 64.94.110.11
>> 11.110.94.64.IN-ADDR.ARPA domain name pointer 
>> sitefinder-idn.verisign.com
>>
>> It even responds on port 25 (says 550 on every RCPT TO).  Gah.
>
>
> No, it accepts if the from domain exists - but only if it *REALLY* 
> exists.
>
> [...]
> rcpt to: [email-masked]
> 250 OK
> mail from: [email-masked]
> 550 User domain does not exist.
> mail from: [email-masked]
> 250 OK
>
> Nice that their spam filters still work. :(
>
> And I love the 221 close message:
>
> data
> 221 snubby1-wcwest Snubby Mail Rejector Daemon v1.3 closing 
> transmission channel
> Connection closed by foreign host.
>
Worse than that - it's a fixed sequence of responses...

$ telnet akdjflasdf.com 25
Trying 64.94.110.11...
Connected to akdjflasdf.com.
Escape character is '^]'.
220 snubby4-wceast Snubby Mail Rejector Daemon v1.3 ready
sdfg
250 OK
sdfgsdfgsdfgsdf
250 OK
sdfgdfgaegqaergqaergvav
550 User domain does not exist.
asdfgasdfgasdf
250 OK
sdfasdfadsfasdf
221 snubby4-wceast Snubby Mail Rejector Daemon v1.3 closing transmission 
channel
Connection closed by foreign host.

/ Mat

---

From: Yakov Shafranovich <[email-masked]>
Date: Tue, 16 Sep 2003 01:27:09 -0400

The SMTP server is fake, take a look at this transaction:

----snip---
open 64.94.110.11 25
220 snubby1-wceast Snubby Mail Rejector Daemon v1.3 ready
blahblahbla
250 OK
blahblahbla
250 OK
blahblabhjla
550 User domain does not exist.
blahblbjhbj
250 OK
blajbjbjb
221 snubby1-wceast Snubby Mail Rejector Daemon v1.3 closing transmission 
channel

Connection to host lost.

---

From: [email-masked]
Date: Tue, 16 Sep 2003 01:52:10 -0400

> The SMTP server is fake, take a look at this transaction:

Actually, that was my point.

---

From: Yakov Shafranovich <[email-masked]>
Date: Tue, 16 Sep 2003 01:56:06 -0400

Mea culpa, sorry.