Subject: TCP over IPSec ESP??

From: chintan sheth <[email-masked]>
Date: Sat, 21 Feb 2004 02:51:12 -0800 (PST)

Hi,

Is there anything called TCP over IPSec ESP? I believe
it should be IPSec ESP over TCP. Please clarify. Also,
point me to the relevant RFC #.

Thanks,

Chintan

__________________________________
Do you Yahoo!?
Yahoo! Mail SpamGuard - Read only the mail you want.
http://antispam.yahoo.com/tools

---

From: Stephen Kent <[email-masked]>
Date: Mon, 23 Feb 2004 10:15:25 -0500

>point me to the relevant RFC #.

TCP can be encapsulated by ESP.

The correct spelling for the protocol is IPsec, not IPSec.

ESP is not generaly run over TCP.

RFC 2402 describes the use of ESP.

Steve Kent

author of 2401, 2402, 2406, ...