Subject: Re: Last Call: 'The IESG and RFC Editor documents: Procedures' to BCP

From: [email-masked] (Scott Bradner)
Date: Mon, 10 May 2004 09:33:51 -0400 (EDT)

looks good to me - one suggestion of clearer language and a potential
addition

>   o  Documents for which special rules exist, including IAB documents
>      and April 1st RFCs, and republication of documents from other SDOs
>      - the IESG and the RFC Editor keep a running dialogue on which
>      documents these are

awkward wording - maybe you want to say

   o  The IESG and the RFC Editor keep a running dialogue on which
        documents require special rules (for example, IAB documents,
        April 1st RFCs, and republication of documents from other SDOs)

section 3
>    The IESG may return five different responses

this misses one of the outcomes listed in RFC 2026 - specifically (quoting
from 2026):
	"the IESG recommends that the document be brought within the
	IETF and progressed within the IETF context"

this path has been used from time to time and I think it is a valuable
option - I'd suggest that it be added as a 6th response

Scott

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Mon, 10 May 2004 10:54:16 -0400

--On Monday, May 10, 2004 9:33 AM -0400 Scott Bradner 
<[email-masked]> wrote:

>
> looks good to me - one suggestion of clearer language and a
> potential addition
>
>>   o  Documents for which special rules exist, including IAB
>>   documents and April 1st RFCs, and republication of
>>      documents from other SDOs - the IESG and the RFC Editor
>>      keep a running dialogue on which documents these are
>
>    o  The IESG and the RFC Editor keep a running dialogue on
> which         documents require special rules (for example,
> IAB documents,         April 1st RFCs, and republication of
> documents from other SDOs)

Scott, while I agree that the current language is not optimal, I 
don't think the above is the right fix.   The whole point of the 
agreements about publication of IAB documents is that the RFC 
Editor reports, from an overall policy and strategy standpoint, 
with the IAB.  Turning that situation into "the IESG and the RFC 
Editor keep a running dialogue" rather dramatically revises (or 
confuses) that situation.

    john

---

From: John C Klensin <[email-masked]>
Date: Mon, 10 May 2004 10:54:16 -0400

john

---

From: Pete Resnick <[email-masked]>
Date: Mon, 10 May 2004 10:27:00 -0500

On 5/10/04 at 10:54 AM -0400, John C Klensin wrote:

>--On Monday, May 10, 2004 9:33 AM -0400 Scott Bradner <[email-masked]> wrote:
>
>>>documents and April 1st RFCs, and republication of documents from 
>>>other SDOs - the IESG and the RFC Editor keep a running dialogue 
>>>on which documents these are
>>
>>documents require special rules (for example, IAB documents, April 
>>1st RFCs, and republication of documents from other SDOs)
>
>agreements about publication of IAB documents is that the RFC Editor 
>reports, from an overall policy and strategy standpoint, with the 
>IAB.  Turning that situation into "the IESG and the RFC Editor keep 
>a running dialogue" rather dramatically revises (or confuses) that 
>situation.

John, the paragraph which Scott aims to fix is in the section which 
describes "what is currently happening". And, indeed, I believe it is 
true that the current state of affairs is that the IESG and the RFC 
Editor *do* keep a running dialogue about out-of-the-ordinary 
documents which may or may not need IESG review (where republication 
of certain SDO documents do -- because of liaison agreements -- and 
April 1st RFCs do not, as far as I know).

Perhaps this would be better stated as:

o  The IESG and the RFC Editor keep a running dialogue on which 
documents require special rules (for example, IAB informational 
documents and April 1st RFCs never require IESG review, whereas 
certain republication of documents from other SDOs do because of 
liaison agreements)

(assuming that captures what Harald, and Scott, intended in their attempts).
-- 
Pete Resnick <http://www.qualcomm.com/~presnick/>
QUALCOMM Incorporated - Direct phone: (858)651-4478, Fax: (858)651-1102

---

From: Pete Resnick <[email-masked]>
Date: Mon, 10 May 2004 10:27:00 -0500

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 10 May 2004 15:28:18 -0700

> option - I'd suggest that it be added as a 6th response

actually it was more-or-less intentionally left out.
There are 3 scenarios to consider, I think:

- There is a valid reason why it's impossible to do this work outside of 
the IETF. Response 4 or 5 should be returned, explaining why.

- The work can be done in the IETF, and the author agrees. The author 
should (IMHO) be the one to inform the RFC Editor that he/she is dropping 
the request to publish outside IETF review.

- The work can be done in the IETF (or rather, this draft could be the 
basis for further work in the IETF), but the author wants it published 
independently anyway. In this case, I think it is good for the health of 
the RFC series AND for the time budget of the IESG that the IESG does NOT 
say "should be brought in" to the RFC Editor; the IESG, having failed to 
convince the author, should just live with the RFC Editor's judgment on 
publication.

My opinion only.....

                      Harald

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 May 2004 04:15:50 -0400

Pete,

I thought I was describing the status quo and what is currently 
happening.   Unless the IAB has handed off that responsibility 
to the IESG in the last two years (in which case the community 
wasn't told), the IESG's having any discussion at all with the 
RFC Editor about an IAB document -- what is in that category, 
how they are handled, etc.-- is because the IAB asks for that 
discussion.  It presumably also occurs in a three-way 
environment, even if the IAB decides to be silent about 
particular aspects of the conversation.

     john

--On Monday, May 10, 2004 10:27 AM -0500 Pete Resnick 
<[email-masked]> wrote:

>>>    which  documents require special rules (for example, IAB
>>> documents, April  1st RFCs, and republication of documents
>>> from other SDOs)
>>
>> Scott, while I agree that the current language is not
>> optimal, I  don't think the above is the right fix.   The
>> whole point of the  agreements about publication of IAB
>> documents is that the RFC Editor  reports, from an overall
>> policy and strategy standpoint, with the  IAB.  Turning that
>> situation into "the IESG and the RFC Editor keep  a running
>> dialogue" rather dramatically revises (or confuses) that
>> situation.
>
> John, the paragraph which Scott aims to fix is in the section
> which describes "what is currently happening". And, indeed, I
> believe it is true that the current state of affairs is that
> the IESG and the RFC Editor *do* keep a running dialogue about
> out-of-the-ordinary documents which may or may not need IESG
> review (where republication of certain SDO documents do --
> because of liaison agreements -- and April 1st RFCs do not, as
> far as I know).
>
> which documents require special rules (for example, IAB
> informational documents and April 1st RFCs never require IESG
> review, whereas certain republication of documents from other
> SDOs do because of liaison agreements)
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 May 2004 04:15:50 -0400

Pete,

     john

---

From: [email-masked] (Scott Bradner)
Date: Tue, 11 May 2004 08:46:25 -0400 (EDT)

> the IETF. Response 4 or 5 should be returned, explaining why.

not the case I'm speaking of - I'm speaking of new work that the IESG 
feels would be a good new IETF topic or that it fits within the charter of
an existing WG (and maybe the author did not know that) and the IESG feels
that it would be good to have the WG work on the document.

> the request to publish outside IETF review.

but that seems to drop a ball - the RFC Editor asks the IESG a question
imo the IESG should answer - maybe just say 'we are talking with the
author about doing this work in the IETF' but at least say something
to close the loop

I also think that just leaving out these possibilities makes this 
document an incomplete  picture of the processing that goes on
and I fail to see a reason to not mention that bringing the work into
the IETF is an option (even if you think the author should tell the
RFC Editor that is being done)

> convince the author, should just live with the RFC Editor's judgment on 

agree (and 2026 specifically calls this case out)

Scott

---

From: [email-masked] (Scott Bradner)
Date: Tue, 11 May 2004 08:46:25 -0400 (EDT)

Scott

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 11 May 2004 14:34:50 +0100

--On 11. mai 2004 08:46 -0400 Scott Bradner <[email-masked]> wrote:

>> should (IMHO) be the one to inform the RFC Editor that he/she is
>> dropping  the request to publish outside IETF review.
>

Yes - the IESG should answer.
But I believe the question being asked is "is there a reason, based on 
conflict with existing IETF work, that this document should not be 
published?"

And the IESG should answer yes or no to that question.

Anything else should (IMHO) be advice to the RFC Editor and the author, and 
not be part of the formal position-taking the IESG makes.

Because in the past, we've seriously bogged down independent publications 
because we were debating (with or without the author) whether or not they 
should be IETF work.
And we need to stop doing that.

                    Harald

---

From: [email-masked] (Scott Bradner)
Date: Tue, 11 May 2004 09:57:04 -0400 (EDT)

> not be part of the formal position-taking the IESG makes.

we may be debating termonology

your ID says "The IESG may return five different responses"

that seems to eliminate the possibility of communicating any
such advice

> And we need to stop doing that.

beware of tossing too much away just to "stop doing that"

I still fail to see why this document cannot say that one of the
outcomes could be that the author could agree with the IESG to bring
the work into the IETF -  it seems a bit dogmatic to refuse to say that
(and counter to the intent of 2026)

Scott

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 11 May 2004 14:34:50 +0100

Harald

---

From: [email-masked] (Scott Bradner)
Date: Tue, 11 May 2004 09:57:04 -0400 (EDT)

Scott

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 May 2004 12:18:20 -0400

Scott, Harald,

It seems to me that this problem/ disagreement could be easily 
solved while preserving the (IMO, valid) points both of you are 
making, by including a sentence somewhere to the effect of...

	Of course, the IESG or individual ADs may have
	discussions with the author during this period about
	other possible ways to handle the document.  Should that
	discussion result in a voluntary action by the author to
	drop the request to the RFC Editor to publist, the
	document moves immediately outside the scope of this
	specification.

Now, that may not be the right phrasing in context, and can 
certainly be improved.   But I think it covers the full range of 
from "we really think this should be standardized, why not let 
us process it that way" to "if you insist on publishing that 
thing, I'm going to break both of your legs".   The question of 
whether those actions are appropriate is a separate issue, but 
the IESG has never been able to insist on either standardization 
or withdrawal.  And, as far as I know, both actions are 
identical as far as the RFC Editor is concerned: the document is 
spontaneously withdrawn as an individual submission.

       john

--On Tuesday, May 11, 2004 9:57 AM -0400 Scott Bradner 
<[email-masked]> wrote:

>> Anything else should (IMHO) be advice to the RFC Editor and
>> the author, and  not be part of the formal position-taking
>> the IESG makes.
>
>> Because in the past, we've seriously bogged down independent
>> publications  because we were debating (with or without the
>> author) whether or not they  should be IETF work.
> I still fail to see why this document cannot say that one of
> the outcomes could be that the author could agree with the
> IESG to bring the work into the IETF -  it seems a bit
> dogmatic to refuse to say that (and counter to the intent of
> 2026)
>
> Scott
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 May 2004 12:18:20 -0400

Scott, Harald,

       john

---

From: [email-masked] (Scott Bradner)
Date: Tue, 11 May 2004 12:39:02 -0400 (EDT)

in general that seems OK though I'd like to see "including the possibility
of the author pursuing the work within the IETF" added

----

---

From: [email-masked] (Scott Bradner)
Date: Tue, 11 May 2004 12:39:02 -0400 (EDT)

----

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 May 2004 21:04:14 -0400

--On Tuesday, May 11, 2004 12:39 PM -0400 Scott Bradner 
<[email-masked]> wrote:

> in general that seems OK though I'd like to see "including the
> possibility of the author pursuing the work within the IETF"
> added

Clearly I intended that option to be included.  I didn't state 
it for two reasons.  First, I thought it was obvious.  Second, 
it felt like it was looking for trouble to identify one example 
("pursue the work within the IETF" while not identifying any 
others.  And, bluntly, the obvious other example is "the IESG 
beats the author (I hope only intellectually and metaphorically) 
to a  pulp and convinces him that the document is really stupid 
and will cause him embarrassment for the rest of his life".  I 
don't want to go anywhere near that in this sort of document, 
but avoiding doing anything that would permit someone to 
complain that AD administration of a clue-by-four (even 
aggressively) is inappropriate.

Much more broadly and IMO, if the IETF is going to be worth 
anything a few years from now, the ADs have to be enabled to 
educate, and encouraged and expected to do so, even when the 
subject of such education is unwilling.   As long as "education" 
doesn't shift into "intimidation", if the side effect of such 
education is withdrawal of a dumb document, then I think it is 
wonderful.  This isn't the critical mainstream for this 
document, with or without the suggested modifications, but, 
based on the experience of the last few years, I get really 
worried about text -- especially new text-- in these procedural 
documents that enables or encourages potential protocol 
lawyers... whether they are inside the IESG or outside the core 
IETF community.

    john

  --On Tuesday, May 11, 2004 12:39 PM -0400 Scott Bradner 
<[email-masked]> wrote:

> in general that seems OK though I'd like to see "including the
> possibility of the author pursuing the work within the IETF"
> added
>
> ----
>
>> From [email-masked]  Tue May 11 12:18:30 2004
> X-Original-To: [email-masked]
> Delivered-To: [email-masked]
> Date: Tue, 11 May 2004 12:18:20 -0400
> From: John C Klensin <[email-masked]>
> To: Scott Bradner <[email-masked]>, [email-masked],
> 	[email-masked], [email-masked]
> Subject: Re: Last Call: 'The IESG and RFC Editor documents:
>  Procedures' to BCP
> In-Reply-To: <[email-masked]>
> References:  <[email-masked]>
> X-Mailer: Mulberry/3.1.3 (Win32)
> MIME-Version: 1.0
> Content-Type: text/plain; charset=us-ascii; format=flowed
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
>
> Scott, Harald,
>
> solved while preserving the (IMO, valid) points both of you
> are  making, by including a sentence somewhere to the effect
> of...
>
> certainly be improved.   But I think it covers the full range
> of  from "we really think this should be standardized, why not
> let  us process it that way" to "if you insist on publishing
> that  thing, I'm going to break both of your legs".   The
> question of  whether those actions are appropriate is a
> separate issue, but  the IESG has never been able to insist on
> either standardization  or withdrawal.  And, as far as I know,
> both actions are  identical as far as the RFC Editor is
> concerned: the document is  spontaneously withdrawn as an
> individual submission.
>
>        john
>
>

>
> ----
>
>> From [email-masked]  Tue May 11 12:18:30 2004
> X-Original-To: [email-masked]
> Delivered-To: [email-masked]
> Date: Tue, 11 May 2004 12:18:20 -0400
> From: John C Klensin <[email-masked]>
> To: Scott Bradner <[email-masked]>, [email-masked],
> 	[email-masked], [email-masked]
> Subject: Re: Last Call: 'The IESG and RFC Editor documents:
>  Procedures' to BCP
> In-Reply-To: <[email-masked]>
> References:  <[email-masked]>
> X-Mailer: Mulberry/3.1.3 (Win32)
> MIME-Version: 1.0
> Content-Type: text/plain; charset=us-ascii; format=flowed
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
>
> Scott, Harald,
>
> solved while preserving the (IMO, valid) points both of you
> are  making, by including a sentence somewhere to the effect
> of...
>
> certainly be improved.   But I think it covers the full range
> of  from "we really think this should be standardized, why not
> let  us process it that way" to "if you insist on publishing
> that  thing, I'm going to break both of your legs".   The
> question of  whether those actions are appropriate is a
> separate issue, but  the IESG has never been able to insist on
> either standardization  or withdrawal.  And, as far as I know,
> both actions are  identical as far as the RFC Editor is
> concerned: the document is  spontaneously withdrawn as an
> individual submission.
>
>        john
>
>

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 May 2004 21:04:14 -0400

john

---

From: [email-masked] (Scott Bradner)
Date: Wed, 12 May 2004 07:12:28 -0400 (EDT)

> I get really

a reasonable worry (sorry to say) - note though that the text I'm suggesting 
is already in RFC 2026 so unless this new ID specifically obsoletes 
the section of RFC 2026 (right now the ID says its compatable with that 
section) - the old text still could be used by those protocol lawyers

Scott

---

From: [email-masked] (Scott Bradner)
Date: Wed, 12 May 2004 07:12:28 -0400 (EDT)

Scott