Subject: Language Tags: Response to a part of Jefsey's comments concerning the W3C

From: "Addison Phillips [wM]" <[email-masked]>
Date: Mon, 3 Jan 2005 18:11:39 -0800

I'm not going to respond to most of Jefsey's comments. However, wearing my W3C hat for a moment....

Jefsey wrote:

- "RFC 3066bis" wants to fix some of the W3C needs, in a way which would 
make these patches Internet standards. This is not the appropriate way. 
(There is a W3C document on its way, why two?)
--

Let me be abundantly clear.

"RFC 3066bis" (that is, draft-phillips-langtags) is not intended to solve or solely to solve needs described formally or informally by the W3C Internationalization WG nor, as far as I am aware, any other part of the W3C. Participants in the W3C I18N WG (such as, obviously, myself) and other W3C working groups have contributed to the development  and review of the draft, but they have done so as individuals or as representatives of their organizations or employers. This document emphatically is not a product of the W3C, however. It is an individual submission to the IETF supported by many of the subscribers in the IETF-languages list (where it was developed) and by these various organizations.

There is not yet a W3C document on its way related to language tags. In the draft charter renewing the Internationalization Working Group, which I hope is approved shortly, there is some discussion of guidelines for implementation of RFC 3066 and (I hope) its successor. There is also a specific work item to define locale identifiers for the World-Wide Web in general and Web services in particular. None of this work is in the current charter. It is my hope that this new charter will be approved to start soon.

Locale identifiers are emphatically not the same thing as language tags. The use of RFC 3066 in W3C specifications has always been very clearly as language identifiers and never (to date) as a locale identifier. Although there is a relationship between the two applications and although RFC 3066 language tags have been used as a kind of de facto locale identifier in the past (especially by some Web applications with regard to the Accept-Language/Content-Language headers for HTTP), this should not suggest that some W3C specification is in the offing that overrides or supersedes RFC 3066 or its successor. Nor will the W3C I18N Core WG be chartered, AFAIK, to replace RFC 3066 (or its successor).

To the extent that W3C specifications are important consumers of language tags, there is interest at W3C and I'm sure the W3C's official liasons will make the W3C's position (assuming that it has one) known at an appropriate time. 

Best Regards,

Addison

Addison P. Phillips
Director, Globalization Architecture
http://www.webMethods.com

Chair, W3C Internationalization Working Group
http://www.w3.org/International

Internationalization is an architecture. 
It is not a feature.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "JFC (Jefsey) Morfin" <[email-masked]>
Date: Wed, 05 Jan 2005 02:31:05 +0100

At 03:11 04/01/2005, Addison Phillips [wM] wrote:
>I'm not going to respond to most of Jefsey's comments. However, wearing my 
>W3C hat for a moment....*

Thank you for that.

>To the extent that W3C specifications are important consumers of language 
>tags, there is interest at W3C and I'm sure the W3C's official liasons 
>will make the W3C's position (assuming that it has one) known at an 
>appropriate time.

??? I am not sure I understand. Every network user application is a 
consumers of language support. If there is no W3C official position yet, 
why not to follow under IAB guidance (or to review) the charter I proposed 
yesterday, in an IETF way everyone could participate, and to have all these 
applications supported one shot in working on a linguistic ontology where 
each language instance would be documented by an ad hoc authoritative 
source. Otherwise it could not be the standard you wish.
jfc