Subject: My current timeline for IASA BCP action

From: Harald Tveit Alvestrand <[email-masked]>
Date: Fri, 21 Jan 2005 10:44:46 +0100

As you will probably be totally unsurprised to see, I'm pushing back the 
prospective dates for IASA BCP approval again.
I think we are "close, but not finished" with the various clarifications 
and process polishing - and still don't have a workable consensus on the 
appeals issue.
I also have some points from legal review to insert.

So this is my current plan:

- Today, Friday, January 21: Send out "consensus?" messages on all 
remaining issues from the tracker that are not currently in play.
Suggest a plan for resolving the "appeals" issue.
Send out for review input from legal review.

- Tuesday, January 25: Issue version -05 of the BCP, with the changes we 
have agreed to at that time. This should be a version that the IETF can 
agree to and that the ISOC BoT can agree to, possibly pending resolution of 
known open issues (I hope there are none!)

- Friday, January 28: If there are resolved issues that demand revision of 
text between Tuesday and Friday, issue version -06.
This text should be the final text, and I will ask people to not suggest 
"minor clarifications" to that document, but rather consider whether or not 
they find the document as a whole acceptable for going forward or not. This 
is the time when polishing stops.
I will also send a note to the IETF-announce list saying that the final 
version is now ready.

- Thursday, February 3: Ask the IESG to formally approve the document. 
After this, if the IESG approves, no changes will be made at all, and I 
will send a message to the ISOC BoT asking them to approve the same 
document.

On my previous timeline, January 12, I promised to ask the questions 
relative to the -04 draft:

>   - Is the draft now good enough?
>   - Do we need to reissue, lengthen or restart the Last Call?

I think the first question got answered with a "no" - hence this plan, and 
the new revisions.

Does anyone wish to argue that the second question need to be answered 
"yes", or that there are other things that make this timetable an 
unreasonable one?

                        Harald

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: John C Klensin <[email-masked]>
Date: Fri, 21 Jan 2005 12:14:32 -0500

--On Friday, 21 January, 2005 10:44 +0100 Harald Tveit
Alvestrand <[email-masked]> wrote:

> As you will probably be totally unsurprised to see, I'm
> pushing back the prospective dates for IASA BCP approval again.
> I think we are "close, but not finished" with the various
> clarifications and process polishing - and still don't have a
> workable consensus on the appeals issue.
>...
> On my previous timeline, January 12, I promised to ask the
> questions relative to the -04 draft:
> 
> I think the first question got answered with a "no" - hence
> this plan, and the new revisions.
> 
> Does anyone wish to argue that the second question need to be
> answered "yes", or that there are other things that make this
> timetable an unreasonable one?

Harald,

I'm not prepared to argue a personal need for another
several-week Last Call, but want to make two observations:

(1) When one looks at the number of changes that have been made
since the initial Last Call, and the number of those that have
actually been substantive, I think a narrow reading of our
procedures _requires_ such a Last Call and that proceeding
without it would be easily appeal-able.  From that perspective,
what you are asking for is broad community consent to not hold
that Last Call.  That is perfectly reasonable, but we should all
understand it in the same way.

(2) While I don't think we need four weeks, I'm concerned about
having only three working days (between the announcement
sometime on Friday 28 Jan to the IESG approval call on 3
February) to review the final document.  While I think the
editors have done an astonishingly good job of pulling all of
this together, it is a lot of work and we know that a few things
that were agreed to slipped through the cracks of -04.  So I
want all of us to be able to study -06 or whatever the IESG is
going to vote on.  Three working days is not enough -- if I
recall, it even violates the IESG's internal minimum for WG
document availability ahead of a decision.  My recommendation is
that:

	* You not try to take a formal IESG decision until
	Monday, 7 February.
	
* Because this is not a standards action that is clearly within
the IESG's responsibility, and because the foundation documents
that got us here were joint IESG/IAB responsibilities, the IAB
should be polled on its opinion of the community consensus.  The
information from that poll should be supplied to the IESG well
in advance of that Monday decision window and, if there are
dissent(s), the dissenter(s) should be encouraged to post their
concerns to the IETF list.
	
	* If the IESG is unanimous on the decision, you should
	be able to take that decision by email and to do so quickly. 
	
	* If the IESG is not unanimous, then the concerns of the
	dissenting IESG members should be posted to the IETF
	list for comments and further input (and a period of at
	least a could of days) before the IESG meets (presumably
	by phone) to determine if it can reach consensus under
	its ordinary voting rules.  I am assuming that, if doing
	this quickly is important enough to justify any
	accelerated handling (i.e., not a four-week Last Call on
	-06), then the IESG can find time for an extra
	teleconference if that is really needed (and,
	conversely, that the desire to avoid such a call may
	motivate people to reach consensus :-( ).

If there is really adequate community consensus behind this, and
the IAB poll and IESG action reflect that consensus, this
"costs" only a weekend and will, IMO, leave us all feeling much
more secure about the result.  If there is still significant
dissent --either in the community or within the IAB and/or IESG
-- then airing and resolving it by this sort of pre-approval
mechanism is much faster than dealing with a possible appeal.

    john

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Mon, 24 Jan 2005 14:21:53 +0100

> understand it in the same way.

I understand it - we could argue about whether the procedures were written 
with the intent that such a narrow reading entails, but that's a long and 
separate discussion. I do think we have to have broad community consent (as 
represented by the readership of the IETF list) to not hold a second Last 
Call.

> 	* You not try to take a formal IESG decision until

I'll make that "seven days after the last version of the I-D is published". 
Makes sense to me.
However, sooner or later we've got to stop fixing the small bugs - at the 
time when the "presumed to be final" I-D is published, I will have to ask 
people to only raise new issues that they feel are "show-stoppers" - this 
is the same discipline that we've tried to enforce in the IESG with regard 
to second and subsequent reviews. (Note: According to Friday's schedule, 
-05 is not "presumed to be final".)

> concerns to the IETF list.

Reasonable thing to do.

> 	motivate people to reach consensus :-( ).

We discussed this in the IESG telechat on Thursday last - the IESG members 
agreed that they would raise DISCUSS-sized issues on the list, not via the 
balloting mechanism. So given that these can be resolved, I believe there 
should be few problems in achieving IESG consensus.

> mechanism is much faster than dealing with a possible appeal.

Thanks!

                Harald