Subject: RE: draft-phillips-langtags-08, process, specifications, "stability", and extensions

From: "Peter Constable" <[email-masked]>
Date: Wed, 5 Jan 2005 14:16:10 -0800

> From: [email-masked] [mailto:ietf-languages-
> [email-masked]] On Behalf Of Bruce Lilly

> > [...] RFC 1766/3066 need to be able to deal with tags that contain pieces they don't
> know about -- the only subtags they can know about are initial subtags of "i", "x" or
> ISO 639 IDs, or a second subtag consisting of an ISO 3166 code in case the first
> subtag is and ISO 639 ID.
> 
> Right. I.e. they should be able to deal with superfluous stuff
> on the right.  But not script tags that suddenly appear between
> language code and country code.

For purposes of an RFC 1766/3066 parser, a script tag plus anything after it would be "stuff on the right I don't know anything specific about". It could not be described as superfluous -- the process can still compare tags and make matches according to whatever rules it uses, such as left-prefix matching.

> For the triple of
> language/country/script to match usefully in the general case by
> RFC 3066 parsers (which are unaware of script in general), the first
> and second subtags would have to remain language code and country
> code respectively.

If you consider realistic scenarios, this makes the wrong assumption that country distinctions generally matter more to users.

> not on a Quixotic quest for "stability"
> of nations.

The draft doesn't try to achieve stability of nations. Only stability in the semantics of metadata elements.

Peter Constable

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: [email-masked]
Date: Thu, 06 Jan 2005 06:31:40 -0800 (PST)

> If you consider realistic scenarios, this makes the wrong assumption that
> country distinctions generally matter more to users.

If you want to consider realistic scenarios, it is often the case that country
information is readily available as input to matching algorithms, whereas
script information is not. Therefore the assumption that scripts matter more
than countries may be true but isn't relevant.

				Ned

---

From: Keld Jørn Simonsen <[email-masked]>
Date: Thu, 6 Jan 2005 16:56:45 +0100

> than countries may be true but isn't relevant.

I would also favour the country code as second field, as it would be
backwards compatible with RFC 3066, and also compatible with the order
used in locales.

Best regards
Keld

---

From: Keld Jørn Simonsen <[email-masked]>
Date: Thu, 6 Jan 2005 17:30:42 +0100

On Thu, Jan 06, 2005 at 04:08:05PM +0000, Michael Everson wrote:
> At 16:56 +0100 2005-01-06, Keld Jørn Simonsen wrote:
> 
> That would be an example of getting these tags to 
> do more than identify varieties of language.

It was not the intention to use the RFC 3066 bis tags as locale identifiers.
I only listed the concern as to not confuse the public at large with
different rules for similar concepts.

Best regards
Keld