Subject: draft filenames (Was Re: MARID back from the grave?)

From: Bruce Lilly <[email-masked]>
Date: Mon, 7 Mar 2005 21:33:46 -0500

>  Date: 2005-02-25 22:14
>  From: Dave Crocker <[email-masked]>
 
> in terms of naming, I think syntactically it reduces to:
> 
> 
>   I-D-Name       =  "draft-" owner "-" category "=" title "-" version
>  
>   owner          =  author-name / "ietf"
>                    ; who retains change control
> 
>   author-name    = { last name of first author }
>  
>   category       =  working-group / topic 
> 
>   working-group  = { IETF working group }
> 
>   topic          = { term under which I-D topic fits}
> 
>   title          = { text specific to this I-D, to describe it }

No, because ABNF quoted strings denote case-insensitive matching,
whereas draft filenames are prohibited from containing upper-case
letters.  So you would need something like %x64.72.61.66.74
instead of "draft", %x69.65.74.66 instead of "ietf", and comments
about the upper-case prohibition regarding author names, etc.

Also, I believe that the "=" in the first line is a typo.

With the proposed restriction of characters to lower-case letters,
digits, and hyphen, there would probably have to be additional
commentary regarding author names (some of which contain accented
letters or use non-Latin scripts), topics, and titles.

Finally, version needs to be defined, e.g.:

   version        = 2DIGIT ; starting with 00

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 09 Mar 2005 19:23:49 +0100

Reality check: there's a draft in last call about a proposed
tool for submitting drafts. Specific comments on that draft
would be very useful, possibly more so than tuning the ABNF
for file names.

    Brian

> The IESG has received a request from the TOOLS team to consider the 
> following document:
> 
> - 'Requirements for IETF Draft Submission Toolset '
>    <draft-ietf-tools-draft-submission-07.txt> as an Informational RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send any comments to the
> [email-masked] or [email-masked] mailing lists by 2005-03-28.
> 
> Note that this is an unusual document, in that it doesn't specify a protocol
> or a procedure; instead, it specifies requirements for a tool to make IETF
> procedures run more smoothly. The process that produced this (the Tools team)
> is itself an experiment; in addition to commenting on the content of the
> document, comments on whether or not it makes sense to publish this as
> an RFC, and comments on the process that produced it, are appropriate.
> 
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-tools-draft-submission-07.txt