Subject: Fw: Presence -Watcher clarification

From: "Rg" <[email-masked]>
Date: Wed, 6 Apr 2005 19:28:48 +0530

Hi

Greetings again

Could any one help in clarifying the below issue please?

Thanks
GandhiSivakumar
ProjectManager
NM-Research,
MBT,India
----- Original Message -----
From: Rg
To: [email-masked]
Sent: Monday, March 21, 2005 10:09 AM
Subject: Presence -Watcher clarification

Hi

Greetings!

Can any VOIP -Presence Agent designer help me in clarifying the below issue?

This is  with reference to the Model for Presence and IM and related Info.

The watcher sends SUBSCRIBE Request to the Presence Agent and the Presence Agent sends Notification for any change observed in the presentity.
"In contrast the fetcher is interested only in the current status of the presentity ,it does not send SUBSCRIBE request" -in this context , what is the method invoked by the Fetcher (like the watcher invoking SUBSCRIBE method) ? Whom does it query?Does it query the Presence Agent? Or it has access to the registration database ?( Logically I affirm that the fetcher need not have access to the registration data base).Could any one help me in clarifying the issue?

Thanks and Regards
Gandhi Sivakumar(RG)
Project Manager
NM -Research
MBT,
INDIA

*********************************************************
Disclaimer:   
The contents of this E-mail (including the contents of the enclosure(s) or attachment(s) if any) are privileged and confidential material of MBT and should not be disclosed to, used by or copied in any manner by anyone other than the intended addressee(s).   In case you are not the desired addressee, you should delete this message and/or re-direct it to the sender.  The views expressed in this E-mail message (including the enclosure(s) or attachment(s) if any) are those of the individual sender, except where the sender expressly, and with authority, states them to be the views of MBT.

This e-mail message including attachment/(s), if any, is believed to be free of any virus.  However, it is the responsibility of the recipient to ensure that it is virus free and MBT is not responsible for any loss or damage arising in any way from its use
     
********************************************************

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 06 Apr 2005 23:15:11 -0400

These topics are being discussed in the simple working group. I'd 
suggest you direct future queries there as they are likely to result in 
a faster response.

To briefly answer your question, a SUBSCRIBE is also used to query. The 
Expires header field is set to zero. This tells the presence server to 
send a NOTIFY with the current state and then terminate the subscription 
immediately.

-Jonathan R.

Rg wrote:

> *From:* Rg <mailto:[email-masked]>
> *To:* [email-masked] <mailto:[email-masked]>
> *Sent:* Monday, March 21, 2005 10:09 AM
> *Subject:* Presence -Watcher clarification
> 
> Hi
>  
> Greetings!
>  
> The watcher sends SUBSCRIBE Request to the Presence Agent and the 
> Presence Agent sends Notification for any change observed in the presentity.
> "In contrast the fetcher is interested only in the current status of the 
> presentity ,it does not send SUBSCRIBE request" -in this context , what 
> is the method invoked by the Fetcher (like the watcher invoking 
> SUBSCRIBE method) ? Whom does it query?Does it query the Presence Agent? 
> Or it has access to the registration database ?( Logically I affirm that 
> the fetcher need not have access to the registration data base).Could 
> any one help me in clarifying the issue?
>  
> Thanks and Regards
> Gandhi Sivakumar(RG)
> Project Manager
> NM -Research
> MBT,
> INDIA
> The contents of this E-mail (including the contents of the enclosure(s) 
> or attachment(s) if any) are privileged and confidential material of MBT 
> and should not be disclosed to, used by or copied in any manner by 
> anyone other than the intended addressee(s). In case you are not the 
> desired addressee, you should delete this message and/or re-direct it to 
> the sender. The views expressed in this E-mail message (including the 
> enclosure(s) or attachment(s) if any) are those of the individual 
> sender, except where the sender expressly, and with authority, states 
> them to be the views of MBT.
> 
> This e-mail message including attachment/(s), if any, is believed to be 
> free of any virus. However, it is the responsibility of the recipient to 
> ensure that it is virus free and MBT is not responsible for any loss or 
> damage arising in any way from its use
> 
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com