Subject: RE: Last Call: 'Requirements for IETF Draft Submission Toolset' toInformational RFC

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Fri, 8 Apr 2005 15:01:21 +0200

Elwyn,

As one of those who still use M$Word when writing drafts, I can also
confirm the generic text driver problems. Actually, I have had to
patch the draft parser for each new Windows version. However, after
doing that, I am still fine with using Word for drafts, as I like
WYSIWYG, and have no problems with making sure myself what I have
actually put in the draft (when it comes to mandatory sections, etc).

In most cases when you ask people what tools they prefer, they will
answer that they prefer to use the one(s) they have been using before
and are familiar with. So some people prefer to use nroff, others
use XML, others MS Word, etc.

Thanks to the IETF principle of having txt being the official format,
people have the opportunity to use whatever tool they like when they
write drafts. That is excellent, and I hope we can keep that principle.

Cheers,
/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Elwyn davies
> Sent: den 8 april 2005 12:32
> To: 'Stewart Bryant'; 'Brian E Carpenter'
> Cc: 'Alex Rousskov'; 'Bruce Lilly'; [email-masked];
> [email-masked]; 'IETF TOOLS discussion'
> Subject: RE: Last Call: 'Requirements for IETF Draft 
> Submission Toolset'
> toInformational RFC
> 
> 
> FYI I am an ex-Word user, now fully converted to xml2rfc.
> 
> I thought Word was a convenient way to conform to Draft style 
> and handle
> revision control but was frustrated by the toolchain.  The 
> main problem I
> found was the badly broken 'Generic Text Printer' driver which has not
> worked properly for a number of versions of Word in my 
> experience. Symptoms
> include:
> - unilaterally changing the paragraph width so that it 
> outputs one character
> on each line starting from some random point in the document
> - unilaterally changing the fount height to a microscopic 
> value so that text
> is converted to a horizontal line in random paragraphs
> 
> Microsoft are in denial about these bugs.  Presumably there 
> is not much call
> for the Generic Text Printer. (I must admit I haven't 
> bothered to try it in
> my most recent version of Word, but I wouldn't hold my breath).
> 
> I am aware of other possible ways to get the ASCII output but 
> they are all
> just as flaky and tedious.
> 
> I'll live with the need for balanced tags (I am pretty adept 
> at detecting
> what has gone wrong by now) and some other minor irritations 
> for the sake of
> knowing that I won't end up fighting the tools when trying to 
> get a draft
> out close to the deadlines (when of course the random bugs noted above
> always strike!)
> 
> I know several other authors who have defected for similar reasons.
> 
> Regards,
> Elwyn
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of
> > Stewart Bryant
> > Sent: 08 April 2005 10:47
> > To: Brian E Carpenter
> > Cc: [email-masked]; Bruce Lilly; Alex Rousskov; 
> [email-masked]; IETF
> > TOOLS discussion
> > Subject: Re: Last Call: 'Requirements for IETF Draft 
> Submission Toolset'
> > to Informational RFC
> > 
> > I would also be interesting to know how many use Microsoft Word
> > to produce drafts.
> > 
> > Stewart
> > 
> > Brian E Carpenter wrote:
> > 
> > > Regardless of the interesting side-discussion about 'voting',
> > > what the toy shows after about a day is:
> > >
> > > prefer nroff: 8
> > > prefer xml:  37
> > > neither:      9
> > >
> > > which implies a few hundred abstentions, of course.
> > >
> > >    Brian
> > >
> > 
> > 
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ietf
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Elwyn davies" <[email-masked]>
Date: Fri, 8 Apr 2005 14:40:54 +0100

One big win with the xml2rfc toolchain is draft and rfc references.
 
Just musing...

With an appropriate set of styles it ought to be possible to make a
processor that turned .rtf files into xml2rfc source.  I did think about and
start work on a text draft to xml converter but it turned out to be very
hard work (too many heuristics).

That way you could get the best of both worlds... more or less WYSIWYG 
Construction for the bulk of the text and pictures, auto-insertion of
boilerplate and some way to leverage the references stuff in xml2rfc.

Regards,
Elwyn

> From: Lars-Erik Jonsson (LU/EAB) [mailto:[email-masked]]
> Sent: 08 April 2005 14:01
> To: Elwyn davies; Stewart Bryant; Brian E Carpenter
> Cc: Alex Rousskov; Bruce Lilly; [email-masked]; [email-masked]; IETF
> TOOLS discussion
> Subject: RE: Last Call: 'Requirements for IETF Draft Submission Toolset'
> toInformational RFC
> 
> Elwyn,
>

---

From: Bill Fenner <[email-masked]>
Date: Fri, 8 Apr 2005 10:13:25 -0700

> boilerplate and some way to leverage the references stuff in xml2rfc.

I've written a plugin for the XMLMind XML Editor that gives almost
WYSIWYG editing of xml2rfc documents.  See
http://rtg.ietf.org/~fenner/ietf/xml2rfc-xxe/ for a screenshot and
download info.

  Bill