Subject: RE: What's been done [Re: Voting (again)]

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Thu, 28 Apr 2005 09:30:42 +0200

> >  But I, Dave and ICAR blew the early review issue so far.)
> 
> Since this was an effort directly targeting quality and 
> timeliness -- and especially since early reviews seem to
> have succeeded at gaining IETF rough consensus as a Good
> Thing to do -- do you have an theory about the failure to 
> get this going, or better still, how to get it to succeed?

>From the ICAR review team page at
http://www.machshav.com/~icar/reviews/people/
one can observe that only two review requests were ever
submitted, and just one of these (a request submitted by me)
resulted in a review (by Bernard). The other requested
review, actually on Dave Crocker's list, is still pending.

So, it seems like WG chairs were not very interested in
getting help with early reviews, but I would not say this
is necessarily a failure without giving it more time. It
takes time to change mindsets, in the beginning you must
be regularly reminded about the availability of the
early cross-area review team. Not all documents would 
naturally benefit much from "WG external" early reviews,
and especially not every revision of a draft. The review I
got from Bernard was very useful, and I would be happy to
make use of this resource pool again, for some documents
at certain stages in the document development process.

Rgds,
/L-E, ROHC WG chair

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Pekka Savola <[email-masked]>
Date: Thu, 28 Apr 2005 10:37:51 +0300 (EEST)

> review, actually on Dave Crocker's list, is still pending.

This is not quite true.  There were _at least_ one or two additional 
requests, but they just didn't get included on the web page.

I certainly as WG co-chair submitted 2-3 of them, just to test the 
process, but unfortunately.. it didn't quite work out (see the other 
mail for a bit more).

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Dave Crocker <[email-masked]>
Date: Thu, 28 Apr 2005 09:26:46 -0700

>  So, it seems like WG chairs were not very interested in getting help with
>  early reviews, but I would not say this is necessarily a failure without
>  giving it more time. It

And therein lies a key point about fixing underlying problems.

We seem to be willing to give unproductive working groups YEARS to fail.  We 
do not seem to be giving process improvement efforts more than a few MONTHS to 
succeed. We do not seem to be willing to work on improving such efforts.  We 
would rather just declare them failures.

The SIRS design involved iterative review with an IETF working group or 
mailing list (I don't remember which) and substantial changes according to the 
feedback.

When we started it up it was early in a summer.  We got a nice round of 
registrations of reviewers, quickly.  However by early Fall, senior IETF 
participants were declaring it a failure!  As I recall, that included Brian.

Eventually the ICAR effort started.  It then took a year to re-invent 
essentially the same mechanism as SIRS, but with a politically correct 
acronym.  By that time, it was a nicely marginalized effort, with respect to 
other IETF "improvement" efforts.

It went for a few months, didn't show instant success, and was shut down.

1. The demotivating aspects of re-starting essentially the same efforts are 
significant.  The IETF has become a place that likes (Re-)Design by Committee, 
rather than taking an existing, reasonable design and making tweaks to it.

2. The distracting aspects of IETF Management's focus on administration rather 
than process semantics are significant.

3. The unwillingness to persist in an effort to improve process semantics 
ensures that we will never fix underlying problems.

  d/
  ---
  Dave Crocker
  Brandenburg InternetWorking
  +1.408.246.8253
  dcrocker  a t ...
  WE'VE MOVED to:  www.bbiw.net