Subject: RE: Last Call: 'Internet Code Point Assignments' to Proposed Stan dard

From: "Gray, Eric" <[email-masked]>
Date: Fri, 12 Aug 2005 13:20:10 -0400

Alexey,

	There is an AFI (Address and Format Identifier) that has
been allocated to IETF/IANA for several years. The intent is the 
same as for many other AFI assignments - to establish an NSAPA 
number space that belongs to some specific entity to be allocated 
as they see fit (subject to certain limits).

	Presumably, the IETF has experts sufficient to determine 
some form of "as they see fit".  I doubt that more than a little
further IANA action will ever be required for this number space, 
but I am reluctant to recommend imposing unnecessary restrictions
that may later need to be removed.

	At last check, there was a draft in the works that proposed
allocation of a block of "Internet Code Points" (ICP) to allow for
storage of certain address information in an NSAP format. The ICP
was specifically intended for NSAPA encodings that would "never be
seen on the wire."

	For some applications, the most obvious "experts" are the 
people who have decided to publish something they have been doing 
for some time - i.e. - the authors of any specific proposal under 
review.  In such cases, we would not ask any of the authors to 
subject the work to a further review (presumably the outcome would 
not depart very much from expected) and assigning anyone else to 
be an "expert" could be fairly arbitrary.

	I assume that this is essentially a restatement of your own
point.  That being the case, you should probably agree that a more
open review approach is likely to produce a better result.  

--
Eric

--> -----Original Message-----
--> From: Alexey Melnikov [mailto:[email-masked]]
--> Sent: Friday, August 12, 2005 11:29 AM
--> To: Brian E Carpenter
--> Cc: [email-masked]; [email-masked]; [email-masked];
--> [email-masked]; [email-masked]
--> Subject: Re: Last Call: 'Internet Code Point Assignments' 
--> to Proposed
--> Standard
--> 
--> 
--> Brian E Carpenter wrote:
--> 
--> > 2. IANA Considerations
--> >
--> >    ...
--> >    Remaining decimal values '2' through '9999' SHOULD be 
--> assigned on
--> >    an IETF consensus basis, with IANA consent.
--> >
--> > I don't understand "with IANA consent." Also SHOULD seems 
--> ambiguous.
--> > Suggest:
--> >
--> >    Remaining decimal values '2' through '9999' MUST be assigned on
--> >    an IETF Consensus basis [ref RFC 2434].
--> >
--> > but I wonder whether Expert Review wouldn't be sufficient? Do we
--> > really need to trouble the whole IETF for this?
--> 
--> IMHO, Expert Review would be sufficient, but does IETF have 
--> experts to 
--> review NSAPA allocations?
--> 
--> Alexey
--> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Gray, Eric" <[email-masked]>
Date: Fri, 12 Aug 2005 11:18:30 -0400

Pekka,

	While I personally am not directly involved in ATM
development any longer, Marconi develops, builds, sells 
and delivers ATM equipment on an on-going basis.

	I do not agree that there is anything to gain from
explaining why we do this in an RFC.  We do it because we
have customers willing to pay us for doing so.

--
Eric

--> -----Original Message-----
--> From: Pekka Savola [mailto:[email-masked]]
--> Sent: Friday, August 12, 2005 8:54 AM
--> To: Brian E Carpenter
--> Cc: [email-masked]; [email-masked]; [email-masked];
--> [email-masked]; [email-masked]
--> Subject: Re: Last Call: 'Internet Code Point Assignments' 
--> to Proposed
--> Standard
--> 
--> 
--> On Fri, 12 Aug 2005, Brian E Carpenter wrote:
--> >> Given RFC 4048, is there sufficient evidence that this 
--> would be useful to 
--> >> the operational (or any other) community ?
--> >
--> > My understanding is that the ATM world needs this.
--> 
--> Even the ATM forum has died, having been abandoned by the operators 
--> almost 10 years ago.  I doubt anyone is developing the technology 
--> anymore.  V4 and v6 work just fine with ATM SVCs and PVCs as it is. 
--> It might be useful to describe (in the draft if this goes 
--> forward) why 
--> exactly these code point assingments are needed.
--> 
--> (Your other editorial suggestions seem OK to me..)
--> 
--> -- 
--> Pekka Savola                 "You each name yourselves king, yet the
--> Netcore Oy                    kingdom bleeds."
--> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
-->