Subject: Re: Dynamic salting in encryption algorithms for peer to peer communication

From: Benyamin Nasution <[email-masked]>
Date: Mon, 29 Aug 2005 11:06:04 +1000

Dear Atul,

I have the same thought regarding dynamic techniques, in this case the 
encryption.
If you use a well known mathemtical formula, I think passive attackers 
may still have a chance to challenge it.

What if the encryption algorithm is made dynamic?
It means that each peer can update and upgrade peer's algorithm 
whenever required.

Regards,
Benny

-- 
====================================================
Benny B. Nasution
Peninsula School of Information Technology
Information Technology Faculty
Monash University
A U S T R A L I A
+61 401 230 818
+61 397 696 078
email: [email-masked]
====================================================

----- Original Message -----
From: Atul Sabharwal <[email-masked]>
Date: Sunday, August 28, 2005 7:28 pm
Subject: Dynamic salting in encryption algorithms for peer to peer
	communication
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
Generally, I have seen that people use PKI or static salts for encrypting
data e.g. password.
In case of peer to peer communication, would it be useful to use dynamic
salts derived from
known mathematical series e.g. Fibonacci series, Ramanajum number series.
The first
salt need not be item(1) of the list but a random item(N) out of a circular
series of M items.
 
This could be useful for VPN client/server from same vendor.  Web site /Java
Applet from
a company etc. 
 
Is SSL still more secure than dynamic salting for man in the middle attack ?
 
--
Atul
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Sun, 28 Aug 2005 23:20:24 -0400

>It means that each peer can update and upgrade peer's algorithm 

(a) this is off-topic for the IETF mailing list
(b) cryptography is a branch of applied mathematics, with a rich 
literature.  I suggest you consult it first, or at least ask your 
question on a cryptography mailing list or newsgroup.  Start at
http://www.faqs.org/faqs/cryptography-faq/.  (Well, it's dated at this 
point, but it will give you a hint of the flavor of modern cryptography.)

		--Steven M. Bellovin, http://www.cs.columbia.edu/~smb