Subject: Re: BCPs and STDs

From: Bob Braden <[email-masked]>
Date: Thu, 18 Aug 2005 14:14:59 -0700 (PDT)

*> 
  *> At 9:56 +0200 8/18/05, Brian E Carpenter wrote:
  *> >Ed,
  *> >
  *> >The IETF's publisher is the RFC Editor, so they maintain search
  *> >pages etc. at http://www.rfc-editor.org
  *> 
  *> ;) I'm a DNS person, I only do lookups, not searches.
  *> 
  *> >

Ed,

I am not sure what the distinction is, but perhaps in your terminology
we would more properly call it a "lookup engine".  So you have what
you desire.

RFC Editor/bb

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Nelson, David" <[email-masked]>
Date: Thu, 18 Aug 2005 17:24:32 -0400

> I am not sure what the distinction is, ...

A lookup typically returns either a single, exact match or a failure
message.  A search typically returns a [large] number of matches, of
varying degrees of exactitude.

---

From: Bob Braden <[email-masked]>
Date: Thu, 18 Aug 2005 14:46:11 -0700 (PDT)

*> 
  *> Try http://www.rfc-editor.org/rfcxx00.html for document categories
  *> 

This file is the online, current, version of the "Official Internet
Protocols" RFC (also STD 1) that were published periodically starting
in June 1984.  Thus, it omits Informational RFCs as well as all RFCs
that have been obsoleted.  The RFC and BCP indexes, OTOH, list all
RFCs/BCPs.

RFC Editor/bb

---

From: Bob Braden <[email-masked]>
Date: Thu, 18 Aug 2005 14:48:16 -0700 (PDT)

*> > 
  *> > I am not sure what the distinction is, ...
  *> 
  *> A lookup typically returns either a single, exact match or a failure
  *> message.  A search typically returns a [large] number of matches, of
  *> varying degrees of exactitude.  
  *> 

So, the RFC Editor search engine does both.

  *> 
  *> _______________________________________________
  *> Ietf mailing list
  *> [email-masked]
  *> https://www1.ietf.org/mailman/listinfo/ietf
  *>

---

From: "Yaakov Stein" <[email-masked]>
Date: Sun, 21 Aug 2005 10:15:45 +0200

> If I go to www.ietf.org and type "BCP 58" (including quotes) 
> into the search box, the first hit is the document itself 
> (RFC3233).  

But NOW the first hit is your email in the mail archive.

So the search is a quantum phenomenon,
and observation changes the results   :-)

Y(J)S