Subject: Dynamic salting in encryption algorithms for peer to peer communication

From: "Atul Sabharwal" <[email-masked]>
Date: Sun, 28 Aug 2005 02:28:29 -0700

Generally, I have seen that people use PKI or static salts for encrypting
data e.g. password.
In case of peer to peer communication, would it be useful to use dynamic
salts derived from
known mathematical series e.g. Fibonacci series, Ramanajum number series.
The first
salt need not be item(1) of the list but a random item(N) out of a circular
series of M items.
 
This could be useful for VPN client/server from same vendor.  Web site /Java
Applet from
a company etc. 
 
Is SSL still more secure than dynamic salting for man in the middle attack ?
 
--
Atul
_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: David Hopwood <[email-masked]>
Date: Sun, 28 Aug 2005 15:05:10 +0100

Atul Sabharwal wrote:
> data e.g. password. In case of peer to peer communication, would it be useful
> to use dynamic salts derived from known mathematical series e.g. Fibonacci
> series, Ramanajum number series.

No. Ask on the newsgroup sci.crypt for an explanation of why not; it's not
on-topic here.

-- 
David Hopwood <[email-masked]>