Subject: Re: Last Call: draft-chakrabarti-ipv6-addrselect-api (IPv6 Socket API for Address Selection) to Informational RFC

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 May 2007 09:51:50 +0200

Section 8 states

>    Applications MUST not set contradictory flags at the same time.

I think the document should specify what the API must do if
contradictory flags are set. That would be the normative MUST, not
the above statement of the obvious.

     Brian

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Jari Arkko <[email-masked]>
Date: Mon, 21 May 2007 13:47:45 +0300

Brian,

> the above statement of the obvious.

Thanks for your review, Brian!

I agree with the principle that you state above. However,
the document does have a definition of contradictory
flags (Section 2) and explicitly describes what the API
must do when getting them (Section 6) i.e., causes
error EINVAL. Or EAI_BADEXTFLAGS for getaddrinfo
(Section 7).

I do agree though that there's something wrong in the
text in Section 10 about application requirements.
Perhaps s/MUST not/should not/. This may apply to
some other text in Section 10, too.

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 May 2007 13:23:58 +0200

> error EINVAL. Or EAI_BADEXTFLAGS for getaddrinfo

Ah, sorry, I'd missed that.

> some other text in Section 10, too.

Yes, I think it is strange to use the normative words
in this way.

     Brian

-- 
NEW: Preferred email for non-IBM matters: [email-masked]