Subject: RE: Reforming the BOF Process (was Declining the ifare bof for Chicago)

From: Bernard Aboba <[email-masked]>
Date: Sun, 17 Jun 2007 15:44:34 -0700

> (1) Unless things have changed since I was last paying careful> attention, the process you describe is used to adding a new> project to an existing technical committee. 
 
It can be used to form a new sub-group (e.g. IEEE 802.11z), or to form a new group (e.g. IEEE 802.21).  
 
> (2) I don't have statistics, but my impression is that most> technical standards work in the IEEE these days (not just in> 802, but more broadly) starts with a proposal to standardize a> specific industry technology. Those proposals are debated and> refined, but the assumption is that little fundamental> engineering or design work is done in the standardization> process. 
 
I don't think that holds true any more.  Groups such as IEEE 802.11s or 11n are doing quite a big of engineering/design work. 
> (3) Adding a study group creation process and a study group process> to the existing opportunities for delay would not contribute to> speeding things up. Indeed, it would do much the contrary.
 
It was not suggested that study group formation be required.  If a first
BOF demonstrates interest as well as making progress on the charter, then
it would be best to form the WG right away.  The problem happens with BOFs
that demonstrate interest, but where more time is needed to develop the charter. 
Experience shows that in this case the BOF process can drag on with no intermediate
feedback, accountability or clear process for resolution, sometimes for years.  In some
cases, the WG took more time to be chartered than it took to complete the work 
itself!
> (4) Suppose, instead, we were to permit WGs to be set up on a provisional> basis, with intense review after some reasonable period of time> and cancellation if they were not performing adequately and> producing results the community seemed to care about. This> would combine some of the advantages of IEEE-like study groups> with a streamlined process that focused on the one true mFrom [email-masked] Mon Jun 18 10:43:02 2007
From: Bernard Aboba <[email-masked]>
To: John C Klensin <[email-masked]>, <[email-masked]>
Date: Sun, 17 Jun 2007 15:44:34 -0700
Importance: Normal
Cc: 
Subject: RE: Reforming the BOF Process (was Declining the ifare bof for
 Chicago)

> (1) Unless things have changed since I was last paying careful> attention, the process you describe is used to adding a new> project to an existing technical committee. 
 
It can be used to form a new sub-group (e.g. IEEE 802.11z), or to form a new group (e.g. IEEE 802.21).  
 
> (2) I don't have statistics, but my impression is that most> technical standards work in the IEEE these days (not just in> 802, but more broadly) starts with a proposal to standardize a> specific industry technology. Those proposals are debated and> refined, but the assumption is that little fundamental> engineering or design work is done in the standardization> process. 
 
I don't think that holds true any more.  Groups such as IEEE 802.11s or 11n are doing quite a big of engineering/design work. 
> (3) Adding a study group creation process and a study group process> to the existing opportunities for delay would not contribute to> speeding things up. Indeed, it would do much the contrary.
 
It was not suggested that study group formation be required.  If a first
BOF demonstrates interest as well as making progress on the charter, then
it would be best to form the WG right away.  The problem happens with BOFs
that demonstrate interest, but where more time is needed to develop the charter. 
Experience shows that in this case the BOF process can drag on with no intermediate
feedback, accountability or clear process for resolution, sometimes for years.  In some
cases, the WG took more time to be chartered than it took to complete the work 
itself!
> (4) Suppose, instead, we were to permit WGs to be set up on a provisional> basis, with intense review after some reasonable period of time> and cancellation if they were not performing adequately and> producing results the community seemed to care about. This> would combine some of the advantages of IEEE-like study groups> with a streamlined process that focused on the one true measure> of whether a WG could produce useful work: starting it up and> seeing if it produced useful work. 
 
I agree that that rather than attempting to predict whether a WG will 
produce useful work, it is better to get real data by examining the WG
in action.  
> Since decisions as to whether to charter a WG are somewhat> subjective and the IESG has broad discretion, this is a change> the IESG could institute --experimentally or permanently-- on> its own initiative without our spending energy on changing the> processes. 
 
Indeed.  The same is true of the "Study Group" concept -- the IESG
can charter a WG for the purpose of writing a problem statement or
refining a future charter, at its discretion. 
 
> Its success would, however, depend on a change of> attitude in the community: today, so much effort goes into the> charter process because it has become almost impossible, in> practice, to kill off a non-performing WG or to put a tight> leach on one that is wandering in the weeds. 
 
The IETF seems to invest most of its effort at the beginning (the BOF process)
and at the end (IESG review).   Neither investment seems to be very effective. 
At the beginning, the BOF process has been called a "blood sport"; at the end,
a "death by a thousand cuts".  I had not considered the leach analogy before,
but perhaps there is something there ;)

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Clint Chaplin" <[email-masked]>
Date: Mon, 18 Jun 2007 19:10:44 -0700

On 6/17/07, Bernard Aboba <[email-masked]> wrote:
>
>  > (1) Unless things have changed since I was last paying careful
> > attention, the process you describe is used to adding a new
> > project to an existing technical committee.
>

Well, let's be really clear here.  802 is a horse of a different
color, unlike any other project IEEE has going.  Unfortunately, it's
the model we are all most used to.

802 is the original project, and still exists in the form of the 802
Executive Committee.  All 802 groups (802.11, 802.1, 802.3), exist as
a sub working group under 802.  Some of these sub working groups have
themselves spun off sub groups of their own (802.11 TGr, 802.11 TGT,
etc.).

I've never seen the process of starting a whole new project within
IEEE; I'm not sure a study group is required, or even done.

>
>  > (2) I don't have statistics, but my impression is that most
> > technical standards work in the IEEE these days (not just in
> > 802, but more broadly) starts with a proposal to standardize a
> > specific industry technology. Those proposals are debated and
> > refined, but the assumption is that little fundamental
> > engineering or design work is done in the standardization
> > process.
>
>  I don't think that holds true any more.  Groups such as IEEE 802.11s or 11n
> are doing quite a big of engineering/design work.
>
> > (3) Adding a study group creation process and a study group process
> > to the existing opportunities for delay would not contribute to
> > speeding things up. Indeed, it would do much the contrary.
>
> > (4) Suppose, instead, we were to permit WGs to be set up on a provisional
> > basis, with intense review after some reasonable period of time
> > and cancellation if they were not performing adequately and
> > producing results the community seemed to care about. This
> > would combine some of the advantages of IEEE-like study groups
> > with a streamlined process that focused on the one true measure
> > of whether a WG could produce useful work: starting it up and
> > seeing if it produced useful work.
>
> > Since decisions as to whether to charter a WG are somewhat
> > subjective and the IESG has broad discretion, this is a change
> > the IESG could institute --experimentally or permanently-- on
> > its own initiative without our spending energy on changing the
> > processes.
>
>  > Its success would, however, depend on a change of
> > attitude in the community: today, so much effort goes into the
> > charter process because it has become almost impossible, in
> > practice, to kill off a non-performing WG or to put a tight
> > leach on one that is wandering in the weeds.
>

-- 
Clint (JOATMON) Chaplin
Principal Engineer
Corporate Standardization (US)
SISA

---

From: John C Klensin <[email-masked]>
Date: Tue, 19 Jun 2007 01:20:50 -0400

--On Monday, 18 June, 2007 19:10 -0700 Clint Chaplin
<[email-masked]> wrote:

> Well, let's be really clear here.  802 is a horse of a
> different color, unlike any other project IEEE has going.
> Unfortunately, it's the model we are all most used to.

I've heard it described as a camel of a different color, and I
think you will find and levels of familiarity vary, but yes.

> 802 is the original project, and still exists in the form of
> the 802 Executive Committee.  All 802 groups (802.11, 802.1,
> 802.3), exist as a sub working group under 802.  Some of these
> sub working groups have themselves spun off sub groups of
> their own (802.11 TGr, 802.11 TGT, etc.).
 
> I've never seen the process of starting a whole new project
> within IEEE; I'm not sure a study group is required, or even
> done.

I just got curious and checked the IEEE-SA web site to see how
much their procedures had changed since I was an ex-officio
member of the Standards Board.  The answer appears to be that
there are a few more hoops to jump through, a new organization
specifically charged with doing in depth PAR (Project
Authorization Request) review and several new requirements on
PARs.  PARs correspond more or less to Charters in the IETF and
to New Work Item (NWI) proposals in ISO.  Getting a PAR even to
the stage of acceptance for review requires a sponsoring body
within the IEEE: if no one is interested, the effort to develop
a PAR is dead (I trust that sounds familiar).

And, incidentally, approved PARs expire after four years.  One
can request an extension, but projects that aren't going
anywhere time out, expire, and disappear.  That is something
that has been proposed and discussed several times around the
IETF but has never gotten anywhere, the actions of a few
tough-minded ADs notwithstanding.

More at
http://standards.ieee.org/resources/development/index.html

This is very subjective, but I think that, if one compares
setting up entirely new projects and WGs to our chartering
process, the IEEE process is more rigorous and probably takes
longer.

    john

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 19 Jun 2007 09:49:46 +0200

On 2007-06-18 00:44, Bernard Aboba wrote:
...
> but perhaps there is something there ;)

I've always believed that WG chartering is the single most important
action the IESG takes (with significant input from the IAB),
so to me the up-front effort is absolutely justified. If we charter
an effort that is going to take several years, we are committing
a lot of resources and maybe setting a major technology direction,
way beyond the IETF community itself. So that doesn't bother
me. If we can make the process more comprehensible and clear,
so much the better.

As for the back end issue, well, we can only change that if we
get more early and ongoing review. As long as documents continue
to emerge from WGs with significant issues of clarity, interoperability,
etc, what else is going to happen? I've seen IESG review from both
sides and the middle, and it's mainly about quality control.

     Brian

0.45])
	by mx.google.com with ESMTP id 54sm953386ugp.2007.06.19.01.51.07
	(version=SSLv3 cipher=RC4-MD5); Tue, 19 Jun 2007 01:51:08 -0700 (PDT)
Date: Tue, 19 Jun 2007 09:49:46 +0200
From: Brian E Carpenter <[email-masked]>
To: Bernard Aboba <[email-masked]>
Cc: John C Klensin <[email-masked]>, [email-masked]
Subject: Re: Reforming the BOF Process (was Declining the ifare bof for
	Chicago)

On 2007-06-18 00:44, Bernard Aboba wrote:
...
> but perhaps there is something there ;)

I've always believed that WG chartering is the single most important
action the IESG takes (with significant input from the IAB),
so to me the up-front effort is absolutely justified. If we charter
an effort that is going to take several years, we are committing
a lot of resources and maybe setting a major technology direction,
way beyond the IETF community itself. So that doesn't bother
me. If we can make the process more comprehensible and clear,
so much the better.

As for the back end issue, well, we can only change that if we
get more early and ongoing review. As long as documents continue
to emerge from WGs with significant issues of clarity, interoperability,
etc, what else is going to happen? I've seen IESG review from both
sides and the middle, and it's mainly about quality control.

     Brian