Subject: RE: Reforming the BOF Process (was Declining the ifare bof for Chicago)

From: Bernard Aboba <[email-masked]>
Date: Fri, 15 Jun 2007 11:03:10 -0700

I agree that the "5 criteria" are not necessarily applicable to the IETF.  However, I think that providing the Study Group with explicit WG formation criteria at its inception is useful, whatever that criteria may be.   That way all parties understand what the Study Group is expected to accomplish, and how its success will be judged. 
 
With respect to measuring interest, it is true that the IETF is more informal, but I do think that it would help to be more explicit about what we mean by "interest".  For example, with respect to Study Group formation, we are talking about interest in the Study Group, on the part of potential participants in that Study Group.  Determining interest in a potential WG would put off until later and would be gauged based on Study Group participation and review of Study Group documents, including the Charter. 

Subject: RE: Reforming the BOF Process (was Declining the ifare bof for Chicago)Date: Fri, 15 Jun 2007 12:22:01 +0200From: [email-masked]: [email-masked]; [email-masked]

Bernard,
 
Speaking as a participant in both the IETF and IEEE 802, there are many things that I like in the CFI / Study Group process of IEEE. Your proposal goes in the direction of solving one of the problems I perceive in the IETF processes which is the lack of repeatability and predictability (again speaking as a participant). I like it. Yet, there are some differences:
 
- The five criteria in the IEEE would not apply as is. I am not sure that 'broad market potential' should be there at all, or should be as strong a factor as it is in the IEEE. Same with economic feasibility, which in the IEEE often refers to the costs of hardware based implementations
- 'Measuring interest' works differently in the IETF than in the IEEE which is very much physical participation based, and where participants and company votes are dully counted and registered in CFI meetings as proof of interest.  
 
Dan

From: Bernard Aboba [mailto:[email-masked]] Sent: Tuesday, June 12, 2007 7:52 PMTo: [email-masked]: Reforming the BOF Process (was Declining the ifare bof for Chicago)
The recent discussion on the IFARE BOF has raised more fundamental issuesabout the IETF BOF process.  Rather than letting discussion continue on theSAAG list, it would seem better for this discussion to occur on the IETF list. > Speaking as a former AD, it can be a very tough call to say yes/no to> a BOF. Unfortunately, there is often interest, but interest is most  > definitely not enough. There needs to be more than interest. It should be understood that this is a feature of the IETF process that isnot necessarily held in common with other SDOs.For example, within IEEE 802 the initial meeting is termed a "Callfor Interest" because the determination of interest is the major focus;writing a charter/PAR is not.                                                                                   Assuming that sufficient interest exists, a study group is formed, whosesole purpose is to write a Project Authorization Request (PAR)(equivalent of a charter), and demonstrate that the proposed worksatisfies the "5 criteria":1. Broad Market Potential  a. Broad sets of applicability.  b. Multiple vendors and numerous users.  c. Balanced costs2. Compatibility with existing standards.3. Distinct Identity.4. Technical feasibility  a. Demonstrated system feasibility  b. Proven technology, reasonable testing  c. Confidence in reliability5. Economic Feasibility> There needs to be a reasonable chance of a positive, forward-moving> outcome.I believe that this ascribes more predictive value to the BOF process thanis warranted by experience.  Quite a few deployed technologies  haveoriginated from BOFs that the IESG judged to not have a likely "forward-movingoutcome", while many unproductive working groups arose from successful    BOFs.   The reality is that BOFs do not much have predictive value, if onlybecause the BOF process does not much resemble the WG process, so thatthe success dynamics cannot easily be ascertained as a result. > Yes, I* opinions are afforded special status. They are our chosen  > leadership, and with leadership comes responsibility. Responsibility> to be sure that if the work goes forward, it is well scoped, has a> reasonable likelihood of success, etc. And please remember, the IETF> is a meritocracy. So please don't raise the "I* has special status"> issue as if it were some kind of unfair or biased way of doing things.Again, the IESG role in the BOF process represents a choice on the part of the IETF.  It is possible to envisage other approaches that could yieldoutcomes as good or better while providing better accountability andtransparency. For example, by restricting the function of an initial BOF to a determination ofinterest and a decision to form/not form a study group,  the opportunitiesfor unfairness and bias can be reduced.  Once the study grouphad produced a charter and documentation of the formation criteria, the reviewof these documents could proceed with more information than is typicallyavailable as the result of a (potentially delayed) 2nd BOF.   Also, the review could utilize existing procedures for ensuring transparency andaccountability, such as an open review process and documentation ofDISCUSS comments. 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 18 Jun 2007 11:45:05 -0400

In many cases, we do this in any event, just via a more heavy-weight  
process, namely by requiring working groups to go through a process  
of requirements, frameworks, architecture and other meta-documents.  
One can discuss how successful these have been compared to the effort  
expended, but moving this process earlier seems helpful, as it now  
follows a fairly drawn-out bar BOF -- scheduled meeting-that's-not- 
called-a-BOF -- real BOF -- IESG deliberation -- WG formation  
process. In other words, having a low-cost version that allows people  
to discuss the problem, without committing to a solution, would be  
helpful.

On Jun 15, 2007, at 2:03 PM, Bernard Aboba wrote:

> I agree that the "5 criteria" are not necessarily applicable to the  
> IETF.  However, I think that providing the Study Group with  
> explicit WG formation criteria at its inception is useful, whatever  
> that criteria may be.   That way all parties understand what the  
> Study Group is expected to accomplish, and how its success will be  
> judged.
>
> With respect to measuring interest, it is true that the IETF is  
> more informal, but I do think that it would help to be more  
> explicit about what we mean by "interest".  For example, with  
> respect to Study Group formation, we are talking about interest in  
> the Study Group, on the part of potential participants in that  
> Study Group.  Determining interest in a potential WG would put off  
> until later and would be gauged based on Study Group participation  
> and review of Study Group documents, including the Charter.
>