Subject: Re: IANA registration constraints (was: Re: Withdrawing sponsorship...)

From: Bob Braden <[email-masked]>
Date: Wed, 13 Jun 2007 11:58:00 -0700 (PDT)

John Klensin,

You wrote:

  *> 
  *> I think real specifications of what the requested parameter will 
  *> mean and be used for are important.  I think there is a 
  *> difference between registering a parameter for a non-standard 
  *> specification that is already deployed and in successful use and 
  *> registering one for a wild idea by one person.

I would note that the purveyors of a "non-standard specification that
is already deployed and in successful use" must have somehow obtained
their own number assignment without the IANA's help, or this situation
could not arise.  And before that specification was successfully
deployed, it may well have been "a wild idea".

There seems to be a logical disconnect here.  What am I missing?

Bob Braden

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Wed, 13 Jun 2007 21:34:43 +0200

Bob Braden writes:
> their own number assignment without the IANA's help, or this 
> situation could not arise. And before that specification was 
> successfully deployed, it may well have been "a wild idea".
>

Cases like managesieve. Managesieve is almost a decade old and in real 
use at many sites. Tens of thousands? Even more? No idea.

The port it uses was allocated to another purpose about four years after 
managesieve was deployed.

Arnt

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 13 Jun 2007 13:02:06 -0700

I think that folk should decide where the scope of the IETF starts and ends.

The message I think that the IETF should be sending is 'we own layer 6 and everything below'. I don't think that many people are really wanting to perpetrate unauthorized innovations in those layers in any case.

In order to defend layer 6 and below the IETF should surrender all control at layer 7 and above.

I don't think we can do the second while we still consider port number allocations to be the prinicpal means of protocol discovery. And to support machine to machine protocols effectively we require a policy layer.

> -----Original Message-----
> From: Bob Braden [mailto:[email-masked]] 
> Sent: Wednesday, June 13, 2007 2:58 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: IANA registration constraints (was: Re: 
> Withdrawing sponsorship...)
> 
> 
> 
> John Klensin,
> 
> You wrote:
> 
>   *>
> I would note that the purveyors of a "non-standard 
> specification that is already deployed and in successful use" 
> must have somehow obtained their own number assignment 
> without the IANA's help, or this situation could not arise.  
> And before that specification was successfully deployed, it 
> may well have been "a wild idea".
>

---

From: Tony Finch <[email-masked]>
Date: Wed, 13 Jun 2007 21:56:30 +0100

On Wed, 13 Jun 2007, Arnt Gulbrandsen wrote:
> use at many sites. Tens of thousands? Even more? No idea. The port it
> uses was allocated to another purpose about four years after managesieve
> was deployed.

The smtps port was reallocated too, but Microsoft's MUAs still don't
support SMTP+STARTTLS on ports other than 25 and insist on smtps.
Postmasters have to just shrug and continue to use port 465 for this
purpose. OS vendors can't use the IANA port number list without patches.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
SOUTH FITZROY: SOUTHWEST 5 TO 7. MODERATE OR ROUGH. OCCASIONAL RAIN. MODERATE
OR GOOD.

---

From: John C Klensin <[email-masked]>
Date: Wed, 13 Jun 2007 17:30:43 -0400

--On Wednesday, June 13, 2007 11:58 -0700 Bob Braden 
<[email-masked]> wrote:

>
>
> John Klensin,
>
> You wrote:
>
>   *>
>   *> I think real specifications of what the requested
> parameter will    *> mean and be used for are important.  I
> think there is a    *> difference between registering a
> parameter for a non-standard    *> specification that is
> already deployed and in successful use and    *> registering
> one for a wild idea by one person.
>
> must have somehow obtained their own number assignment without
> the IANA's help, or this situation could not arise.  And
> before that specification was successfully deployed, it may
> well have been "a wild idea".
>

In the instance at hand, the fact that this document was 
approved for publication on the standards track, and a parameter 
value allocated on that basis, before the IPR issues came up and 
the approval (and parameter value) were withdrawn.

In the more general case, yes, we are putting ourselves in a 
position that encourages inventing parameter values and 
squatting  on them.

      john

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 13 Jun 2007 15:00:45 -0700

> purpose. OS vendors can't use the IANA port number list without patches.

The application that 465 was allocated for, runs as an interception
proxy or routers so if you were actually to use URD, you break mail
clients communicating with exchange servers.

There's some serious brokenness in that whole debacle.